Why is there no Wifi?

Just received my phone. Is there some sort of trick to getting the wifi to work?

I have a pretty beefy Linksys wireless router that I have dozens of devices connected to, and it supports both 2.4 and 5 Ghz spectrums.

However, the Librem refuses to connect to either.

It’s not giving me any error. I enter my password, show it to confirm I’ve entered it correctly, then it shows a waiting animation, then then it disappears, but the wifi icon still shows disconnected.

The wifi switch on the side appears to be in the enabled position.

Is there anything else I need to do to get wifi working? This is very frustrating.

1 Like

Check the date/time on the phone and make sure it matches your router’s.

Check here:

1 Like

Check the system date and time. If it is not current, then go to settings > Details > Date and Time. And adjust it.

1 Like

I about this in the other thread. Do you have a clue why the date influences the wifi? I didn’t expect this. What has the date to do with wifi? The only idea I have is that datetime might be a parameter in PRNG and random numbers go into wifi crypto, but still doesn’t explain it.

I’m curious.

1 Like

Hello @prolog

I am by no means experienced with cells. Was never convicted :slight_smile: , but I have had date issues on desk and laptops. I think the date has to do with your ISP lease time, and the router/modem needing to be date synced for, well, syncing devices. Too, some web sites croak if I have a bad date on d/ltops that the server likes to have corrected.



Ah. Leasetimes could be possible. I wonder how they are modeled, as durations or with dates. Also I don’t remember if a date or index attribute is part of IP datagrams alias packages. Receiving stations might need such to process packages in order they were send which might be different from the order they are received.

Edit: IP packets have an “identification” attribute for sequencing packets which is not a date.

1 Like

No good. Even after I disable automatic date/time setting and manually correct the timezone and time, it still doesn’t connect.

Spoke too soon. The incorrect date/time was indeed the problem, but I only thought to fix the time. I didn’t notice the date was also wrong.

And there also appears to be a problem with the hardware clock. After I set the time manually, and then waited 30 minutes to set the date, the clock became 2 minutes behind, so it still didn’t work right away until I again had to fix the time.


Glad you got the wifi working.

When you say “hardware clock”, are you talking about the Clocks app? My time runs perfectly.

Maybe download all the waiting updates and see if it corrects itself. You can check for updates in the PureOS store, or do a sudo apt update in the terminal.

P.S. Do you have a SIM card inserted? (for time syncing to the network)
May not matter, though.

Does ntpq -p show that you’re connecting to NTP servers successfully?

I think it’s not the wifi as such, the wifi is actually working locally on the “link layer” but IP is not working. The problem is with DHCP, see this issue:

Same thing could happen with a wired connection, if you had that, I think.


Is a workaround, for the user, to choose to use a static IP address? (particularly if you only ever use the WiFi at home)

In any case, that might get past the DHCP issue and then you can use NTP to get the correct time.

But easier just to set the date/time manually.


It does :frowning: That’s how I noticed.


I think that should work, but then again that would require making changes on both the wifi access point (router) side and on the phone itself, so setting the date manually is probably easier. Once the date is set, you never need to worry about it again, as I understood it, then everything will work. It’s not like the problem comes back after reboot or anything, it’s just a one-time fix. Could be avoided if Purism had set the date before shipping the phone, @dos wrote something about trying to make that happen for shipments later on. Seems like a good idea to improve the first impression people get of their new phone.

1 Like

Pop off the back and take a picute for me after taking out the battery. I had the same issue weeks ago and have a hunch about how I fixed it. So let’s see if you might have the same issue.

I didn’t necessarily get that impression. The reference to “battery is dead enough for the RTC to reset” suggests that it could happen again and, while power consumption remains high, could happen frequently if you are not careful to charge up before it’s too late - unless the time keeping has some kind of fallback.

One concern would be that for phones going overseas, it takes so long for the phone to reach the customer that the battery is flat before the customer gets it, particularly at this time of year.

Not really. Provided that there is a portion of the IP address space (in the subnet) that is not used by DHCP, you can just set an IP address in the non-DHCP range and away you go.

A different approach would be to reject any saved time coming from the RTC that will cause the error “Unable to set up timer: out of range”. To know that however would require knowing what interface is being used to set the timer and what its limitations are - and changing the code in the future if those limitations are removed. (Is this an early manifestation of the 2038 problem or of the 2106 problem?)


For reference, I had periods over the past couple months where the L5 stayed unconnected for months, and it wasn’t enough to trigger the RTC reset. in fact I don’t remember the last time this happened, and I’m not very careful about the battery.


Is that because the battery reaches a level of flatness such that the phone dies but there is still plenty enough juice to run the RTC for perhaps months?