Wifi/bluetooth issues

I doubt this.

Probably a good idea.

2 Likes

Could you tell us how you proceeded? Thanks. And you seem to have a newer firmware than the one purism provides, can you give a download link of your version? Thanks.

2 Likes

Yes sure there are two ways to burn the image into the controller, i will tell you the easy way:
Put the rps file that you want burn to /lib/firmware/ then reboot, after reboot you can run ‘sudo dmesg | grep redpine’ just to see what are you burning… now delete the the rps file that you moved to /lib/firmware/ after deleted the all rps file from /lib/firmware/ then reboot again, when you booting you will see the new firmware already burned.
Regarding for the new top firmware that i burned i taked from @dos repos, it is a testing firmware, i tested yesterday but it has same bug like you say, that if BT is ON WLAN stop working, so your issues regarding that if bt working then wifi not working it is not that your Librem 5 has any hardware malfunction, it is just Bugs so you can testing all firmware and which it working better.

1 Like

Thanks. This is they way I did several times. Thanks for confirming that you had the same bug when bluetooth on, and strange that @guru confirmed that wifi+bt work for him at the same time. Here is the repository with several firmwares for the redpine wifi/bt card.

1 Like

Remember that @guru it is a guru which everything will work good. :joy:
@guru said that the BT it worked for him but diferent bt profiles like for keyboard and touchpad i tested with other bt-profiles like AD2P which seems broke the wifi card.

Yes that is the repos for newer redpine firmware but remember to rename because it not match for the burner.

2 Likes

WiFi and Bluetooth work for me at the same time. So you don’t have to be a @guru. :wink:

I can have two terminals going at once.

  1. SSH in from a local desktop with the Librem 5 connected to the local LAN via WiFi.
  2. Terminal open on the Librem 5 but driving the Librem 5 with a Bluetooth combined mouse/keyboard

and Bluetooth speakers connected as well!

So this may be a regression, as I am still on amber and have not updated the WiFi/BT card firmware as far as I am aware. For me /lib/firmware does not even exist as a directory or file (as is expected if you have never attempted to update the WiFi/BT card firmware).

But you will also note that I am using operating mode 13 (by default, it’s not something that I have chosen).

It does seem a bit flaky in the sense that use of the BT keyboard seems to interfere with music playback. However that may be because keyboard events are going to Lollypop rather than the local terminal. (A complication is that the BT keyboard is critically low on power and is on charge - and the Librem 5 keeps on popping up notifications about the keyboard having 0% battery, which may be approximately right.)

Even then the SSH session in via WiFi is maintained and continues to work properly i.e. typing commands in the SSH session while music playback on Bluetooth speakers continues without glitches in the background.

If it matters, the mouse/keyboard claims to be Bluetooth 2.0 (on its packaging) while the speakers claim to be Bluetooth 5.0 (on the seller’s web site). I don’t know how to check either from the Librem 5 itself.

redpine_91x: rsi_load_firmware: Loading file RS9116_NLINK_WLAN_BT_IMAGE.rps
redpine_91x: rsi_load_firmware: Failed to open file RS9116_NLINK_WLAN_BT_IMAGE.rps
redpine_91x: ***** Loaded Firmware *****
redpine_91x: ================================================
redpine_91x: ================ RSI Version Info ==============
redpine_91x: ================================================
redpine_91x: FW Version	: 1.2.20.0
redpine_91x: RSI FW Version	:  0000.1.2.0.0502
redpine_91x: Driver Version	: RS9116.NB0.NL.GNU.LNX.OSD.2.0.0.0024
redpine_91x: Operating mode	: 13 [Wi-Fi STA + BT DUAL]
redpine_91x: Firmware file	: RS9116_NLINK_WLAN_BT_IMAGE.rps
redpine_91x: ================================================

(and from /etc/modprobe.d/librem5-devkit.conf pertinent? lines)

blacklist rsi_91x
blacklist rsi_sdio
options redpine_91x dev_oper_mode=13 rsi_zone_enabled=1 antenna_diversity=1
1 Like

I have tested the following firmwares: 1.2.20, 2.0.0.24, 2.3.2.3 and I came to the following results:

  • wifi and bluetooth do not work at the same time (from 2.0 onwards)
  • wifi is slow (up to 1.2.20) and has full speed (from 2.0 onwards)
  • bluetooth (audio) is very choppy (up to 1.2.20) and only a bit choppy (from 2.0 onwards)

So, wifi and bluetooth work at the same time up to 1.2.20, but with the cost that wifi is slow (max. 9.5Mbit) and bluetooth is very choppy, for audio not really useable. There may be further errors/shortcomings you get by downgrading to 1.2.20.

So with the available firmwares the youtube-PR from purism seems to be a hoax. They use shortwave, an internet radio and a bluetooth connection to “Demo of using Bluetooth on the Librem 5”. If they used a firmware up to 1.2.20 bluetooth audio would have to be choppy, if they used a firmware from 2.0 onwards wifi connection would have to be down so shortwave could not have played music.

My questions to purism and developers (@dos) are:

  • are these errors in the firmware known?
  • is there any chance that they will get fixed in the not so far future?
  • is there a bug tracker for these issues?
  • who writes the firmware code, the community/purism or redpine?
  • which firmware was used in the above mentioned youtube-clip? Since this version seems to work.

By the way, I would like to say thank-you to everybody helping here in the forum. Now, I will tackle my gps, calling and power issues.

2 Likes

You not tested FW version: 3.2.2.16 ?
I remembered que Redpine firmware has issues with BT LE so i wil see this config if i get work bt/wlan.

Yep, sorry for the confusion, I tested this one, too. On this site they call the 3.2.2.16 with “RS9116_NLINK_WLAN_BT_IMAGE.FW2.3.2.3.rps”. I stuck to the naming convention on that site.

1 Like

@dos @angus.ainslie @guido.gunther there is a new driver for Redpine: https://github.com/SiliconLabs/RS911X-nLink-OSD/blob/master/ReleaseNotes_OSD.pdf

1 Like

On the driver side there as some changes for STA + AP mode on then some BT driver fixes. I have not tried integrating those into our tree.

I have tested the updated FW and it does not work with the mainline driver and I see no really improvement with the proprietary driver but my testing has been limited so far.

2 Likes

Thanks @carlosgonz. Perhaps this issue is fixed? They write

Bluetooth
- Added a fix to initiate AFH periodically to resolve the BT and Wi-Fi hang issue.
- Resolved the Wi-Fi ping issue that used to occur while connecting to BT in CoEx Mode in the CC0/AA0 modules based on chip version 1.3
1 Like

Yeah @pit maybe we get WLAN and WPAN working together and more fixes on general including powersave. :cowboy_hat_face:

Thanks from my side (as well), done!

@pit your postings are important (and inspiring :blush: to me), so here few things that are related to: sudo journalctl -b | grep 'Operating mode', as @guido.gunther wrote for public use:

where val:
          13 - Wi-Fi station + BT dual mode
          14 - Wi-Fi AP + BT dual mode

As well (as written within Page 9) explained here:

And this post (thread) is additionally explained how to: Bluetooth not found but service runs no default controller. Just replaced current one (see two red marked lines, as linked, I removed dev_oper_mode=5 line) + wlan_rf_power_mode=0x00:
options redpine_91x dev_oper_mode=13 rsi_zone_enabled=1 antenna_diversity=1 wlan_rf_power_mode=0x00

For above working changes, I’ve used sudo/root rights over JumpDrive connection. Please make backup of the original .conf file, as first step (simply add BKP folder over there, in order not to change owner, and copy+rename original file …).

Partially proofed with:
cat /sys/module/rsi_91x/parameters/rsi_zone_enabled
1

@pit, I’m not there yet (not for real), but still wanted to give some direction that should help you with your BT issue. Take care.

2 Likes

Not for me. “music playback on Bluetooth speakers continues without glitches in the background” It was not choppy. It was definitely usable. For clarity: I was playing something off the uSD card, rather than playing something off the server, which would then be being accessed via WiFi.

Obviously there are a lot of variables e.g. Bluetooth version of speakers, data rate to speakers (in my case, stereo), specific make and model of speakers, whether Bluetooth Low Energy is a requirement, WiFi/BT card operating mode.

I haven’t tested WiFi speed. How did you test? iperf3 ? Obviously there are a lot of variables there too. For a start, 2.4 GHz v. 5 GHz.

That is presumably outside Purism’s control. Redpine Signals is at least just down the road from Purism though. :wink:

@irvinewade please share your: sudo dmesg | grep redpine i am fully tracking this bt chopping issue on L5R4

Slightly snipped output was already posted above yesterday. Anything specific that is missing from that output that you wanted to see?

It is not complete like oper_mode parameters.

I edited the post above to add more info. Is that what you wanted?

That fine thank you.