WIFI Connection Errors

I’m quoting the Community Wiki here to help new L5 owners find the solution more quickly:

WiFi Connection Problems: If the Librem 5 won’t connect to your network, verify that the phone’s date, time, and time zone (in Settings > Details > Date & Time are set correctly. At present, it’s necessary to turn off the automatic date/time settings and set these manually. After successful connection, you can return the settings to automatic. If you’re using MAC filtering on your router, don’t forget to allow your Librem 5 in the router settings first. Using hidden SSID on your router may cause intermittent disconnection.

1 Like

@amarok, this issue can easily be resolved by adding an additional screen for the first time startup. When selecting the language preferences there can be next screen that allows setting timezone. This will set the time as well.

I think the assumption that all the phones will have a SIM card at initial startup does not sound correct. So maybe, if Purism creates a new build for the initial startup settings there won’t be this issue at all. I am still waiting for @dos to respond back to my suggestion.

It does not look good when there are videos floating around when the reviewer says it does not connect to the WiFi network, does it?

1 Like

If I recall, I did have a setup dialog that included that, but I probably chose automatic date/time, which most people will probably choose, too. I hope that gets fixed soon, because you’re correct that some might not have a SIM inserted at initial setup.

And I don’t recall if my SIM was in or not. I tend to think that automatic still causes problems initially, even with a SIM inserted.

This reminds be of the HP3000 software that not only reads the HPSUSAN code, but also checked to make sure the clock was not set back to an earlier date, AND it also counted the number of processors it was licensed for.

Doesn’t it use NTP when there is a WiFi connection added during system setup? Should be the way to go, shouldn’t it? :thinking:

Not sure. :man_shrugging:

No. Take with grain of salt but:

WiFi connection (association) works fine.
Then it tries to DHCP.
DHCP fails horribly because the time is so borked.
So you never get an IP address.
So you definitely can’t use NTP (which would otherwise then fix the time).

FYI (although that was then, this is now) :thinking::

purism@pureos:~$ timedatectl status
Local time: Wed 2020-12-23 17:12:45 PST
Universal time: Thu 2020-12-24 01:12:45 UTC
RTC time: Thu 2020-12-24 01:12:45
Time zone: America/Los_Angeles (PST, -0800)
System clock synchronized: yes
NTP service: active
RTC in local TZ: no

This makes sense, given my experience on initial setup.

Correct me if I’m wrong but as far as I know wrong client times are zero problem with DHCP. Wouldn’t even make much sense to offer functionality for NTP servers when the client needs a nearly correct time in beforehand :sweat_smile: Never ever had problem with that. Maybe timezones are a problem.

Yes, grasshopper. :wink:

DHCP itself does not use absolute times. All times are relative, for the reason you imply. (Therefore no agreement on actual time between DHCP client and DHCP server is ever needed. They do need to have clocks that run at approximately the same rate but, depending on your DHCP server parameters, there can be a wide discrepancy even in rate.)

The problem appears to be in the DHCP client implementation. Refer: https://source.puri.sm/Librem5/OS-issues/-/issues/98


We have a fix in place, in the form of an additional test that catches this case where the time is far in the future that gets run along with the rest of our final quality control tests. It just didn’t make it into our workflow in time for a lot of the Librem 5s that got shipped so far.


Hey there, just flagging that wifi is only working intermittently for me. It seems to work on first boot for a few minutes before failing. At this point the network adapter is still visible (using sudo lshw -class network -short) but the device loses it’s internet connection and can no longer detect or connect to any wifi networks.

Toggling the wifi hardware switch off and on does not seem to restore functionality. Often when turning it back on the hardware doesn’t get detected by the system again.

Things I’ve tried so far:

  • Turned off Automatic Date Time and the time is set correctly.
  • I get the same behaviour whether a sim card (with data) is inserted or not.
  • Two different 2.4Ghz networks (one a router, one a mobile hotspot) both with the same behaviour. Though given it can’t even see networks when it fails I’m fairly sure it’s not the networks causing the problem.

Any suggestions for further debugging?

Do you hide your SSID? That caused intermittent disconnects for me.

WiFi is a pig to debug. (WiFi has become like network security protocols. There are so many options that the two ends are almost certain to be unable to agree on something critical. :slight_smile:)

Other things (i.e. other than hidden SSID) to look at:

  • the date has to be set correctly - the time won’t matter - maybe that’s what you meant
  • are you close to the router so as to ensure that you have a strong signal at all times?
  • has the antenna connector worked loose? (be very careful with checking / fixing this)
  • is the WiFi card being put into power save mode?
  • is the router selecting a channel width that is too wide? (for the 2.4 GHz band force the router to 20 MHz channel width)
  • do you have any 5 GHz band capability? - because that band is less likely to be subject to interference and/or congestion

None of these ideas exactly matches the symptoms however.

Typical Linux WiFi behavior makes it difficult to distinguish between associated with Access Point but didn’t get an IP address v. didn’t associate with the AP at all. You may want to jump on the router to see whether the L5 is listed as associated (whether or not it has an IP address).

Regardless, if you are having problems with WiFi, I would just use the hardware kill switch to keep the cellular modem off, so that you (and the L5) can focus on one thing.

I understand that it could be very difficult to address this but … do you have the latest up-to-date software?