Wifi networks problem


#1

although the wifi is on,it doesn’t show any networks
how do i solve this?


Wi-fi connection
#2

First I’d check if antennae cables are properly seated. Also try to move laptop straight under AP to see whether it catches the glimpse of the beacon.


#3

What product are we talking about?

For starters confirm that the WiFi interface exists with ifconfig


#4

more importantly iwconfig but i assumed ‘wifi is on’ means powered on and brought up.


#5

If using a Librem product, I would also check to make sure the hardware killswitch is set to allow Wifi.


#6

Lenovo ideapad 100
it had freedos,then Windows,and now it has Linux mint


#7

And this is under pureos on Purism’s support forum because?


#8

because with pureos on it the wifi doesn’t show any networks


#9

That is because by default PureOS does not load non-free drivers/firmware. You will need to locate your wireless chips firmware for linux and install it. Outside of Purism hardware, this is why I stick with Ubuntu. It does most of that for you.


#10

PureOS, only ships with Free Software, meaning that if your wifi requires proprietary firmware it won’t run.

I have an Ideapad 110-15 ACL, and i remember when i got it (like 2 and a half years ago) the wifi did not worked out of the box with Linux Mint at the time. So i installed Arch Linux :slight_smile:

If you want to run it with PureOS, my recommendation would be to run the command: lspci from the terminal to get a list of your hardware and wifi chip model and search for the corresponding firmware from the Debian Buster repositories, manually download it and install it in PureOS:

https://www.debian.org/distrib/packages


#11

Or replace the WiFi card with one that is freed - if that is possible.

Depends what the goal is.


#12

:heart_eyes:

Yes! That is also an option of course!


#13

i tried to install deb files,but it gets an error that says that the file or directory doesn’t exist
what should i do in this case?


#14

What are you using to attempt to install the .deb?

Most likely, if you downloaded the .deb file using your web browser, the file is probably in your downloads folder. If so, then you could install it with

sudo dpkg -i ~/Downloads/<name of file>.deb


#15

as i said,i can’t get internet,so i transfered them through my phone with an usb cable


#16

Provided you put the deb file in the Downloads directory the above command should work. If it is complaining about the directory or file, then you didn’t move the deb file in question to the download folder.

Note, you don’t HAVE to put the file in the Downloads folder. You can put it anywhere. if you are currently in the folder that the file is in, you would just type:

sudo dpkg -i .deb


#17

i’ll try that,thanks for the suggestion


#18

it gets the same error:no such file or directory


#19

It will be helpful to post the full command and output each time you try it.

So, you copied the .deb file from your USB onto your computer? And you put it in Downloads or another folder?

The dpkg -i command needs the full name of the file you want to install. Maybe you just typed 2disbetter’s command above as is, but it won’t work, because you don’t have a file called .deb - you have a file called <something>.deb, where <something> is whatever the actual filename is.

When using the terminal, the ~ is short for your home directory, which is what contains “Downloads”, “Desktop”, “Documents”, “Pictures”, etc by default. In my original suggestion, I thought it might be in your downloads folder, but as @2disbetter said, it can be anywhere.

But for simplicity, rather than us guessing where you have placed it, and trying to provide the right command for that, I would ask that you do put it in your Downloads folder, so that

sudo dpkg -i ~/Downloads/<name of file>.deb

will work.


#21

it still gets that error