WiFi Not Working on Librem 5

I just received my Librem 5. I have an Eero WiFi mesh with a standard and a guest network and also an Inseego 5G M2000 MiFi device. My Librem 5 will not connect to any of the three WiFi networks. It sees all of the surrounding networks, and I’ve entered the passwords for the three networks, but it simply spins trying to connect to each network in turn. I’m able to attach a USB-C ethernet dongle and connect to the internet successfully. I used this to download the latest OS updates, but the situation is unchanged. I have rebooted the phone, toggled WiFi (software), toggled airplane mode, and toggled the hardware WiFi / Bluetooth switch.

Any advice would be greatly appreciated.

1 Like

I just installed the SparkLan Wifi / bluetooth card. I could not connect to a couple of networks that offered WPA2/WPA3 support. I managed a way to connect to them. It involves trying to click the gear icon next to visible networks. This is challanging as it keeps changing to a spinning ‘busy’ symbol. Once in the menu for the network I go to the bottom and select security, then WPA & WPA2 Personal. Once I do this it connects to the network.

I don’t know if this applies to you or why it is happening. Just thought I would mention it in case it is helpful.


That actually worked, strangely enough. Thank you.

1 Like

You answered so fast. I’m guessing you figured out that work around before I even finished my post. Glad you got it working.

I had actually just tried that and got it working, yes. But I appreciate the response and I’m glad to document it here for everyone else. :slight_smile: