Your browser is unsupported

Since the forum is back to life again, I can’t use this anymore with FF on my FreeBSD laptop.

I’ve set the user agent string in my FF to the same as FF on my MacBook:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/116.0

but it keeps saying: Unfortunately, your browser is unsupported. Please switch to a supported browser to view rich content, log in and reply.

What could I do?

Use Firefox ESR instead.

1 Like

What is the actual Firefox version? Is it up to date?

(The user agent string may not be the problem.)

This happened to me as well with ungoogled chromium installed on debian buster. Fortunately the ungoogled chromium installed on debian bullseye stil works.

Is this somehow fallout from the DDOS attack, or is it coincidence?

I think the forums‘ server software was changed. It says now “Powered by Discourse”

I think it was Discourse before too! But you are right it had kind of a Rollback to a Backup and maybe an update in between.

Have you delete your browser cache guru? Or try to use the same browser with a fresh user or browser config?

Browsers got more and more complex today. Do you support Javascript? I see no issues on any of my systems/browser settings with this forum. But do not have a freeBSD one.

It has always been Discourse. The Purism forums had to be restored from an earlier snapshot because of a recent DDoS attack.

So did you try out any of our suggestions?

I get the same message with my favourite browser on the L5: Angelfish. Also since the incident, and only on this forum. Before there was no problem. Other websites still work as they should.

Thanks for all the hints. My problem is since the incident and with only this forum. Something has definitely changed. I will update my FreeBSD and FF to a recent bleeding edge version which will take some time due to vacation.

I’m thinking the ‘fault’ lies with the website, not the browsers.

@wimdows , if you (or someone else facing the same problem) with a recent FF you could send a mail to @joao.azevedo or @dos that they look into the issue. I can’t do it because the FF on my FreeBSD laptop is outdated.

And the forum works fine on my company MacBook with FF 116.0. and also with 102.13.0esr on the L5.

Ehm, I am not using Firefox. In fact I uninstalled all (well, both) browsers, and chose Angelfish instead.

Oh, and the forum works properly on my Windows tablet, running Firefox (115.03).

Just to check, I re-installed Gnome Web, and it does not have any trouble with running the forums.

It has also been updated to a newer Discourse version.

1 Like

in about:config change the useragent string to newest version of firefox Windows 11 and it will think its a modern browser and probably work

I suspect that is the cause of refusing to serve browers that the forum was perfectly happy with last week.

Didn’t work for me in chromium. I confirmed that the string changed to one that is working for me on a different computer by using some “what is my user agent site”.

Does anybody know how to change the user agent string in Angelfish?
I use Angelfish because it is the only browser that allows me to do my banking on the L5. None of the other browsers I have tried works for this. I presume this is because of the user string Angelfish deploys. But I don’t know which one that is, nor how to change it.

FWIW, in respect of this forum, my browser was working before and is working after and reports (what I already knew to be the case) that my UserAgent string is intentionally dodgy due to Firefox privacy settings (resist fingerprinting?).

Said web site reports

Your web browser looks like: Firefox on Linux
but it’s announcing that it is: Firefox 116 on Windows 10
This conflict might be causing other websites to not detect your web browser properly.

My understanding is that Google announced to the world that UserAgent is being phased out. So any web site that cares about the UserAgent could have a problem.

It tells me mine is “Firefox 102 on Linux” (but it should be “-ESR”) and that it’s “out of date,” which is incorrect. For GNOME Web, it says it’s “Chrome 64” :nauseated_face: and also “out of date.”

By the way, I have no trouble accessing the forums on either of those browsers.

Unfortunately, doing this helps Google to strengthen their gatekeeping of the internet. :slightly_frowning_face:

EDIT: @Captain_Morgan, I see now that I mentally glossed over the word “firefox” in your comment and focused on “Windows 11,” which uses Edge (Chrome) as the default browser, hence my comment about Google.

But still… I prefer to fly the GNU/Linux flag in my browsers. :slight_smile:
(And Google still sucks, big time.)

1 Like