Adjusting Touch/Tap/Swipe

You can skip down to the “QUESTION” or read the preamble.

Thanks to some training here, I performed the following fist:

I have handed the device off to 3 different people and asked them to:

1- Open the device with following password.

2 - Open Firefox
I know, 2/3rds are off screen. “Use Bing instead of Duck”. I have checked, and it does work on a Puri staff members device. So it is functioning here, once I get the device hooked up to a monitor and keypad. But it took a while for 2 of them to get past the extra keys appearing, but another screen way off-side.
3 - instead. close that and open Test Editor. Tap in ‘my dog has fleas’.
They had a hard time hitting the right keys. Even close bside the key will produce extras.

4 - Close that and open ‘htop’. ,Good, I don’t know what they all mean either, but I was told to install it and run it.

Three people all with a cell, had difficulties with typing, tapping and swiping. No one needs to exactly hit the key to make make it show up. 1/8 to 1/4" away will make the target respond sometimes with 2 3 copies of the target key.

Too, they complained that it sometimes takes 5 - 8 tap before it responds. That is the 12 -13 second delay that comes around between most taps & swipes I mentioned earlier in a post.

The non-scientific test was done to check to make sure I wan’t the only one. But then again, after tapping and editing back, and getting the correct key result on-screen, might mean it is functioning. I didn’t get the memo.

You know what hte issues are if you read the above so, may the end user have access to whatever, and adjust pressure/tap/swipe so that the timed-space between when the finger actually touches the board and target reacts so that the tap isn’t registered unless finger has touched, and not just above, the target key? tia

I’m not sure how to adjust keyboard sensitivity. Hopefully someone can help with that.

It was I that suggested the htop command. If you are just using the phone screen (not attached to a monitor), you might need to turn the phone to landscape to see the full lines and tell if there is a process taking up a lot of the CPU.

I have something you can try. I’m not sure if this is the issue, but I’ve had trouble with the tracker daemon sometimes.

In the Terminal, can you try typing this: tracker daemon -t

With your terminals weird behavior, I know that it might take some effort :frowning:

The -t means ‘terminate’. Note if you reboot the phone the process will start back up. If that process gets stuck running, it can cause trouble in my experience.

If it is that process that is causing issues, stopping it will cause an immediate difference. If it isn’t causing any issues, it doesn’t hurt anything, and will restart on a reboot anyways.

But if it is causing any issues, then we’d know. The htop command could indicate something else causing trouble as well… anything with a high CPU usage that doesn’t go away.

Again, I hope someone else on here knows how to adjust the keyboard sensitivity, which was your question in this thread.

1 Like

I can confirm this description. I find that my fingertip must be placed onto a key of the keyboard with much more care/precision than with an iPhone or Android. If not, it’s easy for me to get two characters typed with a single keypress. I type much more slowly, and with more errors, with the L5 keyboard. For me, it certainly takes some getting used to.


I’m not saying you are wrong but bear in mind that e.g. iPhone is doing autocorrect all the time. I can be a fairly crap typist on the iPhone and it mostly comes out OK. The Librem 5 does not yet have autocorrect, I think. If that is correct then for an apples-to-um-apples comparison you would want to turn autocorrect off on the iPhone i.e. Settings / General / Keyboards / turn off all the smarts and make you type exactly what you want.

1 Like

Three different people! You’re really compromised now. Are you sure one of them isn’t your handler?

(Cold war humor, don’t mind me.)

FWIW, I have never had a problem with my L5’s keyboard, with either amber or byzantium. Has always worked as expected for me.

Sounds like @sharon’s and @zimmy’s software is malfunctioning.

1 Like

Umm, add Sharton, Bethany, and Jim to that list. They have cell phones and have for a long time, except Jim. All 3 had issues trying to type on this, trying to swipe. If it was software, I think there’d be more issues with pad. As I said, one only need to be near, not touching, and load something up, or when typing, must be fast. and accurate with each tap on a letter or get 2 or 3 copies of the llletter and that’s without touching the paadd :slight_smile: Maybe, it’s our electric personalities.

I think this might be a Evergreen. Maybe it’s a different pad than amber or byzantium.

Am following @leetaur suggestion to look for demons running in background.

Hi and thanks.
I see htop is like ProcessExplorer for Windows.
Stopping ‘tracker’ didn’t show anything different. In Usage it still shows up 70% - 80% beside Usage.
Know of a exorcist? :slight_smile:

In Usage, the graph/screen pauses every 5 seconds. I set it to “show all processes.” and when it pauses it draws a red line in the graph showing zero to top of chart. I wonder, could it be a bung Usage program?

When tapping, it may be that when tap, and nothing, several times, if the first tap wasn’t during the brief pause, and starts when the pause (about 1 - 3 seconds).

@Sharon, as I somehow asked earlier: Screen protector for the Librem 5 and if this applies there:

I cannot find any protective cover over the screen. There was none when out of the box. But, it could still be there, but doesn’t appear to be and if it is, which I doubt, I’ve no idea how to remove it. Around the speaker area, the speaker hole is perfectly aligned, so I think there is no plastic shipping cover.

I checked for a plastic cover using a plastic tipped tool and it doesn’t find anything. Looks like it is not the case.


Already filed an issue with squeekboard:

At least one of the issues with reliable typing on squeekboard is that swipe to type is enabled by default. Where iOS keyboard does not allow swipe to type (i.a. only one letter at a time).

This i believe can be improved without relying on any prediction since it goes to and addresses the root cause of the issue (which is unintended key selection regardless of reason)

Evergreen is a hardware batch name. Almost everyone has a phone from the Evergreen batch.

amber and byzantium are operating system (software) release code names. amber is old. Any recent phone will come with byzantium, including I suggest your phone. To check yours: lsb_release -c

Unfortunately I don’t think this is a valid test. Usage itself sucks up so much that I see usage of 69% to 72% just running Usage - on my phone, which works fine and normally. I think you will need to use e.g. top (where the top command shows itself using only 1% to 2%)

(which reminds me :open_mouth: I still have a web server running on my phone).


I marked this as solved because it addresses the Usage usage program being high.

I can swipe and nothing. Swipe 6 - 8 times, and it kicks in.
I can tap in a sentence i.e. ‘Down with demolitions’’ and if it’s the right time, I might get ‘Down with de’ and tap that ‘m’ key several times before it registers ‘mmmmolition’. There is a pattern to the degree of pauses where everything freezes for a few seconds. Manually counting between them is about 13 seconds. Every 13 seconds there is a freeze for only a few seconds.

To be clear, 13 seconds and freeze for 3-5, continue for 13 seconds, repeat or freezing stops for awhile… But, it can stop and not be so mean for some time, 5 minutes, maybe 10 and it starts again.


This is output that you’d like to see (check and confirm) on your phone screen:

1 Like

Well, um, I said it already but I’ll say it again … I really think you should be contacting Purism support. Something isn’t right. “No one” else is having a similar problem. It can be hard to understand what you are observing without actually seeing it. Someone might want remote access into the phone in order to investigate (and that should be Purism support, not some random on the internet 1).

However it might also be suggested that you need to reflash the phone in order to make a clean start and potentially eliminate config or software problems. I don’t know whether you are up for that.

1 We get scam calls all the time telling us that our Windows computer has been compromised and is responsible for criminal activity but that the helpful man on the phone will be able to fix the problem with remote access. Not that we personally have a Windows computer …

1 Like

Well, I’m happy for “everyone else”. But I’m more concerned with this device, not theirs.

I read a lot of other’s issues and by the replies, I thought they were getting support in this arena. OK, I’ll look for support.

1 Like

Since I get bashed for not responding to every reply, I tried before, and still tried again, but:

  1. This is a old phone.
    I tried tried to get a picture and by sheer luck, I got a screenshot of the results from using

Unfortunately, some fixes rolled in this a.m. and the camera no longer loads, but I did get this before it died.
Never mind, on upload it says it can’t accept, only gif, png (but not MY png’s!)
This thing is so possessed!
I’ll take a pic with a real camera and IF I can see the pic, then I’ll upload (embed I think is the word) to this reply.
I did do as told and sent a request to (I hope that was the right lace. Not easy to find them).

It didn’t bounce back. I didn’t get any auto-reply that it was received so I’ve no idea if they even got it.

What DID show up on the device was a lot more headache. I managed to login with a 109 Bit 20 Channel 20 character password. On the devices keyboard, the extremely overly sensitive tap. 22 channel.

The image’s are there, I can open them, but when uploading and the forum goes silly about only accepting…, png … but doesn’t say why it won’t accept my png. Gee, wouldn’t be the devices fault would it?

1 Like

I haven’t, I don’t and I won’t - trust me.

I’ll trade ya! :smirk:

Please open (with Image Viewer or Shotwell) related .png file and Save it as: .jpg (in order to be able to upload related screenshot). Sorry for not bringing that up earlier.


Are you (already) familiar with uuu package and (as correlated) with the Jumpdrive usage?

I uploaded png here before. But maybe the fixes fixed it, so I need to get a new program to vie, change the format and upload that. I hope I can remember all this stuff. Does everyone else have to take a pic, change the format, then upload?

I’ve been on this all day today, it’s nearing midnight and I turn into a real … so tomorrow then.

1 Like