Command line won't take password

I figured that, so before I listed this umpteenth bug/glitch/ I tried just entering the whole pass-thing already a few times. Thanks anyway.

You are very clever person indeed.

Finally you are at the point where you might want to take Librem 5 battery out (and insert precisely leveled cards).

Why has everyone ignored the question? "

I’ll unplug the pwr supply, and turn it on and let it run dry, then take out the card. That should be OK - right? I read about the “Press the POWER button until HTC U12 life vibrates”. Have no idea what or who HTC-U12 is/was/or might be.

Thanks very much,

You are not allowed to do this. @dos warned about related already. Librem 5 needs to be treated as home pet and not like some wild animal.

Please use: sudo systemctl poweroff before you start do destroy your Librem 5 microSD card slot.

EDIT: microSD cardreader not working tells us: “please move the tray only when the phone is off, it isn’t really meant to be hotplugged”.

As far as I understand, using sudo is no option.
Entering a password is not possible.

As far as I understand usage of sudo works on every Librem 5 out-of-the-box.

EDIT: @shopping4purism, you are anyway very welcomed to help @Sharon with usage of passwd, if 123456 still counts on this particular Linux smartphone.

You didn’t read it!!! :face_with_symbols_over_mouth: and you point the shame-finger at me!
Recall that help if you can from @shopping…, because you have, unintentionally I’m sure, misled them as to the unread issue.
Could you hear me all the down to California? Good. Cause I still need to get the thing fixed.

BTW sudo worked, right out of the box. Still works as a matter of fact. Never said it didn’t.

1 Like

maybe, treating people as home pet and not like some wild animal; will improve the Forums image.
Stop insulting. Thanks for your past help. Bye.

Don’t follow this advice. HTC U12 is some other phone.

1 Like

Poppycock. I just used sudo’d, and found a way to circumvent the CPU hog long enough I could get all the numbers in without a problem. READ More please ->>> The issue was never with Sudo NEVER. It is/was about sudo, then password - tapping in 123456 and the hog burps, and it might look like 123 and that’s it. Since we are blinded from viewing what we’re tapping what goes, be it counting the asterisks or seeing the cursor move and gather the dev team was short of asterisks so I rightfully assumed nothing was going in, and I looked, and I read, and read all day and into late tonight.

Later. I forget who (sorry who) told me that it’s done on purpose. That makes it hard when one is typing and looks at their screen to see 12 words, and the rest din’t go in while the beats was busing using the resources.

Too, some things simply freeze. I’ve used clever phones (no such thing as smart phones), tablets, laptops, and desktops since 1981 - before Internet, before PC’s were normal in-home demons.

I very much appreciate the help, but multitasking has proven that reading one thing while listening to someone, or watching something unrelated reduces a mans cognitive skills to that of a 8 year old. I am not suggesting anyone is acting like a child. But it cover what I said earlier, some people are not reading it all.

It’s probably difficult for people working here to run between people an their issues and cognitive hammer kicks up a hiccup. I sure wouldn’t want the job.

Now, we are at the stage where insults and innuendos have gone too far. How do I arrange a refund and where do I start? I read it is easier to do than to fix the phone.

This photo looks just fine to me:, as I wasn’t requested to made one and as I recommended fine horizontal aligment of both cards in my post, because those weght almost nothing and replying here if this important point of mine missed.

This actually isn’t true, from what I’ve read. I think your next option at this point is reinstalling the operating system.

I don’t know if you’ve mentioned it elsewhere, but have you applied all the software updates available? If not, open the PureOS software store app, tap Updates and start accepting and applying any waiting updates. Refresh updates until there are none left to install.

BTW, when the Ctrl key is activated, only certain keys will register… Ctrl + c means cancel, for instance. That’s why I asked.

About the brightness fluctuation, make sure automatic brightness isn’t activated. (Settings > Power > Automatic Brightness > off.)

When an app window has no “back” button, dismiss the window by swiping up from the bottom to minimize it to the open apps tray. Then swipe up again to get rid of it.

If none of these things apply, you should probably reflash the OS. (Instructions and forum threads about that are available, and not very complicated.)

1 Like

Maybe your way of communicating is not so clear as you think it is. The thread is called “Command line won’t take password”…
I’ll leave it at that.
Edit: If your problem has been solved it’s a good habbit to flag the msg as “solved”

Look @Sharon I was in the middle of doing something else (that was important to me), yet skimmed your message, decided to leave away what I was doing and studied carefully what you were about to perform (burn out your microSD card contacts). Therefore and as long you didn’t damaged your Librem 5 microSD card slot I’m fine with your judgment (but you are having right that I do not read many of your posts yet indeed studied few of them and glad if helped at least once).

You may not remember but it was you amarok and others that helped me tto setyup PureOS on a old Z400 workstation alongside Pop, Ubuntu and Win 10. It run like a hot darn thanks to you who provide much of the details. Thank you again.


  • apologies to ‘others’. Memory is waning :slight_smile:
1 Like

@Sharon, my only wish is that you keep Librem 5 for yourself as you deserve it (latest Evergreen batch). Or just in simple words, please keep this Librem 5 for yourself. You’ll not master usage of PureOS PHOSH (on top of GNOME environment) in few days (just put it aside for a while, take recovery as you would after finishing your very first marathon race), perhaps not in a few months, yet advantage that here related backstage support is growing (for your and mine advantage, even if pleasure of using Librem 5 might be based on various backgrounds) with every new day as well.

One of my Librem 5 phones I got from Greece in November '21 (as second hand it was not even in great shape externally, not at all, aluminum frame related) and started to use it as intended, as I use it even today as my most important device, yet in “full speed” only after I performed PureOS reinstall. And, as well, I never have had some issues with its hardware (yet I got very well organized and top service under Purism RMA on some newer version of Evergreen that I use as well). Now, please understand that surrounding development on top of this i.MX8MQ arm64 processor is almost rounded or if not it will be definitively rounded with the release date of PureOS 11: Is there a PureOS 11 ETA?.

As last but not as least, I’ll make it short, there exit none comparable Linux smartphone on top of this and other NXP’s application processors projects.

P.S. For example (if I got right any of your posts in this thread, and as my fingertips bigger than what might be preferable for comfortable usage of any touch keyboard, and need daylight as best light source and therefore my indoor light sources are the best ones as well, mostly with CRI of above 95%), please consider to buy yourself precision capacitive touch screen pen (should help to those using a corrective lenses as well):

1 Like

IMO: Glass, plastic and variety of metals cannot and never will be “smart” unless of course the masses succumb to marketeers befuddling gobbledygook. The Easter Bunny, Santa Clause, Tooth fairy and SMARTdevices are in the same camp. Christmas use to be the Christmas holidays. Marketeers by repetition and belligerence, turned it into propaganda to get every religion and atheists to buy “Holiday gifts”. It’s easy to control masses. It’s done all the time now.

On to other things. There are two logins. First the crypting that places the keyboard at bottom. The letters on that are small - yes, then the Unlock screen opens and the numbers are much bigger.
I sometime hit 2 keys, but I can see, & correct that as it happens.

I appreciate your looking at all the possibilities, but I think best, due to lack of understanding, that I focus on why there are intermittent times when no input is accepted. This can be during typing in a password on the command line to tapping a [next] or swiping up, or down until the background hog releases the device back to use. i.e., I can be entering numbers in the unlock screen and tap 12345 but 4 & 5 don’t register, and tap 4, again, again and again. No “4”, no 5. I wait about 10 seconds, then re-open Unlock try again and again until all keys register. and I’m in.

But, I’m going to follow the advise to reinstall PureOS. But first I’ll follow instructions to, and I lost who, press and hold the button for x second, re;ease and again for x seconds, but I lost my place and can’t find it. When I do, I 'll try that.

Yes. Looks like the phone is mine.

1 Like

No need to rush into PureOS reflash process (as phone received in January 2023), yet once there you’ll note how strong Purism support@ actually is. At first place functioning sudo apt upgrade will do what necessary there.

Besides, functioning uuu -lsusb command (after Librem 5 connected to, over USB cable, to your host computer) is good starting point (it is mandatory connection check, up to how I define this approach): Librem 5 flashing process fail (LED turn green even before any up front reinstall of PureOS. In addition to functioning uuu -lsusb before reflash process requires, over related script, stable Internet connection. Having Librem 5 battery at over 80%, before PureOS reinstall process started, will help too.

P.S. If on your Librem 5 screen still initial screen protection plastic glued above it, please remove it away.

@Sharon, your first investment should go into RTL8153 chipset (works out-of-the-box with Librem 5). My warm recommendation to you as sudo apt update, etc. (no similar thermal issues that are related to WiFi usage) will work with this USB Type C Ethernet adapter at the speed of light.

EDIT: Also, let me correct myself and differentiate passive and active brake time (introducing to you Librem 5 support Team), please be aware of this upcoming content/event: (as even simple user as I am should follow on how much very specific knowledge is “hidden” behind the Librem 5 development).

1 Like