Adjusting Touch/Tap/Swipe

This is output that you’d like to see (check and confirm) on your phone screen:

1 Like

Well, um, I said it already but I’ll say it again … I really think you should be contacting Purism support. Something isn’t right. “No one” else is having a similar problem. It can be hard to understand what you are observing without actually seeing it. Someone might want remote access into the phone in order to investigate (and that should be Purism support, not some random on the internet 1).

However it might also be suggested that you need to reflash the phone in order to make a clean start and potentially eliminate config or software problems. I don’t know whether you are up for that.

1 We get scam calls all the time telling us that our Windows computer has been compromised and is responsible for criminal activity but that the helpful man on the phone will be able to fix the problem with remote access. Not that we personally have a Windows computer …

1 Like

Well, I’m happy for “everyone else”. But I’m more concerned with this device, not theirs.

I read a lot of other’s issues and by the replies, I thought they were getting support in this arena. OK, I’ll look for support.

1 Like

Since I get bashed for not responding to every reply, I tried before, and still tried again, but:

  1. This is a old phone.
    I tried tried to get a picture and by sheer luck, I got a screenshot of the results from using

Unfortunately, some fixes rolled in this a.m. and the camera no longer loads, but I did get this before it died.
Never mind, on upload it says it can’t accept, only gif, png (but not MY png’s!)
This thing is so possessed!
I’ll take a pic with a real camera and IF I can see the pic, then I’ll upload (embed I think is the word) to this reply.
I did do as told and sent a request to (I hope that was the right lace. Not easy to find them).

It didn’t bounce back. I didn’t get any auto-reply that it was received so I’ve no idea if they even got it.

What DID show up on the device was a lot more headache. I managed to login with a 109 Bit 20 Channel 20 character password. On the devices keyboard, the extremely overly sensitive tap. 22 channel.

The image’s are there, I can open them, but when uploading and the forum goes silly about only accepting…, png … but doesn’t say why it won’t accept my png. Gee, wouldn’t be the devices fault would it?

1 Like

I haven’t, I don’t and I won’t - trust me.

I’ll trade ya! :smirk:

Please open (with Image Viewer or Shotwell) related .png file and Save it as: .jpg (in order to be able to upload related screenshot). Sorry for not bringing that up earlier.


Are you (already) familiar with uuu package and (as correlated) with the Jumpdrive usage?

I uploaded png here before. But maybe the fixes fixed it, so I need to get a new program to vie, change the format and upload that. I hope I can remember all this stuff. Does everyone else have to take a pic, change the format, then upload?

I’ve been on this all day today, it’s nearing midnight and I turn into a real … so tomorrow then.

1 Like

I just did as requested and uploaded a jpg file. Site still says …“is not authorized (authorized extension: jpg, jpeg, png, gif, webp)”

1 Like

I’m about to check this. Also and related to our next day conversation:

My upload test (.jpg file is on this forum converted to .jpeg extension, as visible when opened within new Tab) was successful (I’ve made another post with upload today as well). Perhaps you might want to Save as related file to .jpeg right away. Perhaps log out from this Forum => log in helps there.

EDIT: If you are indeed out of working space (and you never wanted to accept this as a fact), and if I’m guessing right (as I do not know for sure) and as you already introduced yourself to @marcf post, df -kh / and expansion of / partition related, are you out of /home directory space there?

Furthermore, @Sharon, upload might therefore not work from Librem 5 (if available partition space is at its minimum) and by copy of this screenshot to some external USB drive (or external SD card device over USB-C port) you’ll be able to upload it (or attach it to the related E-mail) from another computer.

Nah! I have used Windows Phones keyboards for quite a few years. None of them were so hard to negotiate as the L5’s keyboard. Of course autocorrection makes a difference, but the L5’s keys are somehow smaller or at least more fiddly then the keys I was used to on my previous phones.

O, and in landscape orientation the keyboard takes up the whole screen. That makes typing a lot easier, for sure. But as you can’t see what you are typing, you still end up with loads or errors.

So, the keyboard is too small in portrait rotation, and to big in landscape orientation.


One thing I have noticed, is that there are two different keyboard layouts for the portrait orientation: one that shows when you have to enter the disk encryption password, and another that shows up most of the other times (like when you have to enter your sim password).
The first has black borders around the keys, the second does not have these borders.
I think the first one is a bit easier for typing than the second one.

This is for Mladen.Pejakovic @mladen

Wow, I renamed it to ml.jpg - not what we see above. But it’s the same image.


1 Like

Not sure at this moment how (and if I understand your screenshot correctly), yet quite sure that you can help yourself by using those two tools on your host computer, when your Librem 5 connected to it: Fix broken phoc.ini. Once picocom runs there please introduce yourself to relevant (perhaps) content of: Tutorial: Full disk encryption on Librem5.

Second (similar resize partition approach related or at least to make more available/working space on this Librem 5 /home) tool (using already installed uuu package) that easily needed there would be (please search this Forum on how-to):

P.S. I’m continuing to guess what needed there but anyway trying to help somehow,

I don’t know whom you are responding to, but if it was me, the image is for @mladen regarding the camera screen no longer making it after opening Camera. He has already replied via email so soon, I may change be use the Solved button :slight_smile:~s

Others do have the same issue.
I’m not concerned about other devices - just this one. Comparing rocks to boulders - na.

It’s very simple. The keypad is extremely overly sensitive. If there is no way to adjust, I’l hook the L5 up to the tower, and use, similar to lapdock only using a better keyboard, and monitor, then I save a lot time changing each app so it fits on the screen without the need to be scrolling back and forth to get what is off-screen, IF, the device puts a scroll bar, most times not.

My Hoyoki arrived, to run phone through desktop.

Overly sensitive areas on keytab causes search box to appear with a cursor in it. Why? I didn’t press anything for that. Getting the cursor out of the search box is done by out of the search box is only by reboot, if one swipes/taps anything, and it stubbornly does nothing 2, 3 6 9 times, and finally does,the search box underneaths existing view shows up with cursor inside it. Only way to get cursor out is reboot.

The keytab is sensitive, when the pad is being read by the system. Something must be interfering, and blocking things while whatever takes over id done. That might be 2,3 4, 6 seconds.

1 - create a means to edit the time between taps.
2 - Set a means with which to get the cursor out of the search box without having to do a cold start.
3 - whatever interrupts key-presses, permit L5 users to enable/disable it. If nothing is interrupting (I think there is), please recommend a good compatible anti-malware and virus detector.
4 - failing that, I’d rather spend the time of reinstalling OS than trying to remember what needs tweaked that works and stop what doesn’t.

What is Best Practice procedure to wipe it clean and start over OS again? I didn’t see any in


Hi @Quarnero

The result is: 29g 7.2g 20g 27%

plus I have a 64g card.


It’s there, under Troubleshooting > Reflashing the phone

That also links to the reflashing documentation in the developer docs.

Be advised that if you want to add LUKS encryption to the image, you have to specify it when installing. I didn’t; I just used the regular image. It was fairly easy.

If you need help with the actual process, you might want to start a new thread and ask questions as you go. :slight_smile:

1 Like

Thanks amarok for response.
Sorry to waste your time, but I thought it might be similar to dropping PurOS on a device and boot into the install. There goes another feature.
Thank you for your time.

1 Like

I was scared to do it at first, but it turned out to be pretty straightforward.