Can't use L5 after update!

Hello, I just updated my L5 through the PureOS store and after the update installed the phone re-booted and the encryption log-in comes up with the on screen keyboard visible but it does not respond to touch.
I turned it OFF and back on again, but still the same. The keyboard is the but does not respond to touch.
As a Noob, what do I do now?

Your Librem 5 is just frozen at that point, I guess. Please read and understand on how-to proceed up to this link:

As quick approach, please cd to your extract folder (/jumpdrive-librem5/src/) and execute: ./ Now you need to make some space on your Librem 5 /boot partition by removing (just delete): config-5.13.0-1-librem5, dtb-5.13.0-1-librem5 and initrd.img-5.13.0-1-librem5 packages as seen here (as I suppose those are still there):

All above while I guess you reached 100% within /boot partition and therefore cannot move anywhere. Also, Jumpdrive is important tool as you might like and need to backup your personal data as well!

After above done just disconnect (umount) your Librem 5, no need to mount your /home partition if backup not needed.

IMHO it’s an outright bug of the installer script not checking the free space below /boot before polluting the partition with the new kernel files.

Where should I file the bug issue?


Maybe start here:

1 Like

I do not expect that here related issue exists with:

As already explained here:

Therefore I’m just trying to help to @LinuxNoob888 to come out as of his current situation, while working on how to avoid this to happen again isn’t of much help in this thread, not now (although this situation could have been avoided as @guru kindly warned earlier within this Forum).

I am suffering the same problem on my L5…after the PureOS store update, the phone boots to the encryption screen and then is unresponsive to any touchscreen input.
I’ve tried removing the battery, waiting five minutes and then re-inserting the battery, but the results are the same.
While I consider myself a well-above-average technical person with personal computers and have some experience with various Linux distributions, I now find myself with a device I cannot use until (I suppose) I re-flash the OS to the phone and wipe it. It goes without saying that a user should NOT have to perform such an operation on their device, and that the process of updating your device should NOT result in a device that is unusable.
What I and LinuxNoob888 now need is a step-by-step document that tells us what to do to re-flash the phone…a document that assume NOTHING and tells us everything we need to know.
Any takers?

1 Like

I am experiencing exactly the same problem. I’m a beginner so besides knowing how I can start using the Librem5 again, I need to know how I can retrieve all the data I have saved on the memory card so I can find all my phone numbers and appointments in my calendar.

Please contact support who can provide you with steps you can perform to recover the system without having to wipe and reflash it.


Hi Kyle, I have to say that is BS.
Support do NOT know what is going on, and after biting my tongue for a long time I have totally lost faith in Purism. I was not going to mention how long it actually took for us users to finally get our Librem 5’s and now to give an update through the PureOS store that has now bricked our phones.
No one is support is giving a definitive answer to solve this issue.
At this stage the advice I am getting is to re-flash the device! I mean WTF? seriously?
That is what I expect from the PinePhone, not Purism and the Librem 5.
Plus I’d like to know what kind of guarantee do we have that this won’t happen again, on the next update or one after that?
So thanks for the brick guys, I guess I have a new paper weight.

What is BS? Every Linux Kernel is new beginning, but the linux-image-5.16.0-1-librem5 is the LTS or simply the great one (currently as 5.16.3pureos1), IMHO.

I’d like to add some critics:

Had the issue like 12h ago - librem5 is bricked after update, issue fits the description provided here.

The initial post is more than 48h ago.

Understanding of the problem seems to have existed before the initial post.

Why didn’t Purism stop (kernel-) updates until the issue is resolved to deliver the resolution as the first update to make sure that not more customers are affected?

If not already happened: Stop updates, please, until the next update ships the resolution of this fatal error first. @jeremiah, @joao.azevedo?

Instead of heaving everybody strucken by this error contact support it would be nice to have that information on the wiki.

1 Like

… or even just in this topic.

Support didn’t have resolution steps to begin with when the problem first surfaced. They aren’t all-knowing and can’t know the resolution to every problem when it first surfaces. Instead they (like anyone doing troubleshooting) work the issue, and work with other folks at Purism to figure out the best way to resolve it. In doing that, they first advised reflashing as a simple (if destructive) way to definitely get the phone back to normal (it also has the side benefit of increasing the size of /boot to my understanding). We now have a universal set of steps we are advising people to perform who run into this issue. Early on, yes, reflashing probably seemed like the easiest way to get someone back to a functioning phone, but now we have a better process in place.

We have been working to halt the kernel update, however the problem to my understanding isn’t universal and isn’t within the kernel update itself (ie it’s not a kernel bug), it happens if you happen to have too many past kernels taking up space in /boot.

Sure, and if you want we can post in this topic too, although I’d still prefer people work with support to perform the steps in case they have questions or run into any issues along the way.

1 Like

Steps to perform:

On your computer with GNU/Linux system:

  1. Install the package uuu, on PureOS and other Debian based systems, from a terminal run the command: sudo apt install uuu
  2. Open terminal and run command: mkdir jumpdrive && cd jumpdrive (creates new folder and changes location to it)
  3. Download: wget
  4. Unpack: tar -xf purism-librem5.tar.xz
  5. Put the Librem 5 in uuu mode:
  1. Ensure that the phone is switched off.
  2. Turn all Hardware-Kill-Switches off
  3. Remove battery
  4. Hold volume-up
  5. Insert the USB-c cable: (red light blinks, no green light)
  6. Reinsert the battery: (red light is constantly on, the script will continue)
  7. Release volume-up
  1. To confirm that the device is in uuu mode, in the terminal run the command lsusb and search the following for an entry like:
    001 Device 106: ID 1fc9:012b NXP Semiconductors i.MX 8M Dual/8M QuadLite/8M Quad Serial Downloader

  2. Run the script: sudo ./

  3. Once it is run the L5 will show up as an external drive

  4. There will be a 465 MiB drive and a 28.7 GiB drive: open the 465 MiB one

  5. Delete “initrd.img” and “vmlinuz”

  6. Rename “initrd.img.bak” to “initrd.img”, rename “vmlinuz.bak” to “vmlinuz”

  7. At that point you should be able to unmount the external drive and reboot normally

Once you get the device booted you should clean up the failed parts, so run these commands in terminal, one by one:

  1. sudo apt remove linux-image-5.13.0-1-librem5
  2. sudo flash-kernel

@guru @ChriChri @DrTechnical @Marts @LinuxNoob888 please check the above post ^^^


My Librem 5 no longer had the wifi and bluetooth icon active after the update. So I rebooted and I could no longer start the Librem 5. Then I followed the instructions above, but after step 5 "Run the script:“ ./ “” on the Debian PC it did not appear the Librem 5, here is from the terminal:
$ ./
./ 3: ./ uuu: not found
I mean I DON’T see a hard drive. My Librem 5 no longer had the wifi and bluetooth icon active after the update. So I rebooted and I could no longer start the Librem 5. Then I followed the instructions above, but after step 5 "Run the script:“ ./ “” on the Debian PC it did not appear the Librem 5, here is from the terminal:
$ ./
./ 3: ./ uuu: not found
I mean I DON’T see a hard drive. So I can’t complete the procedure. I plugged the USB-c cable into the Librem and the other end into the USB of the PC, is that correct?

1 Like

Looks like you need to install the uuu utility. @mladen we may need to revise the instructions to take that into account.

Done, the instructions are updated


After installing uuu, here’s what happened.
jumpdrive# ./
uuu (Universal Update Utility) for nxp imx chips – lib1.4.77
Success 1 Failure 0
2:1 3/ 3 [=================100%=================] SDPV: jump
3:1 10/10 [Done ] FB: Done
No device on the PC, but on the Librem 5 the image of the smartphone profile with the word error in red. And on the bottom: “/dev/mmcblk0 could not be opened, possible eMMc defect”.

So I unplugged the USB cable and magically the Librem 5 came back on and I was able to log in again. Now I will go to the boot directory and continue with the deletion and renaming. To turn the librem back on I have to use volume-up.

where is the file 5.13.0-1-librem5 ? it shows:
E: unable to locate package 5.13.0-1-librem5