Charger compatibility

Just under a week into using the Librem 5, I’m finding it to be a major upgrade over the Pinephone in many ways, but charging is a serious problem.

I’ve tried five chargers with the Librem 5:

  • Included charger, works fine.
  • Belkin 68W USB-C PD charger, works fine
  • Anker PowerPort PD Nano 20W, fails to negotiate any charging amperage
  • Onn USB 2 charger, works at 0.5A. Not enough to charge the battery, but significantly slows down the discharge rate.
  • Belkin 37W dual port car charger (USB-C PD and USB-A), repeatedly connects and disconnects, no net effect on discharge rate

From my understanding, and from what I’ve seen on the forum, the Librem 5 won’t take a voltage higher than 5V. But the non-working USB-C PD chargers should support some current at 5V, which the Librem 5 should be able to request from the charger.

Is this a known problem?

I would not call it a problem. It is a matter of feature set.
Some charging protocols are supported by Librem 5. Others are not supported by Librem 5.
It is not really a priority to make Librem 5 compatible with every single charging protocol that exists in the wild. Especially when you get a charger included in the package.

This is one of the crazy things of the new EU regulation that requires charging by USB-C for some devices.
USB-C is not equal USB-C. We might end up with people buying the corresponding brand USB-C power supply anyways because it works best with the device / charges the fastest.

PD should be the best choice for Librem 5 I hear.
I don’t know why chargers that claim to be PD have problems. It might be that some deviate from the specifications. Or there might indeed be somewhere a bug.

Using a charger that does not fit the Librem 5 well might lead to more heat and decreasing the life of the battery.

1 Like

BUYER BEWARE. Bricked my L5 testing HDMI usb-c hubs, some combination of a Baseus hub and a130w power supply shorted out my battery and or the power controller as well. PHONE DIDN’T LAST A WEEK.

Hard to blame the phone in your situation.

1 Like

Arguable. I tested same devices on my android, given that I’m posting from my android and not the L5 says something. Those same devices including the power supply connected directly to my android and it’s still fine. From what I’ve read in these forums, and now my own experience, I think that points towards L5 being the weak link.

Yes, USB charging is a “known problem”. :wink:

If you want to troubleshoot then
cat /sys/class/power_supply/tps6598x-source-psy-0-003f/uevent

which will tell you: what USB power type, what maximum current and what maximum voltage (always going to 5V or nothing, AIUI) was negotiated.

If you really really want to troubleshoot then get a USB power meter (preferably one that supports USB-A and USB-C).

That is my understanding. If it doesn’t successfully negotiate USB-C PD then it will fall back to standard USB 500 mA, which is not really enough, but is useful, and behaves as you describe.

1 Like

Circumstantially, yes. But the facts are you plugged the dock/hub into your phone and now it won’t charge and the battery appears to be super dead. Hard to blame the phone for that.

I’m not saying you’re wrong, I am even inclined to agree with you. But that’s my own subjectivity, same as this is yours. I don’t know that it will go anywhere beyond being upsetting.

You do still have the warranty to fall back on though, right?

1 Like

Does the device come with a warranty?

1 Like

I’m almost positive, but I don’t have anything to back it up.

No such info came with the device and i don’t see anything in my account in their shop. 🤷

From my understanding all Purism devices come with a 1 year warranty, unless you purchase to extend it.

1 Like

Thanks. You are correct, i found the quick start guide, it’s 1 year from the ship date. Now i just gotta hope purism doesn’t try to weasel out.

Sure it works good with the Librem 5 as it supports USB-DCP protocol (at 5V range, no other interfering charging protocols supported) on both USB-C power outputs:

As far as I can tell, the Anker charger should behave about the same as the 18W port of the Belkin 68W charger - it only supports 5V/3A and 9V/2.22A, while the Belkin charger does 5V/3A and 9V/2A. There’s no indication that the Anker charger supports any protocol other than PD, and the Pinephone successfully negotiates 5V/3A charging with it.

Aside from the Onn charger (which worked), all of the chargers I’ve tested are USB-PD chargers, which is the one charging protocol the phone is supposed to support. So yes, failure to negotiate any charging voltage/current with the single supported charging protocol using a USB-IF certified cable and USB-IF certified charger that works with every other phone, including the Pinephone, is a problem.

1 Like

Could you show that failure? I have never seen Librem 5 fail to negotiate a contract with a conforming PD charger so far.


As far as I can note Anker A2632 negotiates (probably), over its PowerIQ 3.0 port, Apple 2.4A coding (if not in some kind of loop):

And, in short, this would be clear PD connection (rather output when executed directly on Librem 5) that you should accept as the correct one:

Sure, is there a good way to convert a ttyrec file to a gif so I can upload it? ttygif and tty2gif both aren’t working for me, at least on the phone itself.

The basic problem seems to be that the power supply USB type rapidly switches between “PD” and “C” and doesn’t ever settle on one. When in PD mode, the current is 3A, and when in C mode, the current is 0.5A. On the same charger, the Pinephone reports a power supply USB mode of PD.

This is the A2631, not A2632, so if I’m not mistaken it doesn’t have the PowerIQ protocol. The A2631 says “PD” above its port rather than “IQ.”

A2631 (probably wrongly marked above its USB-C port with PD sign), A2632 and A2633 are quite similar devices (if not identical), meaning belong to the same PowerPort III Nano series (unrelated to Anker PD series of power supplies).

Back to my initial post here: “PI’s fast charging chips are also used in dozens of products of famous brands such as Apple, OPPO, and Samsung.” PI SC1548C is built inside of Belkin dual USB-C PD GaN 68W, one of the most reliable (not cheap) power supplies that I could find suitable for charging Librem 5. In addition, Belkin USB-C2 port is based on Navitas NV6115 (relatively old but still one of the most expensive charging controllers) and I’m quite sure that it charges Librem 5 quite similarly to Belkin USB-C1 port. What I’m not sure (while lazy at this moment) is if Belkin USB-C 68W power supply charges PinePhone at all (as PinePhone is not PD conform).

In short (from my side, or objectively positive side), your Librem 5 should be “happy” every time you decide to connect it to here related Belkin dual USB-C PD GaN 68W (WCH003dqWH). Rest of your here provided opinions are irrelevant to me (especially if used peripheral equipment isn’t indeed USB-IF PD3.0 compliant).

EDIT: @Jt0, if pocket size of power supply matters to you I already made some fully working demonstration of, with the Librem 5 compatible power delivery device (although not the one that I really prefer), PD compatible and manufactured from Anker at the same time: USB-DCP-5V-1.5A protocol and Librem 5.

Why not to be polite and contribute/add there some similar working demonstration (post) with your advanced (not some cheap product) Belkin dual USB-C PD GaN 68W power supply?

Gave up on ttyrec, here’s an asciinema recording starting with the phone unplugged and then plugging it in:

1 Like

This will trace USB-C controller’s events to show what’s going on:

sudo i2ctransfer -f -y 0 w10@0x3f 0x16 0x08 0xff 0xff 0xff 0xff 0xff 0xff 0xff 0xff
echo 1 | sudo tee /sys/kernel/debug/tracing/events/tps6598x/enable
sudo cat /sys/kernel/debug/tracing/trace_pipe