Choosing 'Send SMS/MMS' opens Group

Do you know where Chatty stores the config values? Thanks

SMS and MMS works perfectly fine for me in chatty. My post was about the matrix chat protocol in chatty.

For SMS and MMS to work you have to set up APN settings correctly from you carrier.

I have the same issue.

I think that that is talking about matrix protocol not SMS/MMS protocol

What is your carrier?

That is where everyone says that they are stored but I think they just echo the Chatty values

This is what I did to get MMS working:

  1. Search online for “my carrier name MMS setup APN”
  2. Find the APN (Access Point Name). For me it was “”
  3. On the librem 5 go to settings -> mobile -> Access point names -> Press the “+” sign in top right to add a new one.
  4. Insert a name of your choosing and the APN address you found in step 2. I just used the same in both fields “”

After this MMS worked in chatty

1 Like

Just throwing it out there, but seeing the group setup is the default. You can select only one contact to move on to draft and send a message.

As long as the APN settings in “Chatty” matches the on in “Settings > Mobile > Access Point Names” configuration it should send SMS no problem.

For MMS you need to input your carrier’s MMSC address into “Chatty > Preferences > SMS and MMS Settings”

1 Like

Is your issue about ‘matrix chat protocol’ or that the Attach pic to chat that doesn’t send and doesn’t tell you it didn’t do anything at all?

Yes, it is.
After 4 days, I find that the answer to MY question is; not the carrier, me, or L5. It’s the app itself.

s/b Image, not mage.

Why I thought MMS or the Option to Attach was how to send a text w/ pic is irrelevant now. My question has been answered - sending text w/ pic is not a feature even if it seems pics have been attached and sent.

Thanks for the input,

Sorry, @Sharon, I probably should have replied directly to this for clarity. I was saying I have the same issue as your OP. Chatty’s approach to a ‘new message’ is very confusing in terms of GUI.

As for the other issues with sending and receiving SMS and MMS, I believe I have isolated it (for me at least) down to SMS / MMS over 4G, as opposed to 3G. If I force 3G only connection, messages send and receive fine, with the occasional exception. I think they are limited to 160 characters though, which is tremendously annoying.

Note this report:

(I have not yet confirmed my L5 has VoLTE enabled, as I have not taken steps to enable it. However, I have noted that the header icon stays reading “4G” during phone calls though, which work fine - so at this point I am assuming my L5 had VoLTE enabled out of the box.)

I am sorry but texting pics does work

They are talking about something completely different from what you are talking about.

Yup. I read. I saw. I shared. I need to learn to keep my big share shut. :zipper_mouth_face: :grinning:
But now that it is a certainty that it works - for you - I need to re-focus on getting it to work for me.

BTW - did you use Chats or Chatty? I see there are talks of both. The L5 I have, came with, “Chats”, not Chatty. Researching Chatty, seems to be for Twitch.

Many thanks,

‘Chatty’ and ‘Chats’ are the same thing. It is just very confusing how GNOME and PureOS have labeled stuff🙄

So you just to to find the MMS settings for your carrier.:smile:

The carrier tells me the settings are correct. I’ll talk to them again.

These are the settings that you need

(SMS and MMS Settings)

Great.I opemd th sms and mms settings and confirmed w/ carrier that they are correct.

I did read some possible issues with Volte (?) being on or off and possibly limited to 2G or 3G not 4G or words to the affect but I may have read it wrong. I’m checking later.

1 Like

If that’s the case then maybe the modem firmware needs to be updated? For that you will have to reach out to Purism support.

I checked, still the same correct settings. OK, I give up. It’s a text only and I wil just send pics from camera to desktop Win, and email them. Bit archaic. But just another thing that doesn’t work - yet. One day.

1 Like

What carrier do you use? (Just for curiosity’s sake)

Thaaaaaat’s confidential, but I’ll trust you to keep it a secret :slight_smile: Koodo, subsidiary of Telus.

There is a notable problem though. APN address is correct. However, they said they don’t require a username or password. Too late, it was already there. It cannot be deleted, only edited. So as it is, there is no username, but what was a password, is not just a space. Cannot leave it blank.
I was going to ask here, how to tell APN there is no password. Now I’ll ask.