External battery charger for Librem5

Wow good job! Thank you @Quarnero
@librem5 you can use too the app “gparted” for easy for you, just delete all partitions to clean of the emmc-L5

1 Like

@librem5, please check out if this page helps to you any further: https://arm01.puri.sm/job/u-boot_builds/.

1 Like

Should jumpdrive finish with success ?

It never shows eMMC. (same with gparted)

sudo fdisk --list /dev/sdb
fdisk: cannot open /dev/sdb: No medium found
1 Like

I not sure how Jumpdrive work on Librem 5, maybe the Jumpdrive for Librem 5 depend on a good eMMC if so then Jumpdrive will not work with you. As I said before i not tested Jumpdrive to Librem 5 yet, seem it work different than Pinephones.
@Quarnero how you runned Jumpdrive on your L5? Like you burned a sd card with jumpdrive or you just run the jumpdrive in your computer then plugged to L5 on flash mode?

Ah yes I know how to run jumpdrive on Pinephone.
But for Librem5 instructions are:
1. Put phone in flash mode
2. Run boot-purism-librem5.sh

shell script is basically uuu script


Yes it should, here is picture of ready to be used: Can't use L5 after update!. As root user:
uuu (Universal Update Utility) for nxp imx chips – lib1.4.193

Success 1 Failure 0

2:1 3/ 3 [=================100%=================] SDPV: jump
3:1 10/10 [Done ] FB: Done

When Jumpdrive successfully executed do you see with: sudo fdisk --list (should show all your drives/partitions) Librem 5 eMMC?

This is correct procedure. Extract Jumpdrive archive and run things from my computer.

Within same folder, interestingly (informatively) very same VID and PID are within purism-librem5.lst (inside of Jumpdrive extract folder):
CFG: FB: -vid 0x316d -pid 0x4c05
CFG: SDP: -chip MX8MQ -compatible MX8MQ -vid 0x316d -pid 0x4c05

1 Like

I remembered that jumdrive depend of the kernel-emmc of the Librem 5 to boot, but i not sure.
So we need @joao.azevedo here to know how boot sd card with SO on Librem 5 to rescue.

1 Like

Now I understand why another VID and PID. @carlosgonz, thanks a lot for this information!

1 Like

jumpdrive uses it’s own kernel to boot, so it can boot even if the kernel on the Librem 5 is trashed.

So you can use these instructions up to point 9:

This can be done with a version of u-boot that I am not sure if it is still experimental or if it is already shipped by default. I’ll need to check.


jumpdrive doesn’t finish though, it’s stuck.

1 Like

@librem5, several questions (even if you already answered or already gave other hints about them please bear with me) if you don’t mind:

Did you tried already some other USB-A to USB-C cables (just borrow few from your neighbors, up to 0.6m are preferable, should work ones but any will do if just the right one, right choice for the purpose)?

Did you already charged your Librem 5 battery externally up to the point where all four green LCD indicators are staying/lighting steady (when charging stopped at 100%=4.2V)? Asking while suppose that your L5 battery might have some issues, not balanced well or whatever (but not dead one) and suppose you are not having second one to make sure that the your only Librem 5 battery can deliver over 2.0A (even over 2.5A) right from the start of boot procedure. That your battery depletes significantly is already clear but please repeat restart of your phone (directly or through Jumpdrive or any other method) only with over 75% of your battery capacity (your external universal charger will show capacity of it without … see attached picture). Note that steady Librem 5 red LED light will be steady even when L5 battery at 0% of its capacity (we know that but please bear with me). If you live within Europe I might send you another L5 battery overnight, just ask for such help if needed.

Furthermore when your phone’s battery at almost 100% did you hold power button for over 16 seconds and tried to get it back to life that way (I don’t recommend using original power supply when doing this, holding prolonged switch-on button, while not sure …)? As kindly, with emphasis on important procedure, described and explained here:

You are an advanced Linux user and very flexible one (know very well how to find your way through Linux environment) but keeping our dialog alive will help all of us here in this Forum. Did you already tried to power your Librem 5 from its original power supply (it is rated as PD 5V/3A) from, without Librem 5 battery inserted? I never tried this by myself as cannot trust that this will stay within 5V range in any situation and never ever negotiate higher number than 5.0V, but that’s just me.

Please download this PureOS amd64 image (18-Mar-2022 one), burn it on some quality USB Flash drive and use it on/with your laptop in order to repeat needed steps to get your Librem 5 work again. Even installing newest uuu (if needed to be added/installed, probably) package within this live setup is just normal procedure (we do not need to keep there anything forever), although for temporary usage only. If any add-on package necessary:


Just my two cents with hope that any of above (in particular or as combo) questionings or tips help for real.

Related to JumpDrive procedure:


# ./scripts/librem5-flash-image --udev
2022-03-20 15:34:12,246 INFO Udev rules '/etc/udev/rules.d/70-librem5-flash-image.rules' already present

Related to UUU:

$ uuu -udev

@librem5, please execute as advised within the bottom of output (check if output is the same):

1: put above udev run into /etc/udev/rules.d/70-uuu.rules
	sudo sh -c "uuu -udev >> /etc/udev/rules.d/70-uuu.rules"
2: update udev rule
	sudo udevadm control --reload

I’ve put every HKS off (mandatory), on Librem 5 Linux smartphone of course!
@librem5, when ready once again to re-flash your Librem 5 (without using JumpDrive), as initially described in my post #48 above, please remove microSD card if inserted (not just important, this step might be mandatory, but not sure).
I’ve disconnected my laptop from the Internet as well:

/Downloads/Flash_Librem5# uuu -lsusb
uuu (Universal Update Utility) for nxp imx chips -- lib1.4.193
/Downloads/Flash_Librem5# uuu -dry flash_librem5r4.lst
uuu (Universal Update Utility) for nxp imx chips -- lib1.4.193

Note that I didn’t get Success 1 (was Success 0) right away, yet it finally displayed at the end of this flash, as posted here, but orange LED light on my Librem 5 was showing me that librem5r4.img is transferring to it smoothly.

/Downloads/Flash_Librem5# uuu flash_librem5r4.lst
uuu (Universal Update Utility) for nxp imx chips -- lib1.4.193

Success 1    Failure 0                                                                                  
2:1      3/ 3 [=================100%=================] SDPV: jump                                        
3:1      4/ 4 [Done                                  ] FB: Done 

After I removed USB-A cable end from my laptop there was green LED light on my Librem 5. Decided to press power on button and hold it. Few seconds afterwards it was out. Another short press (less then 2 seconds) powered on my Librem 5 with brand new PureOS, as correctly installed, and 123456 passwd (unknown to me :grinning:). Thank you Purism so much! Yesterday (or one evening before) I was only reading about how to (official instructions) and today my “homework” already done.

How long did it take?

1 Like

Not long indeed, perhaps less than four/five minutes. Thanks for asking! I knew right away that I forgot to measure time (you’ll do this I guess, please). I flipped with Alt Tab to check (actually write/prepare my post) something else and flashing process happened already. I didn’t even erased my previous installation of PureOS on Librem 5 eMMC.

I’ve tried 3 total cables (2 USB-A to USB-C and 1 USB-C to USB-C)

I’ve 2 batteries, I make sure at least one is always fully charged.

This vibrates twice and green LED but nothing afterwards, I’ve tried it.

Without battery phone alternates between green LED and amber LED

I’ve been using PureOS on my Laptop. Also I’ve run sudo apt install build-dep ./ this gets all required packages

This only adds udev rules and I’ve done it as first step, can’t run uuu without root if I don’t add udev rules

I’ve definitely kept it running for hrs.
Adding battery images


I am curious why you not reaching the eMMC with Jumpdrive, if your eMMC it corrupted you will not be able to flash the L5 with the flasher, so i recommend you get a SD card with GNU OS(Pure OS) to booting the L5 then reformating the eMMC, then you will be able to flash your GNU Device again.
@joao.azevedo we waiting for you to get an operating system on sd card to booting on L5 to formating an eMMC corrupted.

Not reaching eMMC is my assumption.
Behavior is: waiting for usb.
I’ll wait for a day for support to respond (it’s weekend)

1 Like