How to make a Black “Dark mode”

For the GUI way, you can enter the .config directory, then enter the gtk-3.0 folder, then from the “File” menu at the top of the files navigator, select “Create New Document,” then “Empty Document,” which you should name gtk.css.

Next, after you have copied the full text of the script, go back and open the empty gtk.css file, paste the text, then save and close.

As @Quarnero said, just name your saved background the same as it’s called in the script, and place it in the Pictures directory. But if your background is saved as a .jpg, just change the script to read .jpg instead of .png.

For select-all, copy, paste, and other functions using the on-screen keyboard, first:
Click the “globe” symbol on the keyboard.
Choose “Terminal” for the keyboard type/layout.
Then click on the “>_” key.
Next click on “Menu” and then “Select All.”
Then click on “Menu” and then “Copy” or “Paste,” as required.

1 Like

the “File” menu at the top of the files navigator, select “Create New Document,” then “Empty Document,” which you should name gtk.css .

I cannot find the “File” menu!
Can you show me a pic?

Oops… Sorry for the confusion. I use a different Files manager, called nemo, not the default one, which is called nautilus.

Nemo looks like this:

In nautilus, which I also have installed, I see that there is an option to create a folder, but I don’t see an option to create a document.

Which serves to illustrate why I loathe Gnome’s super-dumbed-down and somewhat opaque menu options. :wink:

If you want to add nemo Files manager, you can run this in the terminal:
‘sudo apt update’
And then if any packages are available to install, follow with:
sudo apt upgrade
Then: sudo apt install nemo

Or search for it in the software store app.
You can have both File managers installed at the same time. Use whichever can easily do what you want.

1 Like

I have installed nautilus! Thank you.
I thought I lost it altogether, not seeing what you were explaining.
So now I have a folder gtk-3.0 with a file named gtk.css.
I cannot copy paste the code because my mail is not on the phone.
I have to write it out in the terminal.
Does it need to be written stepwise as shown in the examples?

I just tried to enter the text straight into gtk.css, it is possible.

1 Like

Aside: You can solve that by enabling the SSH server on your phone and SSHing in from the computer that does have your email (or anything else). Then you can cut and paste from email (or anything else) into a terminal session on your phone.

1 Like

My phone is still not connected, I am still learning how to install the tunnel. Only after that I will turn my phone into my daily driver.
Thank you for your input.

To be clear … I only meant: SSH access from the local network, assuming that another computer on your local network is the one that receives email etc.

The first 3 lines are greyed out.
Are they part of the text to be inserted in the gtk.css
Thank you so much.

Thank you :pray:

Everything between /* and */ is a comment. Its for people to read and isn’t code run by anything.

Thank you so much, it means I can leave it out?

If you want, yes.

You can leave it out, but comments are there to be referred to in the future, in case you, or someone you share the code with, need a reminder about what the script or specific lines of code accomplish. Personally, I would keep it just for that reason. Commented lines like those are basically present in every script.

Here’s a tutorial for setting up SSH (Secure Shell):

Set that up and you will be able to log in to the L5’s terminal securely from your computer’s terminal over your home network. Then you can run commands or copy/paste text easily.

Also see the tutorial for sftp (to easily access the L5’s files directly from the computer’s file navigator), and the tutorial for Enhancing Security for Secure Shell (to replace password-based SSH login with encryption-key-based login).

1 Like

You are the best!
Thank you :pray:

1 Like

I think you mean nemo, right?

Having tried to install the “black mode”, not successfully! Is it possible that the earlier install of the dark mode is interfering?
Just a thought, before trying for the fourth time.
Thank you!

In short, please take a path that is kindly recommended here: [MyL5] Received my Librem 5 (Evergreen). And in addition, this already mentioned comment is probably (I didn’t check on this while not enough time) related to it (that wasn’t clear to myself right away):

Thank you Quarnero,
After writing this question in the forum, I decided to let it be in the meantime and live with the dark mode as is. Thank you for your response and help in the matter.

1 Like

I am finally at the point that my phone is up and running, a lot because of your kindness to help and explain. For that I am grateful!
But back to the black dark mode! I have a question that I need an answer for to be able to understand how the gtk.css is activated?
the command: “sudo system restart phosh”, does just that. Restarts the system.
The gtk.css is in it’s folder gtk-3.0 under the main folder .config. Which command reads the script and activated what is written?
Thank you very much, have a good weekend.

1 Like

“sudo systemctl restart phosh” will restart just the Phone Shell (Phosh) - the graphical interface - not the operating system.

It (phosh) should then re-read the file.

1 Like