L5 Phone Won't Charge

It’s simple.
1-) Before going to sleep, I unplugged the phone because it runs so hot I’m afraid of a fire. It was @ 99% always 99% or lower. Plus there is that constant reminder that phone has a charging issue (blinking light) Never 100% (what ever).

2-) Today, I plugged everything back in, as usual, to get to re-do the set up to use the Hoyok.

3-) There was no light. The L5 booted, and the battery was showing red w/ white “0%” beside it.

I was able to run the following 2 Dos commands.
Bear in mind, I ran the command and grabbed a screencap, same with second command.
Unfortunately, when I try of open the Pictures folder, it doesn’t or won’t open the folder (File > Pictures. ) and the selection sticks. At least something does.I closed Files open Files again, and clicked another folder, (music) and it wouldn’t open nor able to select any other folder. This thing is really from Hell.

So the only way I can get the command line results is to look at the L5 and type is in on my Windows desktop. At least windows is there in a pinch.
Please excuse the layout. This Forum y limited in it’s formatting ability.

Test 1: Result from 1st command line input.
upower -i /org/freedesktop/UPower/devices/line_power_AC
native -path : (null)
power-supply: no
updated: Wed 31 Dec 1969 {You are kidding}
04:00:00 PM (1682373088 seconds ago)
has history: no
has statistics: no
warning-level: unknown
battery-level: unknown
icon-name: ‘(null)’

Test 2: Result from line 2 command line input.
upower -i /org/freedesktop/UPower/devices/battery_BAT0
native -path : (null)
power-supply: no
updated: Wed 31 Dec 1969 {You are kidding - right?}
04:00:00 PM (1682373393 seconds ago)
has history: no
has statistics: no
warning-level: unknown
battery-level: unknown
icon-name: ‘(null)’

I already tested the Pwr supply. To ensure the next outlet is not on same breaker, I had outlets tested and marked to make sure I use a line on a separate breaker. That didn’t repair anything. I also bought another new cable for it in case the other new cable is faulty. I either have 2 faulty cables now, or the L5 is at fault again.

The above commands used are those provided the artificial helper that suggests other posts to read, and those have links to read.
Now I can’t do anything with it, it doesn’t even key me warm now.


Sound that you need a Apple phone not a L5. = )

Write a mail to support.

Every now and then the L5 will show a 0% battery when I know it is charged somewhat. I’ve fixed it by powering the phone off, taking out the battery for a minute, and then putting it back. Once it boots up it shows he correct percentage again

Thanks @Sarcasmo220
No one should have to learn or find the tools necessary, or learn the language to fix soemthing out of the box.
Maybe it’s a good thing it won’t charge. Now I don’t have any problems with the L5 thing. None. It’s like not having any mobile phone again. Quiet.

Best joke I’ve heard all day. Thanks

I’ve never been convicted Carlos, so I have no use for a cell; not even a stalker like a Apple device.
It’s a long story, but I bought a spot in the queue as a gift for a friend. When it arrived, he laughed. Then apologized profusely stating why he would never use it. I won’t go into his reasoning.
Suffice to say, he was right.
But there it sat, so I owned it by default.
It’s not like I never used one. I’ve used them, and even if they are 110% better, I still don’t need it, nor really, do I want one.

But I paid for it dammit so the very least I’d use it for, and probably the most I’d use it for is to make calls, calls that can wait till I get back home or office.

Thanks again Carlos,

1 Like

That was pretty funny :joy:

Well, it is but true as well. People are handcuffed to their cells. I dine out once a week, and I watch people. Couples and families will be seated, and once they order their drinks, drag out their cells. Some actually trust it in their pockets, others carry their cuffs in the open. I hope I never lose consciousness and ascended to that kind of life-style.

I doubt I will. Now that the phone won’t charge again, is like the Warden was fired. It’s sitting here, staring at me and the way the light is hitting the room, it has a evil grin on it. I failed to realize I must be dead. :ghost:

Off to read more novels now. Maybe I’ll find a fix among Google’s most popular (paid) results.

Excerpt from https://docs.puri.sm/Librem_5/Troubleshooting/Charging.html


If your phone fails to charge, or discharges while connected to a power source during use, follow these steps:

    Unplug the phone from the power supply.

    Enable all kill switches to cut power to the modem, WLAN, camera and microphone.

    Remove the battery.

    Press the Volume Up button and hold it.

    Plug the provided USB C charger into the phone. The indicator light should flash red.
    If the light remains off, try repeating steps 1-5 but with the USB C cable plugged into the phone in the opposite orientation.

    Carefully insert the battery.

    The indicator light should be a constant red and should not flash.

    Wait 1 second then release the Volume Up button.

    Unplug any USB device that might be connected to the phone

    Wait at least 1h for the battery to get some charge

    Press the power button untill the green indicator light shows and then release the power button
1 Like

I been told I should not go there. I can’t apologize for feeling I cannot trust Puri any way, any how. If anything goes wrong, it’s Puri way of escaping any responsibility. So would Puri recognize, or recommend or suggest the kind of tech I can take it to, to open it and go though the steps?

Just prior to the battery giving up, I sent a bunch of stuff to “support” as required, but have not heard back and still no answer to average ETA from support.

There should be a smiley that indicates someone totally mystified and shaking their head back and forth in disbelief. It would gauge my ability to hold my temper. This cannot be for real.

Told not to follow the official troubleshooting steps…?!

I think you must have misunderstood something.

Removing the back, taking the battery out, holding buttons down, and plugging in is a quite simple, and perfectly safe procedure.

But it’s up to you, of course.

Can I ask, and forgive me if you said so elsewhere:

Have you been applying updates to your phone since you received it?

You can ask as often and anywhere you like.
Yes, I leave it up to the phone and notifications tell me updates are ready, and do them right away. Once, someone here gave me the text commands to grab a update, that was a while ago.

Before the thing went south, there was red light blinking. I looked that up and it said it was having a hard time charging properly. Phone was off, I unplugged it, and let it cool down. Very hot! About 30 minutes later, I tried to start phone. Got by the two password prompts and it’s lighting dimmed then it went blank. Waited. Nothing. Tried to get to the power off button. Plugged it back in, and started again and got to the power off, but it wouldn’t accept the tap - so what’s new.
Then I just held the top right side button down for a bit, removed the cables and let it sit. Opened this post. Then checked in w/ my analyst. :crazy_face:

1 Like

So yeah, the blinking red LED and the raised temperature would indicate overheating, I think. I’d venture a guess that following the troubleshooting steps above will restore normal charging function.

That’s what I would do, before anything else, at least.

Told by whom? When? Where?

As @amarok implies, content on docs.puri.sm is content that has official imprimatur from Purism.

By contrast, anything in the Community Wiki or anything written by a non-Purism employee in this forum has the potential to be incorrect - and you are free to ignore it (including this post).


I’ll have to go through every damned reply on this - place looking for it… Bear with me sir. Meanwhile , you mighty want to Google it.

Try this:
Command Line worn’t take password 27/28
Is there more help somewhere 12/26

Need more?


OK, I’ve taken this as a link to: Command line won't take password

in which it is stated “No need to rush into PureOS reflash process”


  • it is not outright telling you not do something
  • it is talking about “reflash” whereas @amarok was talking about persuading the charge controller to behave again
  • regardless, none of these posts is “official” (not @‍Quarnero, not @‍amarok, not @‍irvinewade) so you are free to pick and choose as to which to follow and which to ignore - or just to follow the official documentation

Google the rest, or in English search them yourself.

What is your :face_with_symbols_over_mouth: problem? Why do you expect everyone to be on top and know everything there is about this horror house? Some of you UN-officials just want to show off your techineze, or challenge grammar and blame people back because they don’t have the time, experience, or no-all you expect!
I know how precious this device is to you all. And it’s very obvious how dedicated most are to protecting this things image. But - oh never mind, you’d just take it of context and use it against me in this Court Of Purism.
Take a pill
p.s. do what you’d do to me, read part 2 of the reply I gave you and Yes, it’s in the topic I provide and post/of/posts. How much easier would have to walk you to it. Now, I have to wrap up my reviews and get them posted.

1 Like

You have 20 new problems with your Librem 5 everyday; you ask for help and many people here are willingly to help. This is a community forum, all of the answers are people investing in their spare time. There are some Purism staff in this forum but they don’t hesitate to state that they are not speaking for Purism.

Contact the official support. Ask them to change your faulty device. Maybe don’t wonder if they need time to answer. Perhaps Todd is hiring a new support person who is only dedicated to you keeping in mind how many requests you have.

1 Like