L5 the One Way Radio?

Yea I know I should call support, but I’d thought I’d throw this out there and see your responses are.

I get a call on the L5, and I answer, but the caller does not hear me. Works outbound calls also. If I call someone and talk, they can’t hear me. But I can hear them.

I wonder if it is some silly setting that I missed? I don’t really use my L5 for anything except to call myself when I misplace my 'droid in the house to find it by the ring tone. Otherwise it is just spam callers. So this may be a good thing. Of course I could really kill it by not paying my awesim bill.

It also sounds like a method to use an L5 voice call as a dead drop.

“… If caught or captured, we will disavow all knowledge of you and your team, should you decide to accept it. This phone will self destruct in 10 seconds… … … … … … … ppsssffftttt!”


Test using GNOME Sound Recorder.

sudo apt install gnome-sound-recorder

Let us know if your microphone works or not.

Oh, other symptom, is when I talk into the L5, it echos back on the speaker. So I know the microphone works. It is just the other guy doesn’t hear a hear a thing.

I tested against myself on my 'droid. I call myself, answered. Then went to the L5, the L5 echos back. But no output on the 'droid.

1 Like

Okay, try using a different phone for the receiving end and/or adjusting the sound settings on it.

What is the VoLTE status and what is your modem firmware?

1 Like

Maybe try installing mumble from byzantium repo, and then install mumble and mumble server on some computer.

I tried that with a friend and mumble on the L5 seemed flawless. It was one of those odd moments where a 15 year old program can do like encrypted voice calls flawlessly or whatever even though all the programs expressly for that purpose today tend to have bizarre bugs and problems.

I dont think mumble was made to be a “responsive” UI for mobile, though. It’s just another fun way to test the mic.

1 Like

Had someone call me and I call them out of state. Same symptoms.

1 Like

How do I check that. Under what category in “settings” ?

Regarding the second suggestion the idea is to get the phone to work without some other software. (As advertised out of the box, customer shouldn’t have to do that.)

sudo apt install bm818-tools

Then open it in the App Drawer.

Can you try a corded headset with the Librem 5?

I think you are not the first customer to experience this kind of problem but I don’t know what the definitive solution is so maybe contacting Purism Support would be appropriate.

Can you clarify whether

  • it did in the past work reliably, or
  • it has always intermittently had this problem, or
  • something else?

Can you confirm that you are running byzantium?
lsb_release -c


Got it. (Still, although this means I had to do something extra.) Result below. All boxes unchecked:

FW version
Failed to get Modem FW version
VoLTE enable
Check Call for VoLTE
Can’t get LTE status
CBS enable

1 Like


Codename: byzantium

Yes I actually talked to someone last year, barely audible had to turn speaker on, but yes.

1 Like

Right, restart your Librem 5 and open the app again.

After reboot, the second line alternated between “Fetching…” and same result for a couple times then stopped.

(Do I check any of the boxes?)

1 Like

That is unusual, normally it would display a few values after rebooting. For comparison, this is what is displayed on my Librem 5 USA:

Open a terminal window, type groups and verify that dialout is listed.

1 Like

Yes among several:

purism dialout sudo audio video systemd -journal render netdev feedbackd

1 Like

Second reboot, after complete power down, this time second and third lines read (box checked):


VoLTE enable

Called myself again, voice signal was zero by five. (Extra brownie point if anyone remembers that teminology.)

1 Like

Your modem firmware is up to date. I would suggest troubleshooting your Librem 5 sound settings from here and/or using a headset with an included microphone.

I don’t have a headset with a plug that shape or size or even wireless. Only one with a USB and it is a type A plug for a PC.

Will have to go to the Goodwill store and find one when it opens tomorow.

1 Like