Librem 13 screen flickering

I just unboxed by Librem 13 that arrived a few weeks ago, and there appears to be something wrong with the display.

Every now and then the screen flickers (not the whole screen, so it’s probably not the backlight), and sometimes there is horizontal banding and distortion as well.

Have you heard of reports of similar problems, and is it possibly fixable by an update, or do I have faulty hardware on my laptop?

1 Like

Experiment with toggling each of the kill switches and see if you any of the combinations of on/off make the flickering more or less likely to happen. If you find that you only get the flickering when the kill switches are in a certain configuration you may have a hardware problem.

I had the same issues but it was due to Intel graphic card driver. Try updating to latest (as we changes a bit our repos, can you post the output of this command):

cat /etc/apt/sources.list

1 Like

erno@purism:~$ cat /etc/apt/sources.list

deb cdrom:[Debian GNU/Linux none Stretch - Official Snapshot amd64 LIVE/INSTALL Binary 20151112-20:48]/ stretch main

#deb cdrom:[Debian GNU/Linux none Stretch - Official Snapshot amd64 LIVE/INSTALL Binary 20151112-20:48]/ stretch main

deb stretch/updates main
deb-src stretch/updates main

That is what I was afraid of :slight_smile:

sudo nano /etc/apt/sources.list

remove all and add only this:

deb pureos main
deb stretch main

(save it, Ctrl+X, type y and hit Enter)

after that run this command:

sudo apt update && sudo apt upgrade

(reboot and see if flickering still exists)

The update fails with:

W: GPG error: pureos InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY D0E48EFA77FCA5D4

Run this:

curl -sL | sudo apt-key add -

and then:

sudo apt update && sudo apt upgrade

Ok, I managed to add the public key. NOTE: If someone else is doing the same thing, the last character in the command needs to be a short dash instead of a long one:

NOT: curl -sL | sudo apt-key add –
BUT: curl -sL | sudo apt-key add -

After adding the key, I did manage to run the software update and reboot. In order to upgrade all packages, I also needed to run “sudo apt-get dist-upgrade”. I rebooted after that as well.

Unfortunately the problem with the display did not get fixed.

Oh, the forum software appears to always replace short dashes with long ones.

1 Like

Can confirm that I have the same issue. Screen flickers these “static” lines periodically before showing a strange rounded darker “bevel”, then freezing and fading to gray. Sometimes will persist through a reboot (even in the bootsplash), sometimes not, but always eventually happens.

Upgraded Intel video drivers, cleaned and reseated the display cable on the main board - no luck. Can only assume the display cable is shorted or the display itself is defective. Sent an email to support asking for a replacement display.

I had the same exact problem with my new Librem 13 but the fixes proposed here worked for me: Librem 13v2 screen flicker - horizontal lines

It’s got to be caused by the i915 DRM driver.

I tried the all of the proposed solutions in that thread and still no luck. Still having the same issues. I’m convinced it’s a hardware defect. Moving the laptop screen sometimes makes the behavior worse (static lines and flickering), so I can’t imagine it’s coincidence. Strangely, after adding the suggested flags to the grub config, some things appear worse than before. I have visual artifacts of previously open windows (this browser window to be exact) that are slightly visible when viewing gray backgrounds on other workspaces, even when this windows is closed - even the coreboot splash screen (which is gray) shows my previously open browser window slightly! Yeah, window artifacts are persisting through a shutdown and restart. I’ve never seen anything like this.

Now I’ve rebooted 3 times. Each time the window artifacts go away a little more. After 3 times it’s back to “normal”. I removed the boot flags suggested in the other thread, rebooted and now everything appears to be okay (for now). It’s a very frustrating issue.

I read in the other thread someone mentioned thinking it was heat related. I don’t know if there is any truth to that, but over the last week dealing with this, that thought did cross my mind as it appeared to get the worst after running with the lid closed connected to an external display all day. But I can’t really confirm that’s the case - just speculation.

Does the Librem 13 Rev 3 use the same display as the Rev 1? I have a Rev 1 too that never had this issue and I’m running a nearly identical system.