Librem5 vnc remote access

Has anybody managed to connect to their Librem5 via vnc?
I just tried using Gnome Boxes, it prompted me for a password but didn’t get any further.

@Caliga did not think it would be likely to be working, but that was a couple of years ago…

@buzzLightyear @2disbetter did you have any luck?

1 Like

It works for me. I was able to install Anbox and then get MS Word and MS Excel. I used VirtualBox. Both those application were very slow, maybe because I only had 1 GB RAM and 1 CPU for the the Librem 5 VM.

You may want to try the VirtualBox instead of Gnome Boxes

Thanks, I’ll have another go with [quote=“buzzLightyear, post:2, topic:13292”]
VirtualBox
[/quote]
I just wanted to avoid switching between SSH on my workstation to the GUI on the phone.

Not sure where I went there. I’m not after a virtual machine or an Android emulator. Just a remote desktop connection to my Librem5.

Too much work not enough play… Last night I installed vino but it complained of a lack of x11.

What to try tonight?

gnome-remote-desktop

?

But I couldn’t work out how to get it working.

Thanks, could be the way:
https://shebangthedolphins.net/gnulinux_vnc_remotedesktop.html
And…
https://www.osnews.com/story/29982/remote-desktop-finally-coming-to-gnome-on-wayland/

https://wayland.freedesktop.org/faq.html#heading_toc_j_8

https://wiki.gnome.org/Projects/Mutter/RemoteDesktop

I’ll give it a shot after work today.

I’m pretty sure that PureOS uses Wayland, not X11. I’d try installing xwayland to bridge the gap.

1 Like

Correct.

Maybe, but that shouldn’t be necessary in this case because, as per the link in the previous post, as of almost 4 years ago the necessary APIs have been made available with Gnome using Wayland to allow remote desktop protocols generically (whether RDP or VNC) and the VNC server updated to use it.

The problem that I came up against is that the settings for the VNC server did not come up in Settings on the Librem 5, so it isn’t obvious how to enable it or how to configure it. Needs more investigation.

1 Like

I wish I could respond to you on this, but I do not have my L5 yet. I ordered in Oct of 2018 so I imagine I have quite a long wait still. :+1:

On the librem5:

sudo apt install gnome-remote-desktop

I open the Settings>Sharing it is already enabled and Remote Login is on.
This refers to SSH not to VNC

I double checked it had been started:
systemctl --user start gnome-remote-desktop.service

ps -ef | grep remote

purism 2443 616 0 16:41 ? 00:00:00 /usr/lib/gnome-remote-desktop/gnome-remote-desktop-daemon

gsettings list-recursively | grep vnc

org.gnome.desktop.remote-desktop.vnc auth-method ‘prompt’
org.gnome.desktop.remote-desktop.vnc view-only true

Long story short, gnome-remote-desktop is not working on my librem5 (yet).

2 Likes

tightvncserver gives me a fatal error.
It’s dependent on X11:

xauth: file /home/purism/.Xauthority does not exist
Couldn’t start Xtightvnc; trying default font path.
Please set correct fontPath in the vncserver script.
Couldn’t start Xtightvnc process.

Reading the Wayland FAQ led me to WayVNC which unfortunately does not seem to be ported to debian.

I think I’ll just move on for now.

Yes, that is approximately where I got to and haven’t come back to this yet.

1 Like

Still no luck here either.

As it happens, my desktop is running Hirsute (Ubuntu 21.04) and seems to be at a similar level of functionality (Wayland, gnome-remote-desktop) - and VNC does work - at least to the point of seeing something listening on port 5900.

On the other hand, even though I start the service on the Librem 5 and journalctl shows that the service started, I don’t see anything listening on that port.

I have attempted to replicate the configuration information on the Librem 5 (specifying what connections VNC will listen on and specifying the password), the things that the “settings” app allows me to configure for the VNC server on the desktop.

It may be worth revisiting once Byzantium is released.

1 Like

For sure, somebody much smarter (or less time poor) than I am is figuring it out.

Hi there :wave: tried gnome-remote-desktop but didn’t work for me either. Also tried tightvncserver but it just allows me to control a separate X session.

I’m looking for a way to to control Phosh as I see it on my Librem5.

1 Like

I have successfully tested WayVNC on Librem 5.

I have build https://github.com/any1/wayvnc on my x86 Debian Laptop in PureOS ARM64 chroot. Development dependencies are available as regular PureOS packages except for

These can be cloned and provided as subprojects in wayvnc.

Way VNC can be started even from SSH session to Librem 5 when environment points to active Wayland session

export XDG_CURRENT_DESKTOP=Phosh:GNOME
export XDG_SESSION_TYPE=wayland
export WAYLAND_DISPLAY=wayland-0
export MOZ_ENABLE_WAYLAND=1
export QT_QPA_PLATFORM=wayland

Then it is possible to start VNC by

wayvnc -v 0.0.0.0

Use this fully open invocation for test only on the local and safe network. Use password and certificate setting described on Way VNC page.

6 Likes