List of Apps that fit and function well [Post them here.]

Very nice! I found it on my Mobian Pinephone, so I tried it with Evolution. It seems to work with the main form… a little hard to read, but more usable than before. I’m not sure that works with the child forms, however, as they still overflow the screen. Still, I’m eager to try it on other apps.

Megapixels (See link for screenshots of the controls):

View some nice photos taken with the Librem 5:


No, I installed it from the flathub repo. It’s ok I was only experimenting with it. the phone is nowhere near being usable as replacement for Android or iPhone so I’m not too fust about it.

What do you mean? I’m using it as a replacement to my old android phone

You know just minor details like not being able to read contacts from SIM, abysmal battery life, It doesn’t show up as external storage when plugged into a PC. Bluetooth is broken (at least on Amber), navigation apps cannot talk to GPS module. No easy way to flash phone to Byzantium.

I’ve never needed to read contacts from the sim, so I don’t know if that’s fixed, and I usually copy file via nextcloud or syncthing. Bluetooth (on byzantium) kind of work. GPS + pure maps kind of work, too (with gnss_share). I upgraded to byzantium “manually” (by changing repos, so I’ve not tried yet to upgrade the standard way, but I’ll have to in order to have FDE

edit: also, battery life is quite short (approx 6 hours with ~40 min of screen on, modem on and wifi off). But as a workaround I found a 30euros 10Ah power bank with USB-C and PowerDelivery which charges the phone well and should give a couple of charges, bringing the time up to 18hrs in theory. I’ve never measured it but when going out I always bring it with me and never had battery problems. It’s a Varta product if anybody is interested in a power bank that works ok with the phone)

I’m pretty sure I flashed mine pretty straightforward with the flash tool. I think it used to default to amber so I used a flag to flash byzantium.

It most certainly can do that. However the exact behaviour is complex.

If you just plug into a PC then it will show a nominal 1MB disk and you can use that to exchange files if you wish, and know what you are doing (and I have increased the size of this ‘disk’ substantially to make it more useful). I believe one of the developers said that this functionality may go away (by default) in the future.

If you boot Jumpdrive on the Librem 5 (plugged into a PC) then it does more or less what you want. Its two disks (the internal eMMC drive and the uSD card if you have one inserted) are exported as USB drives (USB mass storage device class) and you can mount those on the PC and read/write files as you see fit. A certain amount of caution is advised, since writing files includes wiping out some or all of your phone’s contents, including rendering it unbootable - but also of course the opposite - flashing it to make it bootable; and since if the phone also accesses one of its two disks then this is not synchronised between the phone and the host (but the phone has not booted from disk and has no need to access a disk).

What you can’t do at the moment is plug into a PC and have the Librem 5 fire up a PTP or MTP server, which is what a mainstream phone would do. This would allow more controlled reading and writing of files e.g. properly synchronised with the running phone and can be subject to file access controls (security).

We used to do that on mobian but had to disable it due to security reasons by default. There is no interactive confirmation yet and you don’t really want to grant any usb charger the permission to read and write on your phone disk.
That having said, installing umtp-responder is just an apt command away (it is available in debian) and will work on the L5 too, if that is your personal preference.


Indeed. Just one reason why I am not a fan of USB charging at all. Noone ever got hacked by a barrel connector. :wink:

1 Like

scale-to-fit does nothing to my telegram-desktop, still doesn’t fit properly. I once tried a hack where I launched telegram from the command line with a 90% zoom, but can’t remember how.

I’ve been working on a Kodi remote.

Lots more that could/should be done to it, but it does work.


I found it.
From the terminal, run telegram-desktop -scale 90
Unfortunately no scaling factor that fits the width within the screen fills the total height of the screen, so it looks as if it is in window mode…
scale-to-fit appears to have no effect on telegram-desktop on Librem5 at all though.


I have no problem with telegram-desktop .deb version
sudo apt install telegram-desktop

1 Like

Since telegram-desktop is a Qt app, it will work differently whether the qtwayland5 package is installed or not, so you can try installing (or uninstalling) that. After (un)installation, you need to reboot/relogin for it to take effect.


Finally, full screen telegram with input area that doesn’t hide behind the OSK.



ProtonMail Browser as an app for email, calendar and drive (storeage).


Can you clarify? Is this a web app?
Looks good.

It’s where you take the webpage and make a short cut to your desktop…so it can act like clicking on a app to get to the webpage.


Yes, that’s a web app. Automatically sandboxes any web page you save that way. :+1: