Many problems starting the Librem 5


I have several (serious) problems using my Librem5 that I received yesterday afternoon (Evergreen).

First of all, I can’t use my SIM card yet because it’s not a Nano Card. So I ordered one that I will get in a few days.
So for the moment I’m using the Wifi of my box.

  1. The 128GB memory card is not recognized
  2. Most of the applications, starting with the Librem 5 settings, require the use of the vertical and lateral “scrollbars” because I only have one screen resolution: 720x1440. This is a big problem because some buttons are inaccessible (off the screen). How can I change this resolution?
    Also, the display does not automatically switch from “portrait” to “landscape” mode when changing the orientation of the phone, which adds to the previous problem.
  3. I have not been able to configure one of my email accounts with Geary, Thunderbird or KMail (which, although installed, does not work at all!). I could only do it with Evolution…
  4. I don’t know how to update or upgrade PureOS and/or Phosh
  5. I don’t know how to Frenchify applications like LibreOffice, Text Editor, Audacity, etc…
  6. I don’t know how to install my Librem One applications, to which I am subscribed: Librem Mail, Librem Social…

Thank you in advance for any help you can give me.

Hello and welcome Patrick,

Before you begin, you need to bring your Purism up to date. To do this, start a terminal (app) on your smartphone:

sudo apt update && sudo apt dist-upgrade

And reboot your phone!

  1. If the programs have not been adapted or not completely adapted for the screen, then you unfortunately have the problem that the contents run out of the “window”. Search for applications that are “better” adapted. You can set the “Zoom” to 100%, instead of 200%, under Settings> Displays, then you get to the buttons - but that’s not the right solution.

  2. Use the menu item “Online Accounts” under Settings. If you store the information about email etc. there, the use of the standard apps is much easier.

  3. previous post

  4. Apps that are not Posh compatible will not be displayed in the PureStore, you can install them in the terminal. Simply use the “Apt” package manager - there are enough instructions on the net.

apt install [package name]

  1. Use the settings as mentioned in point 3.

sudo apt install librem5-goodies

and then use the provided Scale Screen app?

I used Geary with success. What went wrong when you tried to use Geary? Did you get an error message? (To configure an account in Geary it seems that you have to provide 100% correct and complete information up front. You seemingly can’t give it partial information to go in and fix up or complete later. I would assume therefore that you need to be on the network correctly in order to configure the account.)

If you prefer a GUI, use the PureOS Store app, which you should have on your main screen.

Have you used Settings / Region & Language to select French? It should be an option that is available out-of-the-box.

Not mounted automatically?

What file system type is on the card? Is it a new card? (never formatted by you) (I found it easier to format first on a Linux desktop/laptop as an ext4 file system.)

Not inserted correctly?

SIM cards mostly arrive so that they can be punched out to whatever size you need. However that can be a semi-reversible process, so if your existing phone requires a SIM card that is larger than nano size, you might not want to do that.


Thank you very much execrable and irvinewade

Some of my problems are solved thanks to you:

I was able to update the system
I could change the screen resolution

Concerning Geary: the returned message asks me to check the incoming server settings. I checked and rechecked but they are the ones I use on my computer (Linux) and my tablet (iOS). I wonder if this is not coming from the ISP itself because I get a message from time to time about a “certificate” problem…

Concerning the memory card, it’s the one I use on my Android phone (under a French version of Lineage: /e/ or e.OS). Maybe it is not formatted in a format compatible with PureOS ?
Could I connect a USB key directly to the Librem, in order to retrieve files ?

Concerning the frenchization : Yes I chose the french language from the beginning.

On the other hand, I don’t see an application to use the camera to take pictures ?
Is there one ?

Thanks again for your help!

If it’s exfat then, yes, not supported out-of-the-box by PureOS on the Librem 5. I would suppose that it’s no drama to install the needed package though.

I would suggest that you connect the uSD card to a regular Linux computer, let it automount and then ask it what the file system type is.

I had the same general kind of problem. Unless all the info works 100% then Geary refuses to go any further.

If it’s a certificate problem, does the mail service provider allow insecure connections? I know that’s so yuck security but it may be one way to get past that point.

However there are lower level things that could be going wrong.

Still being worked on. You haven’t overlooked anything. It isn’t there yet.

Yes, a USB flash drive should work fine. You will need to have a USB-C flash drive or a USB-A flash drive with a USB-A to USB-C adapter.

Be careful though. The problem that you have with exfat will still be a problem via USB. So ideally the flash drive is formatted as ext4. Any flash drive that is larger than a certain size may unhelpfully come preformatted as exfat, so 32 GB or less will be more likely to work.

1 Like

Kernel 5.4 brought native exFAT support to Linux because recently exFAT filesystem was open sourced, why not yet in L5 natively?

1 Like

just a confirmation :wink:



You would have to ask Purism for the definitive answer.

exFAT is big time sucky in terms of licensing, documentation, intellectual property and proprietariness - and that kind of stuff. It doesn’t sit well with the FOSS philosophy and doesn’t sit well with “purity”.

I think basically Microsoft was pissed that every device and his dog uses the FAT file system for its internal storage, and Microsoft was keen to rake in $$ for the next generation of devices (using exFAT).

You would not use exFAT with Linux unless interoperability required it. You would always be playing catch-up with Microsoft, as Microsoft introduces new undocumented features, subtly changes or clarifies the semantics of features, and in any case the specification is very likely tailored towards working well with Microsoft Windows and hence or otherwise being clunky with Linux.

You may have to use FUSE on the Librem 5 to get exfat support if it has been excluded from the kernel.

It is reality though that I connected a brand new USB-C drive to my Librem 5 yesterday and the drive was formatted exfat out-of-the-box and it did not work. So I connected the drive to a desktop, formatted the drive as ext4 - and then the drive worked fine with the Librem 5.

1 Like

For the microSD card in the Librem5, I recommend using ext2 instead of ext4, since it doesn’t have journaling, which means that it requires far fewer writes to the slow microSD card and fewer writes means that the microSD card will last longer.

Try this in the terminal to verify that the microSD card isn’t mounted:
sudo lsblk
If you don’t see the microSD card in the list, then it isn’t mounted.
Then, find out what is the device for the microSD card with this command:
sudo fdisk -l
You will probably find the microSD card at a location like /dev/mmcblk1 but it might be something like /dev/sda0 (I don’t have a Librem 5 to verify what it is named). Once you know the device location, then you should be able to manually mount your microSD card like this (assuming it is using exfat format):
sudo mkdir /media/mysd
sudo mount -t exfat /dev/mmcblk1 /media/mysd

Does that work for you?


Fair point. Any ext as distinct from some horrible Microsoft proprietary thing.

The device is /dev/sda and the (typically sole) partition for mounting is /dev/sda1

This is because the uSD card reader is a separate component and is on a USB bus.

This may not work if Purism is intentionally excluding exfat support.

I have a 64 GB SDcard formatted to EXT4 and work very well on Evergreen.


I think I opted to leave journaling enabled (on ext4) for the time being because I am expecting a number of, um, unplanned shutdowns.


f2fs is also a decent choice, less amount of journaling and should still handle sudden shutdowns fine. It’s not as widely used as ext4 though, but it’s specifically designed for SD-cards and eMMC.


i would use ext2 instead of fat32 just because of how it tickles my tongue …

any other reasons why ext2 is better than fat32 ?

i always format/reformat my drives inside a GNU/Linux distribution whenever i get a new drive for something …

So did nothing come of this then? It sounded promising back in 2019

Maybe I’m not understanding correctly but is this an error Geary is giving you? Certificate errors could be caused by the wrong date/time setup on your device which has happened to some people.

Likely just because nobody enabled it in the kernel config so far.

I hope someone will enable it soon in the kernel because exFAT drives are so common among new users that such issue could limit ease of use of mass production products.

There you go: