[MyL5] Australia/New Zealand

The video example is the only thing I can go by and it seemed to automatically extend the desktop with the monitor’s native resolution area.





I’m not sure if I’m missing one video that would show it better.

Here is moving it with a keyboard shortcut (needs attached keyboard(?)):

In case of no external keyboard and mouse, I think there must be some kind of command line comand, that instructs gnome(?) to move a window on the second display…

Yes, that’s why I mentioned that this is not a dock, just an external monitor.

If it were docked with keyboard, video and mouse then the external display etc. can basically replace the built-in display, which can be disregarded. /Everything/ can happen on the external display, just as would happen on a regular computer.

Docks are a bit expensive. I don’t own one. So I can’t do a full test of this right now.

The kind of scenario that I was imagining is doing a presentation. I’m looking at the phone, I’m driving it on the phone, but other people can see what is on an external monitor, and the external monitor is a mirror of the phone screen.

Don’t forget BT mouse+keyboard option - no need for dock.

1 Like

Oh, that’s what you meant with:

Personally, I’m for avoiding the use of the dock word. I consider that thing as an I/O ports extension. Depending on the extension, it can provide only one port (one HDMI or one audio jack or one ethernet port), or many more and different. So, dock, undock doesn’t feel that right to me as I don’t know exactly what it supposed to mean.

1 Like

Is this meant to be “Blue (flashing)”? Or is there a difference between “Blue” and “Blue (flashing)”?

Also, what makes the Blue turn off?

I received an email, I read the email, I deleted the email, I restarted Geary. Nothing seems to make the Blue turn off. I expected that at least one of those (excluding receiving the email) would cause the Blue LED to go away.

While it’s charging, alternating red and pink is all very pretty and all, but …

Some hours later I had done something and the Blue LED went away.

FYI: The notification area specifically uses the word “dock” or more precisely at the moment the word “Undocked”.

Answer: Yes and it does give a bit more insight into what’s going on. Based on my testing, the only Display Mode that works is “Joined” - and most of the time the right hand monitor is ignored for display purposes (but it is captured by Screen Shot).

I’m calling the default background image “blue hexagons”.

In the Screen Shot, the empty space caused by the fact that the external monitor is deeper than the scaled built-in display is “transparent”.

I’ll post a couple of further images from the Display Settings - but with the blue hexagons cropped out for brevity.

I have experienced one system lock-up and one spontaneous reboot while playing around with external monitors, reaffirming my suspicion that this isn’t ready for prime time.

1 Like

The next image is scrolling further down the Display Settings.

The next image shows the “orientation modes”. I’ve never seen anything except “Landscape” work however.

Yes. And “Video Out”, “Out Video”, “Ext. Display” or similar would be much clear for me of what that option is for. I don’t have to translate it in my head everytime.

1 Like

@dos checkout these screenshots above

The Aus/New Zealand plug is also the one that is used in china, so really no excuses for not having it as an option!

For moving windows to another monitor in Gnome try Shift+Super+(Left Right Up or Down arrow).

For your SSH security I recommend you check out “ngrok”

1 Like

when you remove all notifications for the dropdown menu

1 Like

No dice for me at this stage.

Pairs correctly.

I choose Settings / Sound / Output … Bluetooth - with “A2DP Sink”.

The “Test” button half-worked once. Half-worked means that it showed a Mono speaker to click on to test but no sound came out of the speakers on the host computer.

Thereafter the “Test” button didn’t work at all. No speaker to click on.

I know that this functionality works on the host computer because it works with my existing phone.

Display settings in the GUI are mostly unimplemented yet - but it’s coming (see https://source.puri.sm/Librem5/phosh/-/merge_requests/704)

2 Likes

I can confirm that this works the way you describe. It was a case of “bad user on device”, or to be a little kinder … I needed to make a slight alteration to the way I operate.

I don’t think that’s going to fly … no Super virtual key?

Today I tested … external charging.

The charger that I bought is: https://www.amazon.com.au/Onite-Universal-Battery-Charger-High-Voltage/dp/B005REEWYY

It has universal AC voltage, independently adjustable positive and negative pin position, auto-sensing polarity, and adjustable battery width. So, mostly idiot-proof.

It seemed to work with the battery for the Librem 5, although charging is quite slow.

Like the phone charger itself, it has pins for a US AC socket. A good thing I bought a 2-pack of US-to-Australian AC plug adapters. :wink:

5 Likes

Today I tested … Bluetooth keyboard.

Yay! Worked out of the box.

You can even minimise the on-screen keyboard when using the external keyboard and thereby claw back some screen real estate in the application.

For bonus marks, the keyboard I was testing with has a small mouse-equivalent - and, with the keyboard paired, a pointer appeared on the Librem 5 screen and that works too for operating the GUI. To be honest, using the touch screen is nicer, the mouse is clunkier. I was really only testing the keyboard.

5 Likes

Which brand of keyboard was it?