[MyL5] Received my Librem 5 (Evergreen)

If the docking station has a USB C data port (not plug) you can plug in your alternate adapter there. Even if not, one or more of your alternate adapters can be USB 3 type A. There is no downside to the dock having an ethernet port.

perhaps, but if i’m going to cycle between multiple NIC-external adapters (some usb-A, others usb-C) then having an internal one seems redundant and more costly to produce …

Yes! The image file that phosh uses is at /usr/share/librem5/default-theme/adwaita-phone.jpg and if you replace that with your own jpg file it will use that, rescaled to fill the screen:

sudo cp myimage.jpg /usr/share/librem5/default-theme/adwaita-phone.jpg

Mine looks like this now (using image from https://www.fsf.org/resources/badges converted to jpg): :slight_smile:


Thanks for the answers. OK, I will buy a USB-C to ethernet because at my work ethernet is available but no wifi. Or maybe a dock is a better choice for this. The baseus dock discussed in another thread looks good. I am just no sure if I see the same model here:

(it says “to Huawei & Samsung”)

and if L5 fits in there because is is not as slim (although I really like it is not slim, since it has a great grip).

Thanks for the help with changing the background. I will try.


I have Wifi connection issues. It connects OK. Internet works and then half a minute later the connection gets dropped. Then it tries to reconnect. It reconnects and some seconds later it disconnects again, and so on. Sometimes the connection looks stable for longer intervals and this is how I managed to upgrade the system. Moreover in a small room, 10 sq meters, with wifi device inside the room (a mini travel router in AP mode connected to internet through Ethernet and providing wifi access to wireless devices) and L5 2-3 meters away it may show 2 bars. Is this normal? I tried iw command. It showed 20dBm txpower. Tried to raise it to 30, it failed. Is 20 the maximum?

terminal output shows
ch9 2452 MHz
w 40 MHz
center1 2461 MHz
txpower 20.00 dBm

It is annoying to disconnect frequently. Should I open it and check the cables somewhere?

Something else. When I connect to L13 through USB-C nothing happens on L13. Shouldn’t I be able to access it somehow? I tried to do that because wifi was unstable and I wanted to transfer a file. What do I miss?

Finally does wifi performance relate to the battery level? Is there something interfering with power saving issues?

Which command did you run to get that info?

About Wi-Fi disconnecting, others have reported that it helped to change “bandwidth” setting on the router to 20 Mhz, see for example here:

Maybe the “w 40 MHz” in your terminal output indicates you have bandwidth 40 MHz, if it is possible for you to change that from 40 to 20 MHz then that might be worth trying.

1 Like

Ah, good point. I will try to see if I can do that with the mini travel AP router.

About the command I used it was either
sudo iw wlan info
ifconfig (the battery is depleted now and I charge it, so I will retry later. I think it was iw aftfer the iw package was installed).

It sounds strange that a wider bandwidth is worse than a narrower. I would expect the exact opposite.

So if you go out to a cafe (after we get done with covid :grinning:) there will be trouble. because of course the coffee shop will not mess with such settings. My router says “Auto” for bandidth. So if L5 prefers 20 MHz it should say to the router that prefers 20 and not 40.

…or you can simply change the wallpaper. phosh respects the setting used by GNOME: https://linuxconfig.org/set-wallpaper-on-ubuntu-20-04-using-command-line

The 5.11 kernel which should migrate to amber-phone in a day or two forces 20MHz automatically, which should improve WiFi compatibility out-of-box.


Indeed… I changed to 20MHz width and the connection looks stable. By the way I rechecked and the command that provides this info is

iw wlan0 info

Currently it gives:
purism@pureos:~$ iw wlan0 info
Interface wlan0
ifindex 3
wdev 0x1
addr 88:da:1a:7c:31:44
ssid TP-LINK_61C7
type managed
wiphy 0
channel 3 (2422 MHz), width: 20 MHz, center1: 2422 MHz
txpower 20.00 dBm

But as @dos writes to force the proper width is the correct way for routers we do not control. So I will reset my routers to “Auto” and recheck after I get the kernel update. I will report back.

Any info about connecting to a laptop (such as L13) with usb cable? Or currently it has to be only over network. Not a serious problem if the connection stays stable. But it is good to know.


It shows up on the laptop as a regular Ethernet device that you can configure with NetworkManager on both sides.

There’s also serial console exposed over USB, so you can login without setting up any networking.


Interesting. I will play with NetworkManager as you suggest.

But with minicom how do you find the correct tty? Actually I thought that as root on L13 the command dmesg | grep tty would give me something useful after I connected the L5, but it does not. It gives the same output as before I connect them. Isn’t this strange? It gives printk, systemd and a few error lines about speech-driver. I expected to see some ttyS0 or similar.

Is that on the 2.4 GHz band only?

(I’m using a 40 MHz channel width on the 5 GHz band with my Librem 5 and I’ve never had any stability issues.)

It seems as if the iw package (giving the iw command) is not installed out-of-the-box.

1 Like

Yes, I installed it at the terminal with sudo apt install iw

By the way I have not tested L5 at 5GHz. It could be stable there at 40MHz width. I do not know. My router’s default was 2.4 and never had a reason to switch it to 5.

1 Like

Yes, it’s only relevant to 2.4GHz networks.


The Baseus Mate Docking Station https://www.baseus-cn.com/baseus-mate-docking-type-c-mobile-phone-intelligent-hub-docking-station-standard-version/ is NOT suitable for the Librem 5 Evergreen, because it is too thick for the slot! I’ve ordered it and learned it the hard way…


Which is weird, because I have it too and it fits mine. It sits very straight in it, but it works fine.


@spaetz I can not make it work either. But something is strange. How do you power this device? It comes only with a usb-c to usb-c cable. I put a samsung telephone on it. Connected it with L13 with the supplied cable. Nothing happens. tried with another cable usb-c (on the dock) to standard USB of L13. Nothing again.

Is my unit maybe faulty? How do you connect the baseus? can you describe your topology?

1 Like

I can take a picture tomorrow and post it in a new thread. Basically, I plug the USB-C cable into the pinepower PD outlet and in the Baseus Dock.
When I plug in the L5 it starts to charge - most of the time. When I unplug the power supply, the L5 starts to provide current to the dock though and will be sucked empty soon. All from memory, I am not near my dock now.

1 Like

Pinepower is from pine phone? What is pinepower? Does it work with L5 power adaptor? I tried: L5 power adtaptor + either Baseus or L5 cable and I do not see the L5 charging. Unless I have to press hard in L5 to fit inside the dock. But I am afraid to do so.