New Post: My First Week of Librem 5 Convergence

After further testing on my part I’ve found that my dogwood will crash when trying to enter docked mode with my dock. The dock is a Kensington SD4600P USB-C dock. Serial No B1802B002177. The dock powers the Librem 5, the Librem 5 crashes when plugged into it with a mouse and keyboard plugged in.


I am running the latest software and was at the time. the vender is Kensington, the product id is SD4600P

Actually I meant: type in lsusb and look at the two 16-bit hex numbers. That is the way to ensure that two people are talking about the same make and model of device. e.g. 0424:4041 for the uSD card reader. The first number (0424) is the USB vendor id and the second number (4041) is the USB product id.

1 Like

I did some testing with four docks and my Librem5 (edit: Evergreen). I’m running with the latest amber updates (as of this post).

One thing I wanted to test is whether the Librem5 can be docked and usable without a battery. This is based on my understanding that the ideal battery state for storage is to leave it around 50% charged. So my plan would be to have the phone docked (keyboard/mouse/monitor) without a battery and have my battery in storage until I actually need the phone for mobile.

The docks I tested are:

All connections from the docks were done via HDMI, and I tested the connection between a laptop and the monitor with the cable used for the tests beforehand.

I also tested all of the docks except the Baseus with the laptop, and the keyboard/mouse/monitor worked in all cases.

When I write “power cycling”, I mean:

  1. The phone light goes quickly from green to yellow
  2. The light stays yellow for a few seconds
  3. The light turns red and starts blinking
  4. The Librem5 logo comes up for a moment then goes off
  5. The light goes back to solid yellow
  6. [process repeats 2 or three times, then nothing]


  • No battery: power cycling
  • With battery:
    • Plugging USB-C cable in while phone is already on:
      • Keyboard/mouse works
      • Monitor not detected (not listed in Devices–>Displays and docking mode not available)
    • Resetting phone with USB-C cable plugged in:
      • Keyboard/mouse NOT working
      • Monitor not detected (same as above)

Lenovo USB-C Dock Gen 2:

  • No battery: power cycling
  • With battery:
    • Plugging USB-C cable in while phone is already on:
      • Keyboard/mouse NOT working
      • Monitor NOT detected (not listed in Devices–>Displays and docking mode not available)
    • Unplugging USB-C cable and re-inserting it while running:
      • Keyboard/mouse works
      • Monitor NOT detected (same as above)
    • Resetting phone with USB-C cable plugged in:
      • Keyboard/mouse works
      • Monitor detected in devices, docking mode NOT active or available, no output on monitor. It’s like the monitor is detected but the phone can’t send a signal.

Anker 7-in-1 USB C Adapter

  • No battery: power cycling
  • With battery:
    • Plugging USB-C cable in while phone is already on:
      • Keyboard/mouse works
      • Monitor not detected (not listed in Devices–>Displays and docking mode not available)
    • Resetting phone with USB-C cable plugged in:
      • Keyboard/mouse NOT working
      • Monitor NOT detected (same as above)

Baseus Mate

  • No battery: Nothing. No red light, cannot turn phone on.
  • With battery:
    • Plugging USB-C cable in while phone is already on:
      • Keyboard/mouse works
      • Monitor works. Docking mode is enabled. Tested two different monitors. One weird thing: when the phone locked while in docking mode, I couldn’t unlock it.


  • It seems like I can’t currently run the phone without a battery from any of the docks.
  • Only the Baseus gave me functional video output
  • The Lenovo’s video output half-way worked (it saw the display in Devices, but didn’t seem to push a signal. Also didn’t put the phone in “dock” mode)
  • Keyboard/mouse detection seemed to randomly work. If I restarted or plugged/unplugged the the USB-C connection, I could get it to work sometimes. The keyboard/mouse detection seems to randomly work with the same frequency as my WiFi. I don’t know if those issues are related (is the WiFi running across some kind of USB bus internally? Maybe not).

Thank you @Lagomorph for testing and letting us know.
I ask @amosbatto to update the wiki about compatibility of docks.
I would like to know if I want video out 4K@60Hz and display port, should I look for this:

Kind of comment only (just to encourage further your thoughts direction and in order to learn something from you): As original Librem 5 charger uses PD3.0 protocol (and guessing somewhat that the PD2.0 negotiation is out of question here as well) I do not see that any of docking stations mentioned within your post uses (is based on) pass-through PD charging (but didn’t researched controllers of those hubs at all, certainly not extensively), as input and in particular (if matters here?), as PD3.0 power output standard (directly from used hub) when connected to the Librem 5 USB-C port. In your shoes (as I don’t have L5) I’d test, in order to expect that things might work the way you want (to have it for your purpose) those two devices: C31NANODOCKLANPD (2109:0102, see second link/list) and ZDSHB01 (2109:0103, also second link). Also, you might ask the author of linked thread if this i-tec docking station usable under PD3.0 (only), without battery of course.

Thanks a lot, great post anyway!

P.S. I saw another i-tec docking station that might be tempting if above one works as expected. But anyway, ZDSHB01 is already advanced one as USB-C(1) provides with 30W just enough power for every Librem 5 feature (as said, all here is just current thought of mine, nothing to add/confirm).

1 Like

I have received a second unit of Baseus (the first was faulty) and I can also verify that it works even with the screen protection of ViaScreens I have added. I mean that even with this increased width of the phone the amount the phone “travels” in the dock to connect to the usb-c is enough to make it work. But, you have to give it some time. Say, wait for at least 10 seconds to see that the charging led lights up. If you just connect and expect for charging to start immediately, the way it does when you connect it to the charger it will not work. Give it more seconds.

Now, there is a problem with sound. One of the scenarios for the dock is to connect it through hdmi to a TV and play a video on the TV with the L5 (say with vlc or mpv). VLC can not be moved to the TV screen. How to you grab its window with a mouse? Nevertheless the main problem is how to route the sound through hdmi to the TV.

To make sure it works through Baseus I tried with my sons Samsung using Samsung DeX. And it works. So the Baseus dock can stream the sound to the TV.

But on the L5 how can I do that? It plays through the L5 speaker. I opened Settings→Sound and there does not appear any new output device to select. I can select L5speakers, Handset, Multichannel Output - Modem, and Analog Output - Modem. (4 options).

Is it possible somehow? If not from the interface maybe through terminal?

1 Like

How about using pavucontrol for sound settings? I think you have to install it from the repositories. IIRC there is some tag with a dropdown to select HDMI output.

That is out of my memory from years ago on my desktop.

I installed pavucontrol and connected the the L5 to the TV. Again, there is no such option. In the output devices there is no HDMI out.

Try going to the “Configuration” tab. Do you see HDMI devices in the menu for “Built in audio”? Try selecting an entry with “Digital Stereo (HDMI) Output”.

pavucontrol on L5 with amber, Configuration tab
Build-in Audio
Profile Default
The only other option is Off.

on L13 with byzantium there are plenty of Profiles including HDMI out in pavucontrol.

Is this really a difference of Amber with Byzantium or it is something else? Something specific to L5?

I doubt that this is a pure amber vs. byzantium issue (I reckon that if you were running amber on your L13 you would also see the HDMI profiles). However the audio on the L5 in byzantium might have more options of course - is there anyone here who can check? If not, we could ping one or two of the devs who hang out on these forums.

@amosbatto was asking a related question here: L5 Multiple Audio Outputs.

1 Like

Just checked the @amosbatto question you gave me. Nope. The playback tab for the application lollipop I tested gives only two options:

  1. Speaker+Headset+Jack
  2. Modem
    No hdmi output. Rechecked Configuration tab, no hdmi output there either. So it is time to ask some developer. Dear @dos or @Kyle_Rankin who originally wrote (I think) about the docking do you know what is the problem and no hdmi output is given in either build-in sound preferences or pavucontrol on L5 with amber?

There’s no support for audio output over DP in the kernel yet. From what I know there’s nothing in the hardware that would prevent it from being supported, so it likely just needs some kernel driver work.


Oh, OK @dos So this is one more missing piece which should be considered, I guess, as part of “convergence”. Thanks for clarifying this.

Not to be forgotten, if there is a project I could file a “bug” report please provide a link.


So it is reported by Todd himself. Good.

I tested the L5 with a Trust 7-in-1 dock (HDMI, Ethernet, 2Usb, 2 Card reader, Power In) powered by a 61W PD3.0 power supply (tried both with L5 stock and this one).

Both USB devices work fine (keyboard and mouse), both with and without power supply plugged in (but the battery discharged super fast when not plugged in). HDMI output works, too, sometimes even when it’s not plugged to power supply (but this is inconsistent). Also, when plugged in, /sys/class/power_supply/max_170xx_battery/current_now reports -0.1A/-0.3A (with the L5 display off, wifi off, modem on) which means -1% in a few minutes). Also, sometimes the screen goes blank and reappears with some horizontal shift (the right part of the display is shown on the left. Usually unplugging and replugging the dock restores the right aspect.

The device itself advertise support for USB-C PD pass through up to 5A 100W.
I suspect the dock does not support PD3.0 (I had a problem with a laptop usb-c charger rated 45W = 20V*2.75A maximum, 3A for other voltages including 5V, 9V and 12V) which was not able to charge the L5.

Can this be fixed by some future upgrade, or should I return the dock?

(No battery: power cycling)

You can check what power contract does your hub negotiate with:

cat /sys/class/power_supply/tps6598x-source-psy-0-003f/uevent

5V/3A should be able to charge the phone with no issues.

1 Like


  • Trust 61W Power supply:
    • Alone: 5V2.4A
    • Hub: 5V0.5A
  • Purism Power supply:
    • Alone: 5V3A
    • Hub: 5V0.5A
  • Varta PowerBank (with PD):
    • Alone: 5V2.4A
    • Alone (non-PD port): 5V0.5A
    • Hub: 5V0.5A

I don’t understand why only the purism power supply gets to 3A even if the trust one should support 5V3A (same goes for the varta power bank, which states: 5V3A, 9V2A, 12V1.5A). I’m using the same usbc-usbc cable (purism one) in this tests.
Also, the usb hub seems not to use PD being always capped at 0.5A.