New Problem with Librem 14 not charging battery [SOLVED]

So I saw the other thread recently (Librem 14 Failed to charge SOLVED) showing that people could alter their charge_control_start_threshold file to force their laptop to start charging, I am also having this problem, however I do not have this file. This problem was also addressed in this same thread about how one could go about re-imaging their firmware to receive said files and fix the problem, however after re-imaging my firmware (PureBoot-Release-17.1) I have found that the place in my file directory where said files should be contained are still not their. My concern is that the only way to get these files and get my laptop charging is to re-image with CoreBoot instead of PureBoot. If I were to do this, would my Librem Key still have its intended function? Is there a way that I can get the needed files to get my Librem 14 charging and still use PureBoot? Please give some assistance to me so I know what I am doing. Thanks you.

Edit: João Azevedo reached out to me through email and gave me instructions which seem to have fixed the problem. The solution was to run sudo apt update && sudo apt full-upgrade
This gave me the missing files and I have been able to keep PureBoot as my default. I was then able to run echo '70' | sudo tee -a /sys/class/power_supply/BAT0/charge_control_start_threshold on the now-existing files to set my charging threshold at 70 percent.

2 Likes

I had this issue a few days a go and was able to resolve it as per the thread that you referred to.

My understanding that you need PureBoot for Librem Key to function.

What operating system are you using?

I am using PureOS.

If I re-image to use CoreBoot, do I just lose the functionality of my Librem Key forever, and is this probably the only option?

@MrChromebox ^^^

Just to double-check, did you install the package librem-ec-acpi-dkms as instructed in that thread, and then reboot? That’s what gave me those mentioned files.

1 Like

Yes, if you get rid of PureBoot, then you can’t verify that the boot files haven’t been changed with the Librem Key.

1 Like

I just had this issue with brand new Librem 14 Pureboot on its second power up out of the box. The first powerup I went through the normal configuration of PureOS. The second powerup something was corrupt with the Pureboot and it failed to Recovery command line. Apparently the battery died between the first and second boot, and this corrupted something in the Pureboot. After some searching these were the steps:

-reboot, hit any key before 5 seconds to get boot menu > Options > Factory Reset

-after Factory Reset go back into PureOS

-librem-ec-acpi-dkms is not found in the standard PureOS repos.

-I had to add one of the mirrors listed at this site https://tracker.pureos.net/w/installation_guide/mirrors/ and follow the instructions there for how to add it by editing /etc/apt/sources.list . It’s kind of weird not being able to get the needed files from the official repos, but being able to get them from a guy’s mirror.

-then suddenly apt could see updates. sudo apt-get update and sudo apt full-upgrade found many packages that took about 20 minutes to download and install. Among these was -librem-ec-acpi-dkms

-then I could execute the instructions in these recent forum posts to edit charge_control_start_threshold (but I was only able to do it as Root by sudo su)

-immediately after editing charge_control_start_threshold as Root, I heard the high pitch sound of the power electronics started and the battery LED turned from amber to green, and the battery monitor shows it is charging

-this was frankly a bad out-of-the-box experience. I have some linux experience so I’m used to these issues but it’s probably too much for many users.

I had the same issue with the cat command or even vi not altering the file with just sudo. I had to use sudo su and do it as Root.

@Mikey92 this is marked solved - is that still the case?

I am using Pureboot and Qubes 4.04 on Librem14v1, and install the DKMS driver which somewhat improved things.

Important -> Which v1 did you receive, the factory hotfix with 3 additional conditioning capacitors or the fixed version? Mine is the model that had three soldered on conditioning capacitors (New Post: Librem 14 in Pictures), it is hidden under some tape near the left side USB port.

The DKMS driver has improved but not quite fixed it power loss, but I still can’t take it anywhere. It dies suddenly at around 30-40% now, it just means more time before total power loss on light web browsing loads. The battery lasts longer than ~15 minutes now though, more like an hour and a half then fail at about 30%. The DKMS improvement is that it’s actually charging the battery and now at least I can dial in my expectations of power loss a bit better.

1 Like

@joao.azevedo Please make a chapter about Librem 14 in https://docs.puri.sm because for new users to find useful information from this forum could be not simple as in the documentation.

2 Likes