Phosh 0.39.0 is out!

A new major release of Phosh is out. See the link below for a list of changes in individual components:

10 Likes

This is the first I’ve heard of a Phosh website. (Or maybe I just forgot about it.)

2 Likes

Kind of a cruel announcement when PureOS on the Librem 5 is stuck many versions behind :slight_smile:

6 Likes

Kind of agreed, but I have confidence it will be coming.

Meanwhile, I recall another forum user got 0.36 set up on Byzantium a while back:

I wouldn’t exactly recommend trying this without blessings from some Purism devs or at least an update from this user to see how it’s working out for them or if they ran into any problems.
I’m not sure what would happen now if this script were run.

Either way, the addition of folders in the App Menu is huge and I am really excited for this version.

4 Likes

First thing I did: sudo apt update … nothing …

I thought Purism was back-porting it when I saw this thread. I know about the release for 50h (and also that 0.39 had a delay to finish bigger things), but as long as I cannot install it without doing more than updating, I do not care much about.

4 Likes

@FranklyFlawless what version of Phosh it on Gnu Crimson now?

Thanks of advance.

1 Like
purism@pureos:~$ sudo apt list phosh --installed
[sudo] password for purism: 
phosh/landing,now 0.34.0-2pureos1 arm64 [installed,automatic]
2 Likes

What going on, why why why why 0.34.0??
:rage:

2 Likes

Probably due to unmet dependencies:

purism@pureos:~$ sudo apt list phosh-core --installed
[sudo] password for purism: 
phosh-core/now 24 arm64 [installed,upgradable to: 37]

Attempting to upgrade the package prints this output:

purism@pureos:~$ sudo apt upgrade phosh-core
Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created or been moved out of Incoming.
The following information may help to resolve the situation:

Unsatisfied dependencies:
 phosh-core : Depends: gnome-control-center (>= 1:44) but 1:43.6-2~deb12u1pureos1 is to be installed
              Depends: phoc (>= 0.37.0) but 0.33.0+ds-1pureos1 is to be installed
              Depends: phosh (>= 0.37.0) but 0.34.0-2pureos1 is to be installed
              Depends: phosh-mobile-tweaks (>= 0.37.0) but 0.34.0-2pureos1 is to be installed
              Recommends: gnome-contacts (>= 44) but 43.1-1 is to be installed
              Recommends: gnome-console (>= 44) but 43.0-2 is to be installed
              Recommends: phog but it is not going to be installed
              Recommends: phosh-mobile-settings (>= 0.37.0) but 0.34.0-1pureos1 is to be installed
              Recommends: xdg-desktop-portal-wlr but it is not going to be installed
Error: Broken packages
3 Likes

@spacemanspiffy I’m currently not updating these as backporting to Byzantium ate too much of my free time (as one usually also wants newer mobile settings (to arrange favorites, enable quick toggles, etc) which then requires newer libadwaita, which requires newer gtk, …) , sorry for not having better news.

4 Likes

Oh I definitely understand.

Do you happen to know what version would try to get installed if I were to run l5-fetch-next on my Byzantium phone? Looks like 0.37?

2 Likes

Any idea when we can move to crimson then?