Report: No ringing on my end when placing outbound calls, but the call goes through

Librem 5 with SIMple service.

Frequently when placing outbound calls, no ring indicator is audible to me. Then, after a few moments of silence, someone answers. So the call is being placed.

The call recipient obviously hears ringing on their end. Because, they answer, and we have a conversation. However, I heard no rings. I simply had to wait through the silence.

Occasionally, I do hear ringing when placing calls. But most often, I do not. Currently I still do not know whether this issue relates to the recipient network (i.e whether it’s Verizon users, or whatever).

This occurs whether I’m using my wired headphones, or not using them.

Aside from the absence of the ringing, the call proceeds as normal, decent sound quality, and I’m happy. But it’s a minor issue and I just thought I’d report it here.

1 Like

Just speaking from my own experience, I have the opposite frequency. Most outgoing calls I hear ringing and occasionally have silence but it connects.

So in short, I have no clue either, lol

Do you have VoLTE enabled? In some cases, with VoLTE enabled, there were issues with the ringtone not happening in an outbound call.

1 Like

Thanks for this. I’m still trying to find where/how I can disable VoLTE.

Depending on where you are in the world, disabling VoLTE may mean you are disabling all calling. I’m fairly certain that all major carriers and thus all MNVOs in the USA have stopped 3G service, and 4G calling is always VoLTE.

If you don’t know how disable it I’m pretty sure you didn’t enable it. You can’t do it by accident

1 Like

So it’s not VoLTE. Thanks. Issue persists.

@pureosuser, Maybe we can identify the problem with more info. Who is your cellular carrier?
When you make a phone call, does the 2G/3G/4G indicator at the top of the screen change?
Is it different when using cellular data?
What Linux kernel are you using? What cellular modem?

I’ve been using SIMple, which is not functioning at the moment. The 4G indicator stays persistent. I rarely use cellular data. Using the latest PureOS. I’ll be able to try again once the new network provider is activated.

I don’t know if it helps, but this also happens to me. I’m using Tello/T-Mobile and 4G. The kernel is 6.0.0-1-librem5. The modem is BM818-A1.

Was there a fix for this? My phone had the constant ringing problem with the 44 update. Not the “No ringing on my end” problem. That was working fine. I reverted back to 43 to help with the constant ringing problem. That’s when this problem started. I wasn’t too concerned because It was just annoying, the calls still went through. I thought the new update would fix whatever I did when reverting back to 43. It didn’t. Just looking for some suggestions.

Thanks