Status of Suspend for Librem 5

Well, there are still tests to be made and adding the components in userspace so that enabling/disabling is basically pressing a button from GNOME Settings

1 Like

Thank you for clarifying.

The Automatic Suspend option shows a disclaimer that it’s still experimental, and gives you two options to enable or not: (1) on battery power and (2) when plugged in.

Suspend on battery power can be set to 15, 20, 25, 30, or 45 minutes; 1 hour; 80, 90, or 100 minutes; or 2 hours. Same settings for when plugged in.

BTW, another nice addition to the settings: Show Battery Percentage. When enabled, it adds the percentage beside the icon in the notifications area. (But not on lock screen.)



EDIT: Note that the slowly-blinking blue LED is activated when suspend kicks in. And it stops blinking after a few minutes, apparently.

4 Likes

there is an issue to track that:

and:

5 Likes

Cool wallpaper.

Thanks. And thanks to Sicily. :sun_with_face:
Tutorial.

2 Likes

I’m on kernel 5.16.0-1 and did twice a suspend with:

apt list --installed 2>/dev/null | grep '^linux-image-.*-librem5'
linux-image-5.16.0-1-librem5/byzantium,now 5.16.11pureos2 arm64 [installed,automatic]

echo mem | sudo tee /sys/power/state

Result:

  • display goes off, SSH session frozen (which shows the suspend)
  • phone does not react on incoming call
  • display comes back on short press of power button
  • no further reaction on display nor SSH, only long press to reboot helps

UPDATE

I did two tests with automatic suspend after 15 minutes; result:

  • the device comes back with short press on power button and responds on input from touchscreen
  • an incoming call the Call app, but accepting the call is not possible (no reaction)

It normal that ssh go frozen because the wlan-card it under deep sleep too. Purism it trying to keep alive the wlan card under suspended but seem that redpine card it lacking for a special feature to fully turn ON.

To quick fix this you maybe need to buy a newer batch of modem from Purism store, but i don’t guarantee you it work 100% as my case mi modem work really good even under auto suspend from phosh-setting.

This issue does not happen with me but it could be happen because STR still on testing mode.

1 Like

In case you’re right, what’s the solution or end result?

I guess that Purism will perform a hack to enable the WLAN under Redpine card, to get data and notifications all the time under suspended mode but it will consume a little more battery than expected.
Also i guess that Purism will sale an enhanced wlan-card module to fully fix all the issues related to Redpine to get a better L5 funtions.

1 Like

I like that on auto suspend-to-ram the Librem 5 it notifies with a blue light that the device will quick enter to suspend-to-ram, it also notifies with a blue light that it is waking up from suspend-to-ram, if the blue light does not turn ON when wake up from suspend-to-ram it means the system crashed then it need a long press to power botton to turn off the machine.
At the moment there is only to 15 minutes at minimun to enter to suspend-to-ram, but i think that 5 minutes to go for suspend-to-ram will help to save more battery.

5 Likes

When does the countdown (of for example 15 minutes) start to run? On last touch on touch screen, and the 15 minutes start from scratch when I touch the touch screen? Or is this just a hard value from the moment of enable auto suspend with this number of minutes?

The countdown seems to start when the screen goes blank, whether by timeout or by pressing the power button. The blue LED slowly pulsates for 3 minutes, after which a press of the power button or volume button wakes it. That is, unless it doesn’t, as others have noted, myself included. Pressing one of those buttons also reactivates the blue LED momentarily before the screen awakes.

So I currently have it disabled. The first day I tested the function, I attempted to check the amount of battery drain and it seemed to be around 6% to 7% per hour, with WiFi and Location on, but mobile and bluetooth off. That’s somewhat better than power drain without suspend, if I’m not mistaken. (I only checked three suspend cycles of one hour each, so not very thorough.)

3 Likes

So there is no non-GUI setting to shorten the time to sleep? I guess I’m used to having a config file for everything in linux.

I did a test today, so on auto suspend-to-ram (configured to 15 minutes) the modem crash all time, but if a use the terminal “sudo systemctl suspend” the modem is not crashing…and i can receive Calls and SMS very good.
So auto suspend it not working with the modem on my case. @dos purism.dos

3 Likes

I’m guessing you could still set it how you want in the terminal…?

2 Likes

That’s what i’m wondering… someday i’ll have my L5 to check :smile:

2 Likes

I would test it, but in the current experimental state, I don’t want to accidentally brick anything. :wink:

2 Likes

I tested the commands it work! i configured to 1 minute. :smiley:
thank you @amarok

2 Likes

It crashing the modem to 1 minute too.

2 Likes