System does not have enough working memory

After a lot of monkeying around, I am able to boot my Thinkpad T550 on the PureOS 10.0 install disk. If I do a normal boot, it still comes up with Windows. Or I can interrupt the boot and come up on the install disk. But the Calamares part fails with “The system does not have enough working memory. At least 4GiB is required”.

My C disk is currently partitioned as
Disk 0 465GB
Disk 1 14GB.

There is nothing I need on the C drive. I fact, I want to wipe it.
How do I get rid of Windows and have PureOS use the full C drive?

This is talking about RAM.

So I can’t fully install PureOS unless I get additional RAM installed?

When up on windows, my PC has
Installed System Memory 4GB
Total System Memory 3.88GB
Available System Memory 1.73GB
It sounds like if I got rid of something that is using RAM, I would have just enough.

Its checking your total RAM capacity and deciding it isn’t enough (I imagine it sees 3.88 and then stops because that’s less than 4). The only thing using RAM when you’re running the installer is the live boot environment, but it doesn’t care about that.

So yes, your options are to either upgrade your RAM or use a lighter Linux distro like lubuntu or xubuntu.

See also: Installation (RAM)

Non working memory must be the result of recent lay-offs. Re-hire that memory and put it back to work!

It said it the install could continue but not everything might be installed so I tried that.
I installed PureOS in the same partition where Windows was. It was successful, supposedly.
Now I get “Preparing Automatic Repair” every time I try to boot up from the C drive.
This leads to these options:

  • Continue to Windows
  • Turn Off PC
  • Use Device
  • Troubleshoot
    Continue to Windows just leads back to “Preparing Automatic Repair”.
    There are lots a ways to go under Troubleshoot and I messed around with some of them
    but nothing seems to help.

It sounds like the windows bootloader is still active.

Are you trying to dual-boot?

1 Like

I am not trying to dual boot. I installed PureOS in the partition where Windows was.

1 Like

I would install again, but this time choose to erase disk instead of just overwriting the partition.

1 Like

When I tried the Erase option as suggested, the Next button remains grayed out so I can’t finish the install. This happens whether or not the Encryption option is selected.

1 Like

Post a picture of what you’re talking about.

There are several partitions that need to be created, actually three critical ones that will allow PureOS to run on here related laptop. Related thread/post is here: Installation failed - please help. As well and if any further explanation needed, we are here for you.

Yes, and I already recommended to @knurtsj, as not avoidable requirement (mandatory one) what needs to be done at first place:

But anyway and if Windows cannot be started again (and while Windows NTFS partitions are already locked) hopefully dd erase command (as linked within my previous post) will help there.

Mandatory as well:

My BIOS is set to Legacy only.
Here is a picture of where I am trying to do the Erase Disk in the Calamares part of the install and Next is grayed out.


1 Like

Please understand: Windows 10 & Co. will never allow you to run away from them on your own:

Therefore is: “I am trying to do the Erase Disk” quite wrong approach, please take this path:
sudo dd if=/dev/zero of=/dev/sd[x] bs=32M count=1

I did those two sudo command and was able to complete Calamares and come up on PureOS without using the install disk. So, thanks very much. I have no Wifi but its probably the lack of a driver. I will try plugging into a cable tomorrow.