Three issues bothering me right now: poor call audio, mobile data failures, misleading battery percentage

Thanks for this post @Skalman. It think that posts like this are very important for Purism to set the priorities.

2 Likes

Thanks, I marked your answer as “solution” because you summarised so nicely. However the data connection distruption issue is not really solved.

2 Likes

See for more info: Mobile data stops working, outgoing packets still sent but incoming packets no longer arrive (#328) · Issues · Librem5 / OS-issues · GitLab

In short: to make the mobile data connection stable do:

sudo -i
echo 5000 > /sys/devices/platform/soc@0/38200000.usb/xhci-hcd.4.auto/usb1/1-1/1-1.2/power/autosuspend_delay_ms
2 Likes

This seems like it could be the missing link! This should be getting trumpeted to all L5 users! I mean I get that it is a work around for another bug but if it works it will be glorious. I made the change and will report back my experience!

1 Like

At @janvlug link, @dos says, “Please report your findings at 1s. I’d like to avoid going back to 2s if possible, the difference in power consumption when the hub is active is quite big”, implying a power penalty. The suggestion here is to use 5 seconds.

I can report that even using 1s the power drain is significant. Just consider that if the default value is a half second (500) then by increasing that to a second, you are doubling the amount of time it can theoretically be active after idle.

Still this is a great development because it shows that the problem has been identified and work can continue on a real solution.

regarding the network dropping, does anyone know if it happens to correlate with enabling the toggle for “mobile broadband can be disabled to save power” from the power menu? Cause if the screen is off for an extended period of time, it seems like that disables the modem, only for it to reconnect when you use it again.
Edit: nevermind, this seems to specifically refer to the issues where it cuts out while being used. apologies.

No you are on to something. Power savings on the usb hub is the issue here. What is happening is that the default settings causes a bug to service which makes the cellular connection go stale. This is alleviated by raising the idle time, but has the negative effect of increased power consumption, and it is significant. However, this is just a work-a-round to not trigger the bug. It is not the real solution. But I guess if you are in a place where you really need a stable connection, you can just change this setting, and then when done revert back to the default value for power savings.

It does however work and work well.

This is just a software kill switch and has nothing to do with any automatic power saving.

That (admittedly confusing) sentence is a hint to the user, not a description of what may happen after switching the toggle on.

3 Likes

Understood, thanks!