Three issues bothering me right now: poor call audio, mobile data failures, misleading battery percentage

  • In calls the other end hears me fine and says the quality is good. Have you tried recording the mic audio when not in a call and listen back? You can do this with the sound recorder app from the store. Also, is VoLTE enabled?

  • Mobile data also stops for me once in a while, and it is bothering me. Enable and disable hw switch is enough for me to get it back.

  • Battery is fine for me. Have you tried recalibrating your battery? Battery dropping from 40% to 0 in a few minutes


Battery is fine for me, I think you should contact support on that.

My wife has reported bad call quality in large public places, and that an iphone give a better quality audio of me speaking.

I also occasionally have the mobile data fail," though it’s very rare. Maybe once a week?


Is it bad form to just post “+1”? :slight_smile: Because I have (almost) the same three issues…
Call quality is not always bad though. Maybe 30% of the times people complain and I really have to scream to get myself understood. Once I had to spell my name for a hotel booking, and even yelling alpha-bravo-charlie-style words I had to give up making myself understood.
Mobile data dropping: when I’m using the phone as a wireless hotspot I run a script that pings a host somewhere and tries pulling network down and back up when there’s no response. Often, though, that kills the entire mobile connection (not just data; the whole connectivity indicator disappears) and I have to reboot.
For me, battery starts accelerating at 10% only so it’s not so bad. Once I wanted to show Waydroid to a colleague at work, though and the battery display was just counting down from 10 to 0, one point per second, and then it died before the Android boot finished.


The battery percentage behaves strangely nowadays: it decreases at a seemingly steady pace from 100% to 90% to 80% and so on, but the phone suddenly shuts down already around 60% or so. Se when it shows 70% it really means it’s time to change it before it dies.

I’ve seen this on one unit which was plugged into the charger almost 24/7 as well.
To me it seems that the battery calibration kind of “drifts” towards higher values (since that is where it is operated most of the time?!)
You can remove and reinsert the battery and it should reset the calibration.
If you then do a couple of 0-100% charge cycles it should be a lot more accurate.

Poor call audio quality. I can hear the other person fine, the problem is in the other direction: very often the person I talk to complains that they have trouble hearing me. Note that on the L5 end you will not notice this unless the person you talk to tells you.

I used to get complaints about there being an echo. Lowering call volume (or using a headset) helped.

Mobile data connection suddenly stops working. This happens fairly often, usually at least once a day. I suspect this is due to some kernel bug(s). It starts working again if I reset the modem and restart NetworkManager.

Is toggling the HKS not enough?


You can check the battery’s health/calibration level using the Power Statistics app. Check the “Capacity” field (this is calculating the ratio between the “Energy when full” and the “Energy (design)” fields). If it’s not 100%, try recalibrating your battery and seeing if that resets it to 100% or close to it. If not, then your battery is possibly starting to degrade or is degraded.

You could also use the upower command but I won’t cover that here.


@Skalman I haven’t got a single issue that you have. Calls are great, nobody complained as for now, data is working fine, as far as I can see, and battery percentage is normal.

As other stated, try to reinsert battery, it might help with calibration.

For the call quality, it might be that your sound settings are off.
Try running
sudo rm -rf /var/lib/alsa/librem5*.state ~/.config/pulse
And reboot your phone.

This will erase your current sound settings, and on reboot, default ones will be created.

1 Like

I do not have issues with call quality. People have consistently said that I sound normal and the calls go off without a hitch.

Battery percentages are accurately displayed on mine, and what you have sounds very much like calibration drift. Removing the battery completely as instructed is the fastest way to have the BMS rebuild percentages, etc.

My only real issue is the cellular connection randomly dropping out with the OS not being aware of it. A HKS toggle always brings it back, but this is annoying, and I don’t want to prematurely wear out my cellular kill switch just to have reliable cellular connectivity.

It would be INFINITELY more preferrable to me if a software reset solution could be found. Ie: I run a script and it does similar things to the modem, without physically cutting power to it with the HKS.

One other annoying thing is that whenever the modem is getting reset via software, the micro sd card is reconnected, and this often times doesn’t work. It isn’t properly mounted.

I tried that now (using “gnome-sound-recorder”) and there is a background static noise, as if the microphone volume is too high. Looking at sound settings, there are three different choices for “Input Device”:

  • Handset Microphone - Built-in Audio
  • Stereo Microphones - Built-in Audio
  • Analog Input - Modem

I wonder, is the “Analog Input - Modem” the one that will matter for a phonecall?

Anyway, I never changed any of those settings since I last reflashed PureOS. All three microphone volume settings are set to the maximum. I have been hoping that using the default settings would be good.

Since quality is good for you, could you check what the microphone volume settings look like in your case?

Also, is VoLTE enabled?

No, I don’t think so, at least I did not do anything to enable it. Do you mean that having VoLTE enabled would be good or bad, regarding phonecall audio quality?

This indeed helped, thank you!

I have kept it plugged into the charger most of the time, so my case fits with what you described.

I used to get complaints about there being an echo. Lowering call volume (or using a headset) helped.

Could you explain exactly what you mean by “Lowering call volume” hare? Is that in sound settings, under “Input”? If so, which “Input Device”?

Mobile data connection suddenly stops working.

Is toggling the HKS not enough?

That can also work, however I much prefer to have a software solution, not involving the HKS. Most importantly, the bug(s) causing the issue should be found and fixed. I have been trying to debug the issue myself, but have not gotten very far with it yet. Not sure if things go wrong in the kernel (in which case we can fix it) or inside the closed-source modem firmware (in which case nothing can be done, I guess). One thing I aim to try to test is to use a different modem and see if the issue still appears then.

Where is the VoLTE enabling to be found? I cant find it.

So far my only lip biter is the Battery endurance. 7am-7pm it goes from 100% to 17% …with the unit HK switches in the off position and nothing enabled.

Thanks, I did this now after saving the old settings somewhere, the files were recreated after reboot as you say, and I can see they are different. The two first microphone volume settings (“Handset” and “Stereo”) are no longer at maximum, insted they are at about 40%. I will make some calls and see if the audio quality is better now.

(Earlier I thought I had default settings but it turns out I did not. I fooled myselt because I had reflashed the phone, which did restore defaults, but then after that I restored my old ~/.config directory from a backup copy because I wanted to keep some other settings, not realizing that doing so also restored audio-related settings.)

The following commands seem to work, at least most of the time:

sudo mmcli -m any --reset
sudo service NetworkManager restart

So having a script that checks if the cellular data connection has stopped working and runs the above commands in that case, might work. (But still only as an ugly workaround since all ongoing connections are probably lost when that happens, not very nice.)


Thanks, something like this is what I was looking for. This resets the USB hub that the wifi and cellular radios are connected to, because when you run the script it will drop wifi as well.

Works well though, and using it instead of the HKS is what I would prefer. I also prefer manually triggering it, because there can be so fringe cases in which I wouldn’t want the script to fire.

1 Like

Here is a screenshot of my sound settings right now. I am not sure if this is the default or not

VoLTE will give better call quality as the bandwidth is larger. However, the source mic audio must be fixed first. Have you tried another recording after resetting to default sound settings?

@FPJ you can install bm818 tools to enable VoLTE
sudo apt install bm818-tools


Thank you. Have a great weekend and be safe.


Could you explain exactly what you mean by “Lowering call volume” here?

I meant pressing the buttons for “volume down” during a call so it is not at 100%.
This already reduced complaints about echo A LOT.

Extra data point: I found call audio quality to be best when using headphones.

1 Like

Just wanted to say that this script is exactly what I was looking for. It works consistently. It doesn’t drop the SD card either, I think. I might be wrong.

But this is faster and easier than using the HKS.


I have been struggling with battery calibration for as long as I can remember, even when making a point not to charge the phone until it is close to empty. Seems the calibration continues to drift higher than the energy-full-design value in most cases anyway, as described in this post.

Doing complete drain/reharge cycles is very impractical with a phone where battery usually doesn’t last a full day, so is also constantly carrying a power bank.

For me, no calibration (i.e. after reinserting the battery) is better than the inevitable calibration drift that overestimates the remaining battery life. I think this is true for many L5 users, as I often read about the L5 battery going from 30%/40%/50% to zero in a matter of minutes.

Thanks for this post @Skalman. It think that posts like this are very important for Purism to set the priorities.