Trouble trying to use Jumpdrive: No blue LED, can't enter flash mode

Following @david.hamner 's instructions here, and here, I can’t get the Librem 5’s LED to turn blue-green, or enter flash mode. The phone either boots normally into phosh, or (apparently) fails to activate the display at all, as documented previously here. (So a lot of trial and error and rebooting.)

I did all this, as per David’s instructions:

Install

Then from either a cold start or a reboot, immediately after the power-on LED, I hold down the volume-up button, but no effect.

Any ideas, anyone, (especially from David)?

2 Likes

Have you noticed this thread about Jumpdrive?

1 Like

Yes, thanks. I’ve seen it before, and just read through it again, but I still can’t get into flash mode.

1 Like

I haven’t reviewed David’s repo shown above, but I had previously created a snippet to assist with setup on the host computer (using a PureOS live boot environment to ensure a clean starting point). The script echos various instructions to help the user perform the correct ritual on the L5 to boot into Jumpdrive:

1 Like

Thanks for the response. If I understand your script, you’re installing Jumpdrive on the computer and then running the script on the computer after putting the Librem 5 in flash mode and connecting it?

My issue is that I can’t get the phone in flash mode in the first place, in order to follow David’s simple tutorial to expose the L5’s storage (via Jumpdrive installed on the L5) to a connected computer.

P.S. I have successfully got into flash mode before, when I flashed byzantium for the first time, but for some reason it’s not working at the moment. I’ve tried dozens of times today.

1 Like

It installs uuu on the host computer and runs a script using the Jumpdrive repository to establish a connection with the L5, but the L5 is what’s running Jumpdrive to expose itself :see_no_evil: to the host. The rest of the script is used more as a reminder of the steps.

I just used this script last night to recover a corrupted /etc/fstab file on my phone. I’ve noticed that a successful Jumpdrive boot on my phone is noticeably more difficult to initiate when the phone is in an unbootable state (where the timing of the vol+, USB-C insert, battery insert, release vol+ is more fiddly). It took me a number of times to get it right, and it can admittedly be very frustrating. I had the best results when I performed the actions quickly - within a second or two. It sounds like your situation may be more nuanced, though…

2 Likes

@JCS You may want to use the artifacts from https://source.puri.sm/sebastiankrzyszkowiak/Jumpdrive instead of the tagged release. It’s just the upstream’s latest commit - the last tagged release still used a very old kernel that sometimes fails to probe eMMC and requires several retries, which got fixed years ago.

where the timing of the vol+, USB-C insert, battery insert, release vol+ is more fiddly

It’s not fiddly at all. All you need is to hold Vol+ while turning the phone on. The only difficulty comes from lack of any feedback other than on the host the phone is plugged into.

@amarok Are the volume buttons working correctly when booted in phosh?

immediately after the power-on LED

You need to do it before the LED goes green, and it will stay either red or disabled depending on charging status. Check lsusb on the host to see whether it’s actually on.

David’s instructions aren’t actually for booting into Jumpdrive using USB, but for installing it to use from u-boot. I’d recommend sticking to the normal procedure unless you’re familiar with u-boot. David’s method (well, it was actually a trick I once showed to him :laughing: ) does not use flashing mode at all.

4 Likes

Yep. No problems there.

Nearly impossible, unless…

…which does nothing on my Librem 5, confirmed by then connecting to the computer.

Good to know. (Since his video doesn’t indicate that in any way. :rofl: )

What is the blue-green LED he mentioned supposed to indicate?

OK, I will, because I’m not. :laughing:

I’m familiar with the usual battery-shuffle, claw-grip steps for the flashing procedure, but today I just wanted to learn how to use Jumpdrive to expose the storage to a computer. Not something I need at the moment, but I wanted to see how it’s done. Wasn’t planning on actually reflashing.

I do have this complication, though, so maybe I should reflash. Not sure if that would correct it, however.

1 Like

The thing is … the “battery-shuffle, claw-grip steps” are actually to put the phone in Serial Download mode. In that mode it will do whatever the host tells it (over USB). The host can tell it to

  • load a disk image over USB and use it to reflash the eMMC drive, or
  • load Jumpdrive over USB and then boot it, and thereby expose its disk or disks as USB mass storage device class devices (and also allow network access in to the phone), or
  • other things.
2 Likes

There must be something really obvious and simple that we’re missing, because if volume buttons work just fine while the phone is booted then there’s really no way that the button won’t be able to put the phone into flashing mode, as this is handled in hardware by SoC’s ROM before any kind of mutable software gets a chance to be executed. Technically you could disable it by burning e-fuses inside the ROM, but somehow I doubt that you have done that on your device :wink:

If you take the battery out, hold the Vol+ button and keep holding it while plugging USB-C in - what happens? Describe both the LED behavior and what happens on the host that you plug it into (what appears in dmesg and lsusb after plugging it in).

Try both USB-C orientations and make sure the same cable works fine on the same port when the phone is booted, so we know that the connection is good.

4 Likes

Worth throwing out there that I’ve encountered some USB-C cables that are not reversible for data as well as some that have other quirks of things not working right, may be worth trying another cable.

2 Likes

Absolutely nothing. No LED.

lsusb doesn’t show it.
dmesg does show Purism Librem 5.

Replacing battery does enable lsusb to see it as well. (As connecting to a power source does cause the L5 to power on involuntarily, and as I do have that issue where the screen frequently doesn’t activate on the first try, I took the extra trial-and-error step of getting the screen to activate and then booting into phosh, and shutting down, all while still connected, just to confirm the lsusb and dmesg output.)

I’m not sure why the procedure worked when I flashed byzantium over a year ago, but doesn’t seem to work now.

I tried both a Sony Android cable (which is what I used to reflash before) in both a USB3 and USB2 slot, in two orientations, and the standard Librem 5 cable in four different orientations. Same same.

3 Likes

Have you been using the sugested jumpdrive version from @dos ?

1 Like

So I can’t even get to the point where I would be able to use any Jumpdrive version, unfortunately.

P.S. My current goal was not to reflash the OS, but just to get some experience using Jumpdrive to expose the L5’s storage to a connected computer. But not being able to enter Serial Mode is the actual problem at this point.

2 Likes