Waydroid Installed but network not detected (librem 5 can though)


I’ve successfully installed Waydroid on my Librem 5 plus F-Droid on the Android emulation via linux terminal, however my LineageOS cannot detect my sim card, even though the PureOS can.

I’ve looked but couldn’t find this to be an issue with anyone else (sorry if I missed it).

So I was wondering what I can do to fix this issue. No point having waydroid without internet access.

Any help or guidance would be well appreciated. Thank you

Have you looked here: Anyone Successfully Run WayDroid on Librem 5?

I there a particular post I should be looking at. I’ve tried:

sudo systemctl start waydroid-container


sudo waydroid upgrade

but nothing changed, unfortunately

Hmm… I guess you have tried to reboot the L5 and start waydroid again?
It happens sometimes that waydroid starts with no network, a reboot has worked everytime I have experianced it.

I’m afraid I already have, yes. Before and after using the upgrade command

I’ve been following these instructions here, if it helps: https://source.puri.sm/-/snippets/1198

I’ll probably try re installing it again later

1 Like

Sad it didn’t worked. I don’t think I have any good advice back, unfortunately. :frowning:

I think I followed the same instructions and it is working for me.
Reinstalling seems like an options. I hope it will work out.

Waydroid cannot connect to the Sim card. However, it should be connecting to WiFi through Ethernet.

I recently tried re-installing, rebooting and everything and it’s still hanging on to the same problem.

Seeking help elsewhere too. Will update whenever I find a fix

You mean…like through the emulation/waydroid, not literally through a physical ethernet, right?

It’s just funny that I can install apps on waydroid via terminal (which requires internet) but I can’t cannot to any internet within waydroid itself.

Is there something that I am not getting here?


So the browser does not connect to the internet?

Well, that is through the L5’s WiFi.

'fraid not. Not internet access anywhere, especially from the f-droid app store

1 Like

I had tried connecting the waydroid to my devices wifi but even that doesn’t work

1 Like

Have you tried toggling these settings?

I just turned on the Ethernet tethering. It seemed to have done something, but still no internet.

Although the F-Droid store just keeps trying to update the repositories though

What I do is turn it on then off when I am having trouble connecting.:man_shrugging:

Nah, I’ve already tried that many times unfortunately

Any joy - with Waydroid wifi and Network - as in sim card?

Seems to be both the wifi and sim card.

I did find something online about the kernel potentially being an issue, as in granting it permission.

I share it once I get home