Wee things on Librem 14 that bug me

  • When I press the caps lock key, the time for the light to turn off is a wee bit longer than the time it takes for it to turn on. It just… bugs me. I don’t even know why.
  • The button right next to the power button says “Del” code for its main function and “Insert” as its secondary function, but I can’t seem to make the the button fire the “Insert” code.
  • When opening the Users page of the Gnome Settings program, I do not see the super user unlocking button, not even when logged in to the administrator user.

That is for now.

Some may or may not be upstream problems.

Thank you.

FYI I contacted Purism support about this and they confirmed the issue and are working on it with the developers, that was on July 4th.

You don’t know why it bugs you or you don’t know why the timing is different?

Based on grammar, he is saying he doesn’t know why it bugs him.

That said, I can understand that bothering you, although the insert button never sending that scan code is the main issue I see here.

The first 2 problems are most def a firmware bug that needs attention. Fortunately they don’t seem to be too critical.

Why it so bothers me. :-\

1 Like

I don’t even know why keyboards have cap locks keys… and to top it off they are one of the biggest keys? Strange

To lock capital letters when that is convenient for what you’re typing.

1 Like

lmao well of course… its just I’ve never seen anyone need this :smiley:

I think most touch-typists would probably disagree. It comes in handy for typing acronyms, too. Otherwise you’d either have to hold down the shift key to type all the letters, and potentially change hands for letters on the opposite side, or do a shift+letter every time, nearly doubling the amount of effort. :slight_smile:

On the other hand, I’ve seen lots of people who seem to think capitalization is unnecessary…or even punctuation. Lol!

(Especially on reddit.)

1 Like

I knew I forgot something!

Another thing, not so wee, that bugs me:

  • The audio jack does not work. I plug in my earphones and… nothing. It doesn’t even registers in Gnome’s Settings -> Sound.

p.s. how do I edit my original post? Does my ability to edit my own post vanish after a certain amount of time?

1 Like

This is going to sound a bit silly but it also comes in handy when typing with limited fingers because I am carrying too many other things e.g. on the phone.

1 Like

Known problem, potentially already fixed: Librem 14 ear bud headset output not working

1 Like

Or when holding a sandwich! :smile:

That solved it, thank you!

1 Like

Exactly. Phone in one hand. Sandwich in the other. A couple of loose fingers available for typing. So Caps Lock is used like a non-combining but locking Shift key (instead of Shift itself) e.g. to type “Caps Lock”, press Caps Lock, type c, press Caps Lock, type a, p, s, space, press Caps Lock, type l, press Caps Lock, …

Maybe I should take proper lunch breaks. :joy:


Anyone knows what’s up with the Insert key? :confused:


It is unfortunate that the “Solution” status of each thread is only binary, either solved or not.
One of the problems I did manage to solve by the above advice, but there are more on that list.
I haven’t yet checked if anyone opened other threads, one per each of these problems, but if none exist, maybe I should open a thread per each of these?

Yes, ideally each thread should deal with a single problem, making it easier for newcomers to find the solution.

1 Like