How to reset gnome to defaults?


#1

I tried enabling the “Applications menu” in “Extensions” in Gnome “Tweaks”. It doesn’t work, and now “Extnsions” shows a triangle with a “!” in it next to “Applications menu”.

How do I restore the Gnome state to its defaults?


#2

I had the same problem when I first received my Librem back in April. I did send a note to support in case others had this issue, but I reconstructed the scenario from memory here. I hope that helps you.

You may know this, but where I say to reinstall gnome-menus, use the --reinstall option on install. Otherwise, apt will not let you do it. E.g.

sudo apt --reinstall install gnome-menus

Topbar not showing icons
#3

Thanks for the tip. After reinstalling gnome-menus and rebooting, the “Applications menu” extension was on and working.


#4

I am glad that worked for you.