Librem 14: Dead/No Charge

Hi there,

I have a Librem 14v1, order date was in March, didn’t get it until late May (not Purism’s fault, just the joys of working in an Enterprise and the related politics).

On Saturday, my laptop, which spends most of its life on my desk, would not power on. The LEDs all flashed, the battery light flashed red. I tried both of my factory chargers and USB-C with no success. I was rushing out the door and had to grab a spare computer; quickly I sent a message to support.

This morning, I did not have any response from support. The laptop now does nothing. Seeing other forum posts about faulty batteries and EC problems I disconnected the battery, but that did not change anything. Being back at my office I responded to my original email and added the order number and additional detail.

Look, I get that this is a small, niche, company, but this is an easy ticket. Any other company would at least send me a UPS label to ship it back by now, or preferably cross-ship a replacement. I wasn’t even necessarily expecting that, but at least ACKNOWLEDGE your customer who is in a hard down situation.

I burned a lot of political capital with my employer to score this thing, and now I have to go with my tail between my legs and explain that not only did my special snowflake laptop fail, but I can’t even get support on it.

Is my expectation of support (at least acknowledge the customer and indicate next steps) out of line? It’s not like this is a throwaway Chromebook.

OK, I feel a little bit like a heel, they emailed me a couple hours ago and it got flagged as spam.

Still disappointing.

I do not own … rather I do not know what users are doing over there? Are Librem 14 users using USB-IF certified PD 20A/5A cable at all, etc.? Actually please understand this quite useful information: “If your laptop turn off automatically for several seconds or minutes, it is maybe caused by overcurrent/lowcurrent protection. If automatic turn off is caused by overcurrent protection, please close the screen of your laptop to continue charging.” Now let me “translate” this for you: “If your/used power supply (or powerbank) is not capable to provide enough current to your Librem 14, especially under 20% of its registered battery capacity, it is finding itself in, or rather initiates overcurrent protection on his side and not able to (re)charge your laptop with empty Li-ion battery (that might be easily requesting more than 20V/4A of juice from probably not adequate power supply.” Such behavior have nothing to do with the Librem 14 itself, IMO and hope that my approach isn’t misleading in any way (if not helpful).

@EasyMac308, please search further for another adequate solution/understanding within this Forum. For example read this post:

P.S. Just my two cents, not even close to some/relevant expert opinion.

1 Like

Dude, re-read what I posted. Heck, you even quoted the part you appear to have beef with.

I own two (2) official, purchased from Purism, Librem 14 chargers (standard barrel jack) which I tried. I didn’t mention it, but I did also confirm their output voltage with a multimeter. I also didn’t mention it, but the USB-C charger I tried was the 65W one from an old Macbook, which has plenty of “oomph” and the cable meets specs.

Not wanting to clutter the thread or confuse things further, I didn’t include it in my post, but I also tried a 100W PinePower USB-C power supply and my bench supply. I confirmed with an ammeter that the laptop was drawing 0A when plugged in or when I attempted to turn it on.

My device also lives on my desk 99.9% of the time, so it should not have been drained unless there was a problem (also mentioned in OP).

With all that said, was your lecture on USB-C and your admonition to search for another solution really appropriate?

Now I will confess that I missed the big thread you linked until after I posted this one and was perusing the forums; it didn’t come up in my initial search.

All of this is a moot point, since Purism support did reach out yesterday afternoon a couple of hours before I started this thread, but went to spam. We’re doing an RMA, so let’s see what happens, eh?


It wasn’t an admonition nor lecture. His first language isn’t English and he’s actually very polite. I see how what you read could easily be taken as sarcasm, but that’s not how @Quarnero rolls. He was legitimately trying to provide you with information you may have missed, and when he says “please” it means “I’m not issuing you a command,” not “please for heaven’s sake.” So don’t be mad, he just doesn’t speak English the way an American does (and once you get used to it, it’s actually pretty refreshing).


Fair enough, Gavaudan, I don’t know the personalities involved and I’ll yield to the regulars about whether it was how I took it or not. It is perhaps my own failing that I tend to take it personally when someone provides a response that (to me) indicates they didn’t read or hear what I said previously.

You’re dealing with strangers on the internet, and for that reason I wasn’t at all surprised by your reaction. I don’t even blame you for it, but civil discourse being the rarity it is these days, I wanted to make sure you can enjoy it when it does make an appearance. Worry not, there’s no ill will here.


Not to confuse others, PinePower USB-C port is rated up to 65W.

20×4 = 80 Watt. Anyway and as earlier and kindly noted, here is solution for 65W/0% combo:

You’re absolutely right, my bad. The PinePower is 120W total, but only 65W PD over the USB-C port.

The answer is in this thread. Hopefully your second one (like mine) works. Others have not been so lucky.


That’s also my hope. I convinced my employer to buy me something non-standard because I believe in Purism’s mission, free software, and privacy and security. If this becomes a series of lemons I’m going to have some explaining to do to my boss…


Update: They ended up RMAing the whole laptop. Timeline for those who care about such things:

8/6: Initial email to support (Saturday)
8/8: Initial response form support (Monday - went to spam).
8/9: RMA approved.
8/10: Shipped to Purism.
8/23: Replacement laptop shipped from Purism.
8/26: Scheduled delivery day (didn’t arrive - blame fedex)
8/27: First delivery attempt (missed by seven minutes. :P)
8/28: Successful delivery (Sunday).

So around three weeks, not too bad. The delays weren’t Purism’s fault. I wouldn’t say I was, “happy”, but the result was acceptable. Good job support team.

1 Like

Given things at work it took me a few weeks to get around to moving back in to my L14. Which then failed after a few days in exactly the same way: sitting at my desk, plugged into monitors, and using the factory-provided power supply.

I’ve shipped it back again, hoping for a diagnosis this time. One thing support suggested was that a couple of other customers saw similar behavior and that it might have something to do with having a Dell monitor plugged in via USB-C on one particular port. It’ll be interesting to see if anything comes of that.

1 Like

Got it back Friday, set it up today with a minimum number of peripherals (HDMI monitor, USB KB, unpowered USB hub, USB mouse) and it died again after less than an hour. That’s the third dead one in two months. I’m at a loss, and it sounds like Purism is, too. :confused:

I’m one of them. My problem was not battery dying though. Just that when the monitor was plugged in, whenever the laptop went to sleep, it entered a limbo state that only a forced reboot could fix. After a couple RMAs, I got a unit that works well regarding my Dell monitors. Seems there’s a bad batch.

1 Like

Please take a look at this video: Charging Librem 5 no longer works and let me know on which charging protocol you see (or rather you don’t see) there. Besides, I do enjoy bright sunny day today.

And if proprietary charging protocols still up your taste just do not even try to open related USB-DCP thread within this Forum:

Not sure what this has to do with my L14 problems since I don’t rely on USB-C charging, but thanks for bumping the topic.

Purism completed the third RMA (took a while this time), and I’ve been back online for a month or two with no additional problems, except the Qubes is now popping up the “Your battery is now charged” notification pretty frequently. I’m guessing they changed something about the charging profile, but I dunno.


That’s fine now. And in simple words, I just wanted to warn you not to use PinePower Desktop there (while 65W USB-PD protocol, as this looks likely to me, might be of very questionable 20V negotiation, if established at all, especially when Librem 14 off and/or its battery completely discharged, and while basically here related power supply based/manufactured on top of iLEPO technically similar products, I guess).

Besides, I’m glad to hear that your Librem 14 serves you well.

1 Like

It seems that you’re putting words into his mouth. Perhaps this is a “not native speaker” issue
and that you mean that you’re glad to hear that he has his Librem 14 back and it seems to be working again.

Whatever the case, I can’t help but to point out that it reads poorly and I don’t think that all of the
downtime from having 3 RMA’s over two months should be classified as “serves you well”.


I do admit this. Therefore, my exact point was (if not otherwise proved): “Just do not use PINEPOWER Destkop with any laptop in order to recharge its built-in battery”. There is nothing hidden there (while useless to be even tried to charge …), but if someone do not want to read carefully following non-questionable output:, I cannot translate everything “written” there either (and although problematic, perhaps, direct correlation to this thread topic isn’t that PinePower non-GaN power box is based on QC2.0 charging controller, 12V one, and as I do not want to even guess if WindowsOS might overcome this fact either). And please differentiate “nothing hidden” vs non-supported (when here linked USB meter output opened at all), especially if some charging protocol needs to be supported in order that battery charging functions properly.