Librem 5 does not boot without battery

Hello here,

while I am setting up my L5 I would like to use it without battery to avoid wearing it out.
Although the phone does not boot. I took out the battery and connected the original charger or another USB-C charger from my notebook, all I see is the led changing colors from green to orange and red (in a loop) and nothing else.
When the power button is hold down, the phone vibrates, but that’s it.
When the power and volume up buttons are pressed, the led starts to blink red and nothing else.

What do I need to do to get the phone to boot without battery?


Have you already disabled the WLan, Modem and Camera with the hardware killswitches?

1 Like

Thanks for the reply.

Yes, just tried and same looping behaviour

1 Like

Try to reset the device by holding the power button for 18 seconds with battery.

Is this to say you’re trying to use your computer to power the phone?

With the battery the Librem 5 boots without issues, will try to reset it anyway

Fixed my message, it is a USB-C charger/power supply which belongs to my notebook (not charging the phone using my notebooks USB ports). Sorry for the mis-understanding

Does it stay powered if you take the battery out after booting with battery in?


Yes! That worked twice… but it does not work every time :thinking:

Last edit: yes, it works every time, just do not put an USB-C HUB with HDMI or USB ports in between.

1 Like

Good! But it should still be able to boot up without battery - could you tell me what’s the output of cat /proc/cmdline?

1 Like

u_boot_version=2019.04-g17a6c2261c console=ttymxc0,115200 quiet security=apparmor splash plymouth.ignore-serial-consoles vt.global_cursor_default=0

1 Like

Would you be comfortable with trying a different u-boot version? I wonder if some changes we did recently (not in a currently released version) would make it better. If something goes wrong the phone will become unbootable, but it’s recoverable by using flashing tools (without having to do a full reflash).


I would be comfortable with that, yes


OK then - so install this deb:, then run:

sudo u-boot-install-librem5 /dev/mmcblk0

and then try booting without battery again (and make sure to try the attached charger as well, this one definitely works for me).


Alright, so first time it did not boot, then I turned the USB-C plug from the power supply around and it works now.

Thank you!


Today my Librem 5 stopped booting.
I tried this procedure for Evergreen:

Phone charged for over an hour, LED is still red, the temperature is normal but it does not boot. What are my options?

Unplug the cable and press the power button for about 18 seconds (or until the green LED shines up). Does it do anything then?


That step of disconnecting the charger was missing in the guide

* Unplug any USB device that might be connected to the phone
* Wait at least 1h for the battery to get some charge
* Press the power button untill the green indicator light shows and then release the power button

Sorry for messaging you and thanks for the solution!