Librem 5 SD card reader not working

At first, my Librem 5 sd card reader worked fine, but since I’ve reflashed the device (using the official reflash scripts), it no longer recognized micro SD cards. I’m not sure if it was the reimage that caused it, but I figured I’d mention it. I don’t seem to see anything relevant in dmesg when I plug in a card. I’ve tried shutting down, plugging in the card, then booting up, but still nothing. If i plug a sim card in, that still works fine. I’ve tried the sd card on another machine, so I know it works and is formatted fine.

Here’s what lsusb shows:
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0424:4041 Standard Microsystems Corp. Hub and media card controller
Bus 001 Device 002: ID 0424:2640 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Here’s what gnome Disks shows, but it shows this whether I have the sd card in or not. I believe it’s supposed to show up as /dev/sda right? (The actual SD card read at the top of the screenshot is the built-in 32GB disk for / and /boot)

Any ideas?

@nico202 reported not seeing the SD cards on a newly received L5 (with same behavior in Disks :

1 Like

I’m seeing the same behaviour. @amuser did you ever find a solution?

Edit - I did have this working. Not sure when it stopped working.

Yeah I contacted support and they’re in the process of replacing it now.