Status of Suspend for Librem 5

It was not included with PureOS it gets “patched” into the PureOS image at a specific offset after the image has been created.


5-6 hours mixed use, mixed mobile data and wifi. (pick up phone and unlock every ~10-30min and after phone has gone into suspend on battery).

A couple of observations:

  1. receives SMS messages during suspend,
  2. wakes up pushing power button while plugged in or when on battery power,
  3. reconnects quickly to 4G AT&T, takes a little longer for Wifi with VPN and known network in area,
  4. when briefly waking the phone the battery % status may not be up to date - i saw my ~35% battery go down to 0% in about 30 seconds,
  5. Suspend seems to actually work!
  6. Runs cool while suspended.
  7. when certain notifications are received cant tell which ones as indicated by notification LED colour (pink), on unlock from suspend it appears to automatically and quickly dismiss whatever notification was supposed to be there- i think that happens for non chatty related system notifications.
  8. when rebooting phone with external harddrive attached, used Gnome Disks app to format amd partition a 2.5" drive, the suspend menue disappears from settings and maybe even suspend function until reboot - very interesting,

    i mean it is still insane to me that i can format a harddrive with my L5, using an adapter USB-C to USB-A (blue superspeed), and another adapter that goes from USB-A to USB-B, and an adapter that can take an external 3.5"", or 2.5" hard drive!!

Things not tested:

  1. receive call while on suspend,
  2. what happens to backlight screen on notification of message.

What does not work (Nov 5th 2022):

  1. wakes up on alarm,

Some ideas for further optimization:

  1. Reaction to power button press is a little sluggish,
  2. Wifi of last known connected network could connect faster,
  3. Sometimes touch input is lost, probably a known bug, locking unlocking phone restores touch input,
  4. Do not wake screen on notification when SMS is received, only use sound and LED, same could be done for call, screen wakeup only when tapping screen (think sailfish double screen tap function to see notifications, or lockscreen)
  5. fix rotation sensor to not rotate screen when picking up the phone or putting it down on a table quickly (iphone filters those events out),
  6. Always assume portrait orientation with auto rotate on when waking from suspend, or when showing notifications while screen is locked, and/or phone in suspend temporarily waking up,
  7. sometimes on reconnect when wifi and vpn connect first and then the modem for mobile tries to connect to 4G then the access point selection is lost (no mobile data, roaming selected if previously selected) - manually selecting the mobile data access point restores the connection typically,
  8. When 7. happens the modem for 4G sometimes seems to start disconnecting / reconnecting repeatedly - toggling the modem power switch fixes that typically.

etc etc…


So another test after updating u-boot and PureOS, I confirm that the phone can’t be awaken by SMS or phone call while on Suspend to RAM.

What is strange: if the L5 is in STR mode, and I send a text message or make a call, the L5 screen wakes up but there is no notification of received text messages or missed calls, and the 4G signal bars are totally absent from the notification bar.

So the L5 can detect an activity but cannot display any notification and cannot ring, only the screen turns on. What could cause this issue ?

Thank you.


I have that same behavior with the following notification:
Automatic suspend

Computer will suspend very soon because of inactivity.

It even starts to blink blue/pink just before going to sleep.
I get caught by that many times which prevented the phone to actually go to sleep :wink:

1 Like

A number of messages in this thread had me confused or actively negated each other, but at the time of this writing, on a librem 5 running PureOS byzantium, this is what you should do (and this should be somehow clearly communicated to all librem 5 owners, I think):

  1. In a terminal, run cat /proc/cmdline to find the current version of the uboot bootloader on your device. If the version number starts with 2019, continue to the next step; if it starts with 2022, you don’t have to update.
  2. Run sudo apt update && sudo apt install u-boot-librem5 to install a package that can update the bootloader.
  3. Run sudo u-boot-install-librem5 /dev/mmcblk0 to update the bootloader.
  4. Reboot the phone via the GUI or run sudo reboot to start the phone using the newly updated bootloader.

No need for manual deb package downloads anymore!


Well your solutions was only possible recently, no before, but also ur solutions can not for testing new things of Das-.
Thank for updating this post.

Is there a special repo I need to add for that? On my phone, I get Unable to locate package u-boot-librem5.


Indeed, I was mistaken. Here’s a one-liner to install the latest version (replaces step 2):

wget && sudo apt install ./u-boot-librem5_2022.10-librem5.1_arm64.deb


Is there a reason this is not included in the regular update? Is this safe to run?


I have tried the U-boot update. My actual versions
u_boot_version 2022.10-gc4960dade2
Linux pureos 6.0.0-1-librem5 #1 SMP PREEMPT Mon Nov 7 21:26:38 UTC 2022 aarch64 GNU/Linux
Suspend and wake-ups by button looks working well, congratulation this is big enhancement. But when I use Mobile Settings Librem 5 suspend now or I manage suspend by setting and wait from the Setting Power setup then when I call, device does not wake up. Is is possible that it is again problem of older HW revision as in the GPS case?

same here btw auto suspend and wake is fine but manual suspend through mobile setting fails to wake, maybe file a mobile settings bug?

I also updated the uboot file. And similarly to others, I’m seeing improvements on the wake from suspend. Not a complete fix.

But, now, i’m noticing that if I’m in convergence mode, the phone charge rate is incredibly slow?! I’m using the same usb-pd that came with the phone to power the dock (the one purism sells for the phone). Before I updated the uboot, I didn’t notice this change. If I don’t use the dock, the same usb-pd cable charges the phone at the normal rate.

Anyone else experience this?

I’m using the same usb-pd that came with the phone to power the dock

I have similar experience but even before U-boot update. I have looked at negotiated parameters before, but I am not sure what has been there already.

Anyway, actual output of
cat /sys/bus/i2c/drivers/tps6598x/0-003f/typec/port0/power_operation_mode
is 3.0A
cat /sys/bus/i2c/drivers/tps6598x/0-003f/typec/port0/power_role
is source [sink]
so it looks good and cannot be probably better even with original adapter. Higher voltages are not enabled as said in another discussion etc… On the other hand even dock draw some power so s charging can be slower due to that.

What you want to look at is /sys/bus/i2c/drivers/tps6598x/0-003f/power_supply/tps6598x-source-psy-0-003f/current_max

or even /sys/class/power_supply/tps6598x-source-psy-0-003f/uevent - easier to remember with some help of tab-completion :wink:

1 Like

Thanks for clarification

This is only 1500000 on Vention Type-C (USB-C) to HDMI / 3x USB3.0 / RJ45 / SD / TF / 3.5mm / PD 0.15M Gray.

When power adapter connected directly, then it is 3000000. The question is, if the limit is given by Librem 5 or the dock has its power pass-through limit or dock knows that it has some own consumption and lowers rating to not exceed power adapter capability. I am not sure if it can be checked if the dock internally negotiated higher voltage with adapter. Purism adapter provides 18 W only at 12 and 9 VDC. On the other hand dock does not include stepdown converter to 5 VDC (only acceptable for Librem 5 for now) so probably choice of 5 VDC, 3A (15W) is only option. Question is, if it can declare for example 2.0 A to pass-trough a and use 5 W for itself. Gigabit ETHERNET is power hungry. HDMI should not be so big problem.

It’s what the dock offers to the phone at 5V.

Yes, I understand, but question is why the dock it lowers rating from 3A @ 5V to 1.5 A @ 5V. 7.5 W is a lot but on the other hand if it should have reserve to drive up to three own USB ports and ETHERNET, than it is in the fact right decision… But I have ports empty by now…

1 Like

I have tried experiment to power dock from 112 W power supply and Librem negotiates 1.5 A @ 5 V only as well. When I try to use I-TEC USB-C Metal Low Profile 4K Triple Display, Power Delivery 85W docking station with its its 112 W power supply, I gen only 0.5 A on Librem 5 side. When I use the same dock with Librem 5 adapter, I get again only 0.5 A. But this big dock is generally designed for big laptops, where it is able to power my DELL Latitude, so may it be on 5 V it uses only some basic minimal pass-through.

You might want to do few tests with providing power to Venton or other docking station from some power bank (preferably from USB-A port, especially if used power bank is not of 5V only type) and get negotiated 2000000 there (10W).

EDIT: As well, the same amount of 10W from some docking station we have reported here:

I tested today the suspend so the autosuspend or manualsuspend or appsuspend always wake up my Librem 5 all time. As i still not using L5 as a daily driver so the test was without modem ON.