Is there after purchase support?

I appreciate all the ideas people have here. A very good resource after reading through 145 FAQ questions and technical docs. That, is a long read!
But my Topic issue has become watered down. Now that I’ve learned a great deal more, and experience even more hardware issues, I’m starting this one so it’s back on topic and contains the major issues, so far.


1 - Phone battery discharges too fast.
2 - Phone takes 4 hours to charge, 1 hour to discharge. (rounding off),
3 - Unable to purchase another battery as I’m not in the US.
4 - Under the top right, bulb gets hot - could use it to keep my tea warm. But I have laptops that could nearly roast a pig.
It is IMO, quite possible that programs are running in the background (See “usage” that causes the heavy drain on the battery.

1 - Accessing “Usage” shows the CPU is cranking away at 78 - 84% while System runs at 24 - 30%+ and while watching, it fluctuates - of course - but totals are often over 100%
2 - Tapping is a unwanted leaning experience in that I need to tap slowly i.e. tap then count 1, 2, 3 seconds, tap next key. If I go any faster, the system halts for about 10 seconds, then shows the result of the tap. Getting past the encryption pass/phrase/word/code is a bad trip.
The second required pass/phrase/word/code is the same. It takes many tries of remembering to space taps out. It’s a nice sunny day.
3 - The screen being pre-set to 200% zoom leaves some phone pages to run off the side. There is no reading the invisible area, no scroll bars, no swiping ergo, cannot see some of the settings. If the phone could, I’d set it to 0% zoom, but then, it becomes unreadable for anyone.
4 - The touchy touch tap-screen and beleaguered swipe.
Briefly, taps are not always registered, and harder, softer, hold tap is as if it locked up. Only way is to power switch off , wait 60 seconds, back to the 2 unlock screens, and not touch/tap that again.
Too when tapping/typing in a word, there are pauses up to 5 - 6 seconds, and last 2 taps show up.
EXAMPLE: type/tap the word ‘vacation’, and it shows ‘io’ or ‘ion’ sometimes.Tap slowly, the word incorrect. These tests are done carefully so as taps are spaced 1 second apart, then takes at 3 seconds apart. The system hangs too often needing a reboot and trip down the password hole.
NOTE: Noticed the time between taps can grow to 8 seconds, but happens less often. Don’t worry, be happy.

It’s hard to believe this can do Internet with a CPU choking at 81% all-the-time. To me, it’s causing the delays, where even a 20 second delay before a tap is acted on. Ergo, something is using the resources that is fast draining the batter. I had other plans than hooking it to wall outlet and use it as a second landline. Growl, grumble, mumble.

While I wait for some additional help, I’ll continue through the obstacle course and hopefully, long enough to find where I can start the updates, patches, & upgrades. Maybe then it’ll be OK.

Suggestion. Do NOT sign up with a carrier until you’ve tried the updates/yadda and all is in good order - so far, then sign up and test the networking out.

Thanks for the read,


1 Like

Is there after purchase support?



In a Terminal window, try “htop”.

If it isn’t installed, you can install it with “sudo apt install htop”

I’m wondering if you are going to see the tracker processes running. Tracker indexes your system, and in my experience can sometimes take too long to run (and some people recommend disabling it completely, but certain things like gnome notes won’t work).

Anyways, that’s a CPU hog that can run in the background for quite a while.

Do you suggest I take the issues to them? I ask because I get mixed messages here, but with well meaning intentions I’m sure. Plus I do not have the equipment or know-how to start buying tools to measure the in/out power of a battery that won’t be replaced, a possessed touch screen, and of key taps working - with intermittent results.

No matter when, if I look at the desktop, and slide up, nothing happens for a few seconds. I’m no expert with phones - don’t even wanna be a expert. But sure as Hades need one.
There is s shop a hours drive that people rave about being good at repairing digital phones. $100.00 just to open and look at it. I’ll email support with all the issues and if cannot be fixed using the phone, then the techs nearby can try to make usable.
I empathize with those that waited a year or so for their phone and get one like this.

Yes. some of the problems are user related, like not knowing how to test the voltage in/out and don’t think I should have to learn that too.


1 Like

It’s a brand new phone just shipped from them so you are entitled to ask. Right? It could be that all your issues stem from one issue i.e. some process is running hard, causing excessive battery drain and causing poor responsiveness.

Otherwise, you could follow up on @leetaur’s suggestion.

1 Like

@Sharon I 2nd @irvinewade advice. don’t over think this. you bought a new device and it is having technical issues. It is possible you have defective hardware. who knows. Let the support team at Purism help you out. that is what they are there for.

the people here on the forum will help you get the most out of you working hardware. they can’t fix all problems though.


You should put every HKS down (as preventative)). Power off your phone and exercise taking out your BPP-L503 battery (once out once back, after being aware that you charged your phone before to at least 60%).

Let other people pay you $100.00 “just to open and look at it” (turn around and go back home).

After above done you should proceed as described in below thread post (not before) and there you’ll realize that you have all necessary tools nearby yourself, at your disposal (your hands, your initiative, BPP-L503 battery, recommended power supply, recommended USB-C cable, red LED light (that needs to be at some particular point off).

Now, after you admit that too many “things” bothered you unnecessarily (as brand new user, which is quite understandable) proceed to this thread: Graph of the battery charge level.

P.S. Might be that we see us tomorrow evening (it is your turn now). Otherwise and if you are lucky please accept every helping advice from @dos only, please provide exact description every time you give some feedback to him.

Did you mean remove and re-seat battery?

If he can test the battery with those tiny things that measure in out and minute variables bu removing the battery, testing it like in the pictures here and recommend a battery (as is the images here) then save me days, maybe weeks, maybe forever if I pay someone local to fix it. I don’t know why you’d be so opposed to that.

OK. I’m ready. Where they is the

Your’s is the last post (now mine?).

Yikes! Mine will charge from 40% to 100% in about an hour – even in the car.

That is strange… my Pinephone constantly did that sort of thing, but my L5 does not. The only thing similar for me is Gnome Web has taken to freezing the phone for about 1 to 2 minutes on occassion. It eventually un-seizes, but it particularly annoying. Of course, it still crashes fairly often with multiple tabs open.

I’m very happy with my L5, but I agree with @kms – you may have hardware (maybe software?) problems. I don’t have the problems with my L5 that you do. I’d be significantly less happy with it, if I did.

1 Like

I second this. I’d like to see if there’s a rogue application causing problems.

1 Like

However if it is running while it is charging and it is running hard enough to discharge in 1 hour then it is potentially going to take longer to charge. The only way to get to the bottom of it is with real data.

The test for charging would be to charge it while the phone is off. That takes whatever is going on on the phone out of the equation.

3 to 4 hours from 0% to 100% is not unexpected for the Librem 5.

Charging seems to slow down after 80%, so a better charging comparison would be 0% to 80%.

That’s complicated though because we have no idea what charging hardware you are using in the car - or what it negotiates with your phone. (I’m using the traditional accessories port of the car, which is capable of supplying 180W, and a suitable charger, so it will certainly be limited either by the charger or by the Librem 5, not by the car, rather than using a built-in USB-A port in the car which will probably be limited to 500 mA, barely enough to charge the battery if running the phone.)

@Sharon, I’ll repeat in short, when Librem 5 runs GUI and battery charging indicator turns off (you can even take Librem 5 battery out, GUI will still “run”, yet if battery percantage was 100% when you take it out and put back it will show around 89%, yet red LED light will turns out soon again), please power it off and check if red light again on (if charging indicator on charge BPP-L503 battery until charging indicator turns off). Press power button and go back to GUI and if inserted battery charging indicator on repeat process (linked and related thread is having 37 post and I do not need to read those again, but you might just while free of charge). Please check related values with upower -d again just while I guess that you are having issue with (if your related output thinks it is cca. 1.9 times greater than energy-full-design = 13.8572 Wh):

And when you get similar “numbers” (even if capacity slightly below 100%) to the below ones (without any extra tools) you’ll be done ( ready for some other question, I hope):

I don’t have a clue yet what you’re talking about. Give me day to research it.

1 Like

I have no idea until you told me. Right?

Maybe Pinephone and L5 can use some of the same parts? What ever.

I’m glad to see someone else would like to see if a rogue is causing it. I hope so. It might dispel my thoughts of this L5 of being possessed. :slight_smile:

First, I typoed that – I meant 2 hours, which I verified during my morning commute today. This charging performance is with the screen at about 90% brightness (I wear sunglasses because it is so bright in the desert) and podcasts running at about 90% volume (I control the final sound level from my car head unit).

I’m using a joe blow Amazon charger that I’ve had about five years. I don’t know the exact specs, but I suppose I can try to mine my purchase history. It does have three ports labeled iPhone 2A and one labeled iPad 3A.

More important would be to ask the Librem 5 what it negotiated with the charger. It looks as if your charger has ports for (up to) 2 Amps and (up to) 3 Amps (presumed 5V) but we don’t know what charging protocols it offers and what the negotiation resulted in. Based on “2 hours from 40% to 100%” I would say that it is working well.

Agreed. What command should I run?

BTW, the charger is an EZOPower 4.8A High Output, ourchaded in 2014. I plug the L5 into the “iPad” port.

Regardless of how fast it charges, if I don’t plug it in while podding, surfing the web or using Calls, the phone does discharge rapidly.

1 Like

Regardless, please start to search for old stock of Belkin F8J251 (for example, yet the one with very precise description what to use there) and once you received it please connect your Librem 5 phone to USB-C port (please stop current experimentation there ASAP):

cat /sys/class/power_supply/tps6598x-source-psy-0-003f/uevent