[MyL5] Australia/New Zealand

Hi @irvinewade

Just wondering when did you place your order for the L5?

Sorry if you answered this already, but I could not find if answered else where.


Early September 2017. There are “countdown” topics for Europe and for the US but as there isn’t one for A/NZ (too few customers?) I didn’t bother to post that info.

1 Like

Today I tested: Some new toys

With the Ever Given having been dislodged, my toys arrived. :wink:

One thing I tested is a USB 3.0 to gigabit ethernet adapter. Mine has a USB-A male connector, so I can use it with any random computer, or in a dock connected to the Librem 5, or via a USB-A female to USB-C male adapter direct to the Librem 5.

Both ways of connecting to the Librem 5 worked out-of-the-box. Tick.

Another thing I tested is a USB-C external SSD drive, for connection direct to the Librem 5. That worked out-of-the-box, other than that the drive arrived formatted as exfat and the Librem 5 doesn’t have support for that type of file system out-of-the-box. Reformatting the drive as ext4 fixed that. Tick.

While this can’t be used to make a reliable backup of the eMMC drive, it can be used to back up stuff on the uSD card and can be used for casual backup of user files on the eMMC drive, and can be used for sneakernet (moving files on or off the Librem 5).

The third toy that I tested was a dock. That should allow charging of the Librem 5 (USB-C power passthrough) while connected to the above devices and (not tested) connection to an HDMI monitor. While charging worked, and the above devices worked, after a while the red light began to flash, charging stopped and the Librem 5 appeared to overheat. So I powered off and gave it a little rest. Needs more testing.


Why not? I don’t understand.

Because the root file system (the eMMC drive) is not quiesced. Files on it are changing in a manner that is uncoordinated with the process that is copying files onto the external drive. You will probably get lucky anyway but …

The right way to do this is either

  • to use a root file system type that supports snapshots (may or may not be possible currently but not the case for me), or
  • to boot from another disk so that the eMMC drive is not mounted (not currently possible? although you can probably go close if you are an extra advanced user), or
  • to use JumpDrive to expose the local drives via USB (and hence do the backup on your PC, maybe the only option currently).

Maybe I overlooked some options. Let’s see if anyone jumps in.


I’ve reconnected the dock but without the external drive and it is charging satisfactorily and the temperature is normal.

Edit: No. Gone crazy again. :frowning:

FYI - there’s only one microphone at the bottom of the phone, the second thing you marked as a mic is actually a speaker. The second microphone is at the top near the headphone jack. Also, there’s proximity and ambient light sensor next to the selfie cam and you’re missing the smartcard slot as well.


Thanks. Here’s an updated diagram.


Today I tested … upgrading the firmware on the USB-C PD controller. :open_mouth: (emoji indicates scary concern about bricking the device)

The command to check the firmware version is

sudo cat /sys/kernel/debug/tps6598x/0-003f/customer_use

and that was giving


which I took to mean version 0.1.1 - and that is not the latest.

The update procedure is a little untidy for me because my distro (Ubuntu) does not include uuu so I had to build uuu from source using the info from Purism. If anyone else needs to do this, I suggest replying here for more info.

I will note something from Purism’s web site: IMPORTANT: The firmware is for the Evergreen and Dogwood batches. Don’t flash it to other devices.

Otherwise the needed info is here: https://source.puri.sm/Librem5/firmware-tps6598x-nonfree/-/tree/master

I don’t have a USB-C port on my computer, so I had to use a USB-C Male to USB-A Male cable that I had lying around (and that I connected directly into a USB 3.0 port on my computer). I would suppose that the update procedure might try to make the most limited demands on the USB port but I didn’t push it (e.g. by trying a USB 2.0 port or by trying to do it through a hub).

While connected for update, the Librem 5 showed up with lsusb as:

Bus 999 Device 999: ID 1fc9:012b NXP Semiconductors i.MX 8M Dual/8M QuadLite/8M Quad Serial Downloader

where obviously the bus number and device number will be different on your computer.

The update failed (harmlessly?) the first time due to not running the script as root (and the Purism doco doesn’t specifically mention this). The reasonable error was:

Fail Failure open usb device,Try sudo uuu

Maybe a udev rule on my computer would avoid that problem but I don’t anticipate doing this very often so couldn’t be bothered, so sudo ... it is.

After the update, and rebooting the phone, the above cat command gives


which I took to mean 0.2.0 - so that looks like winning!


Any specific improvement(s) you expect to get from doing that? Do you notice any difference afterwards other than the new firmware version number?


I was wondering whether anyone would ask. I had two motivations.

  1. Charging through my dock doesn’t work properly. I figured that before putting the dock in a drawer and spending money on another dock, it would be best to test again with the latest firmware.
  2. I want to play around with backup via Jumpdrive, so I need to have uuu installed / built anyway.

So the firmware upgrade did not help, charging through the dock is still not working afterwards?

I haven’t retested the dock yet because I will want to test normal charging (via the Purism-supplied charger) first, just to make sure that there’s no regression there, and then maybe tomorrow I will try the dock again.


One oddity … I don’t know whether this is a result of a PureOS software change or a result of the firmware update or something else I have done :wink: … it seems like the battery is now charging to a higher level. With a 4500 mAh battery, previously it seemed as if it is calling about 3800 mAh 100%, whereas now it seems as if it is calling about 4300 mAh 100%.


So the score at the moment is:

Before the update: failures 2 / 2
After the update: successes 1 / 1

with the caution that the phone software is changing all the time too (and did change), so any observed improvement may be bogus / chance / coincidence / unrelated / real. Clearly I need more data.

If charging via the dock holds up then that gives me another win because it means I can connect the phone via ethernet while charging and work around the WiFi signal problems that I have at the charging station - thereby allowing me to be logged in remotely during charging, doing things, and to monitor the progress of charging remotely.

1 Like

Perhaps that will be of any use…?


Maybe. We’ll see. The actual topic for that is: Librem 5 Wi-Fi performance

Today I tested … Jumpdrive and doing a reliable backup

TLDR: Nice one, @dos. Worked like a treat.

As with updating the USB-C PD controller firmware, this is a little untidy because I am using Ubuntu. Now multiply that untidiness by 10. Ubuntu certainly doesn’t come with the necessary toolchain packages installed and nor is there a definitive list of what needs to be installed. So there is an element of trial and error. If anyone else wants to do this, I suggest replying here for more info.

This is a multi-hour odyssey (basically 5 hours). It involves downloading around half a gigabyte of stuff - and then compiling a lot of stuff. If you don’t have a fourth-world internet connection and if you have a faster computer, you may do a lot better than 5 hours. Of course all of this is one-off pain.

Once it is all built … Jumpdrive boots in an embarrassingly short amount of time, perhaps a second or two. :slight_smile: So fight the toolchain for 5 hours and then two seconds later your phone is running Jumpdrive. :joy:

As before, the one line shell script to load Jumpdrive into the Librem 5 requires root access. (sudo ...)

With Jumpdrive booted on the phone, on my computer sda was the eMMC drive and sdb was the uSD card. YMMV.

Warning: Ubuntu automounts both drives and in the case of the eMMC drive both partitions. So if you intend to backup the eMMC drive then make sure that you umount it (sda1 and sda2) before starting the backup.

I chose to do the backup by piping dd through gzip. For me that meant that I could backup the 31 GB eMMC drive in 9 minutes at 58 MB/s producing a 2.9 GB file. That is fast enough to encourage backups actually to be done. No doubt as I put more ‘stuff’ on the phone, it will take longer and produce a larger file.

I consider a reliable backup to be essential. I would not put information on a computer that I couldn’t reliably backup.

Warning … off the top of my head: gunzip --list malfunctions (presents incorrect information) when the original file exceeds 4 GB (as it does here). That can be safely ignored.

It looked to me (big disclaimers apply) that Jumpdrive contains most of an entire Linux kernel. As a consequence, it is possible to telnet in to the Librem 5 and look around and do stuff. This could be quite useful if your Linux install on the eMMC drive is broken but not so broken that you just want to restore from backup.

For example, if you forget the password for the purism account and haven’t created another account, you could fix the password. Of course you could also do that directly on the main computer since it can mount the eMMC drive, and assuming that your main computer is running Linux.


@irvinewade, If you have the time, it would be cool it you wrote down all the steps for doing a backup on the community wiki.

I wonder if this is possible on Windows and Mac computers. Eventually we are going to have people using the L5 who don’t have Linux PCs. I see that uuu is a package in bullseye so eventually it will get to the Debian derivatives. We need to get it into all the major parent distros (Arch, Fedora, OpenSUSE, Gentoo). Is there a way to suggest packages for inclusion in Arch, Fedora, OpenSUSE, Gentoo, etc?

1 Like