[MyL5] Received my Librem 5 (Evergreen)

That’s correct.

Reducing the scale also makes all the buttons and controls smaller and sometimes closer together, so a stylus could help there, too.

I haven’t tried a bluetooth keyboard yet; I don’t have one handy. @dcz, I guess it would work, right?

From what I read on Matrix, it should. I don’t have one either.

1 Like

How far in advance did you get an email asking you to confirm the shipping address?

1 Like

A maybe interesting observation: In the Files App, just as on any personal computer, you can move objects (docs, pics, etc.) to a level called “Desktop” or even make a “Link To” (i.e. shortcut) for said object, but it doesn’t actually display anywhere in a visible form on the phone’s app list screen or on the wallpaper screen.

Not that I would expect it, too. Just a fun fact.

A future capability, maybe…?


@amarok: Just wondering whether you have tested the GPS.

Is there any app that you have used that shows that it is working / not working? (Obviously the camera app would be one such but the camera itself is not ready.) I suppose you would also have had to have ventured outside of the house, which for COVID and other reasons, may not have happened yet.

1 Like

No; I don’t really see a way to test it (if it’s even ready as a function yet). There’s no setting yet for “Location” like you would find on Android or iOS, as far as I know.


@amarok you could install Gnome Maps or PureMaps (from Flathub), switch off Wifi and start the map app and see if it can locate your position?


I windet if Therese isn’t any CLI tool which prints coordinates.

@kieran, @db579, @prolog
I installed Maps using @Skalman’s instructions here: GNOME Maps debugging adventures on the Librem 5 (Thanks Skalman! My first time with flathub/flatpak!)

Map displays well. When I tell it to find my location, it pulls up a dialog telling me to enable location services, with a button that takes me nowhere. (Still no official Location settings in the phone’s menu.)

Hopefully, something official will be implemented before long.


Thanks for the test. Hopefully soon then!

@kieran, @db579, @prolog
Just realized there IS a Location Services in the settings, and it’s On, but it never helped with Maps. Sorry about the misinformation! I suspect it’s just not implemented yet.


1 Like

Finally remembered to get and test the second Q heifer but no sign of the double-tap or did not work at all. Was it suppose to be included in the plain amber phone images (6044, 6119, updated)…?

FYI a kernel update has just arrived that enables proper USB PD current negotiation :slight_smile:


Thank you for the update! Does fast charge degrade the battery faster? If so, can we manually choose the charge rate?

1 Like

Yes, you could do that already before as well:

sudo i2cset -f -y 3 0x6a 0x00 <VALUE>

where <VALUE> is between 0x00 (100mA) and 0x3f (3.25A). See https://www.ti.com/lit/ds/symlink/bq25895.pdf page 32. You can verify the currently set value with

cat /sys/class/power_supply/bq25890-charger/input_current_limit

This is also useful to set input current limit to a higher value than the default 500mA when using USB-A chargers.


If I Set it that way, how to get then back to the proper USB PD current negotiation?
Just remove the USB-C cable?