List of Apps that fit and function well [Post them here.]

thx! i will do that

I don’t know how to use Gnome Calendar v43.0 with built-in screen of librem5:

Yes, the developer already fixed it.

1 Like

File Shredder (flatpak):

(Up to 25 passes possible)

Kudos to Alan Beveridge, @tobias.bernard, noëlle, and David Lapshin. :clap:


I was under the impression “shredding” was kinda pointless on a journaling filesystem or any kind of wear-leveling medium. Or has that been overcome?


Clock (KDE Flatpak):

Sweeping seconds hand:

Authors: Devin Lin, Han Young


Just tested the Geary Flatpak app and works better and is very smooth! The pureos deb version needs to be updated.

1 Like

BM818-tools (PureOS package to enable VoLTE):
sudo apt install BM818-tools
sudo apt update
(apply any package upgrades or dependencies)

Reboot phone.

EDIT: To test, while a call is in progress, open Terminal, type the command:
sudo socat - /dev/ttyUSB3,crnl

Enter your password.

Then this:

It should return this, if VoLTE is in use:


Looks like that same thing is under “Check for VoLTE” does that mean it does it for you?

Yes, it works. “4G” indicator remains in notification area during calls, as well. (For my Ting SIM, at least.)

I had to make volume adjustments, by the way. (To remove some noise from touching the phone.) Calls sound good.

1 Like

In order to get soundcloud to work on your Librem 5 in the terminal for yt-dlp you have to:

sudo install pip
pip install yt-dlp

This downloads all the phonica record mix series! The link is created by going online or through a soundcloud app and select share the stream, copy link and it will generate these static links.

The most annoying thing is actually trying to login to SoundCloud since the spam robot blocker does not allow login, even with VPN off, firefox fingerprinting prevention, and any other blocker off. So annoying- you have to use a device like an iPhone to even login.

It downloads all the streams in the /Home folder and not sure yt-dlp has a setting to define the folder the stream is supposed to be downloaded in?

1 Like

Looks like you’re using an older firmware version than me, so I wonder if something broke with the new firmware? I cannot make VoLTE calls even though everything is enabled to do so.

1 Like

Yep. So it seems.

See: BM818 Modem Firmware version

you maybe using the newest firmware using the commands shown whats your output?

In the terminal:

mmcli -L

then with output … /Modem/1…

mmcli --modem=1


firmware revision: MPSS.J0.2.0.2.c1.1-0032-9607_GENNS_PACK-1 1 [Feb 25 2019 01:00:00]

Which is the newest firmware for my US based modem as of Feb 2023.

See: VoLTE support progress

1 Like

The firmware revision from my newly installed BM818-A1 card (that I recently purchased because I was experiencing unsolvable SMS/MMS problems, and which solved my problems) is:

firmware revision: MPSS.J0.2.0.2.c1.1-0032-9607_GENNS_PACK-1.351938.1 1 [Nov 26 2020 02:00:00]

1 Like

Probably best to transfer this discussion to the VoLTE progress thread, so as to keep this thread focused on app demos.
Thanks. :slight_smile:


This is what I have as well.

Grpn Calculator is a Reverse Polish Notation calculator for you RPN heads out there.
$ sudo apt install grpn

This is the opening screen:

Tapping on “File” at the upper left corner show a pop-up menu:

“Clear” resets the calculator so that all numbers in the stack are cleared.
“Options” brings up the calculator’s settings:

Missing from the calculator is a key-click option to give audio feedback on key presses.
The application fits without issue on the L5 screen, without need for scaling.
However, Byzantium doesn’t classify it as a mobile-friendly app, for some reason.
Apart from that, it’s a welcome addition to my L5.


Just got motivated to try LyX, and it is fully functional on mobile!

This shows selecting items off the screen on the toolbar.

This shows that selecting a footnote via touch opens the footnote edit view.

This shows that outline view might not be too usable, but note that all the text on the right is fit to the visible area. Note: I had trouble clicking the upper right corner ‘x’, but could still easily close the outline from the toolbar view menu.