[MyL5] Australia/New Zealand

Hi, I am about to order a Librem phone from Aus. Can you tell me what the option for “Modem” is or should be? Sorry I am very un techy. Also what is the wait time appox?


Tested OK for calls / text / data on Vodafone’s network and on Telstra’s network. I haven’t got around to testing on Optus’s network yet, although I am not expecting problems.

I don’t really know. Not short. The answer may become clearer in a week or so. Purism has to clear a global backlog of, I would suppose, thousands of phones.

1 Like

Thanks Irvine,
I will order the phone and look forward to its arrival.
Cheers Gerzy

1 Like

Today I tested: Dictionary

I was going for a fully offline install i.e. install dictionaries locally, with localhost dictionary protocol (RFC 2229) server, and the dictionary client (command line and GUI). (The point of the offline install is twofold 1. works with slow, flaky or non-existent internet connection 2. the privacy benefit of not sharing my word lookups with the internet.)

Works more or less. In the GUI the output is annoyingly slightly wider than the screen. That’s with the sidebar disabled, since otherwise it’s never going to fit.

One thing that I couldn’t work out is how to get the GUI to ask the server to search all dictionaries. This works at the command line (by default). This is functionality of the dictionary protocol (specify * for the dictionary) but the GUI always seems to have one dictionary selected for use.


More comprehensive testing:

uSD card: SanDisk Ultra C10 U1 512 GB

read test with: hdparm -t /dev/sda
write test with: dd if=/dev/zero of=test bs=1048576 count=200 conv=fdatasync

(speeds in MB/s meaning decimal MB, not that it makes a huge difference)

With the card in a USB 3.0 card reader connected to a USB 3.0 port in a middle-of-the-range x86 computer …

read: about 85 MB/s
write: about 37 MB/s

With the card moved into the Librem 5 …

read: about 7 MB/s
write: about 10 MB/s

read speed rises to 11 - 12 MB/s if tested with

dd bs=1M count=200 iflag=direct if=test of=/dev/null

where test is a 200 MiB file on the uSD card. Create with:
dd if=/dev/zero of=test bs=1M count=200 conv=fdatasync


Redoing the test of the eMMC drive but using only dd and using a 600 MiB file …

read: about 57 MB/s
write: about 22 MB/s

That’s better!


Did you rate your experiences (UX) here?

Today I tested: Contacts Importer

My starting point was 200+ contacts as schema valid LDAP data in LDIF format.

I thought the easy way to do this would be: import as a new address book into Thunderbird, then export address book as VCF, then scp the VCF file to the Librem 5, then use Contacts Importer.

And that did basically work. Certainly saved a lot of error prone typing!!

On the other hand, the original content wasn’t perfect and, as expected, the GIGO principle applies.

Other comments:

  • Thunderbird produced VCF 4.0 and I wasn’t sure whether Contacts Importer would support that version, but it seemed to go OK.
  • Company contacts, as opposed to individual contacts, all imported with a unique name of the form system-address-book:pas-id-uuid and I had to key in the name by hand (but that’s not so important - I was more worried about error prone typing in phone numbers). The actual problem crept in during the Thunderbird step.

I’m declaring victory on that.


Hi @irvinewade

Just wondering when did you place your order for the L5?

Sorry if you answered this already, but I could not find if answered else where.


Early September 2017. There are “countdown” topics for Europe and for the US but as there isn’t one for A/NZ (too few customers?) I didn’t bother to post that info.

1 Like

Today I tested: Some new toys

With the Ever Given having been dislodged, my toys arrived. :wink:

One thing I tested is a USB 3.0 to gigabit ethernet adapter. Mine has a USB-A male connector, so I can use it with any random computer, or in a dock connected to the Librem 5, or via a USB-A female to USB-C male adapter direct to the Librem 5.

Both ways of connecting to the Librem 5 worked out-of-the-box. Tick.

Another thing I tested is a USB-C external SSD drive, for connection direct to the Librem 5. That worked out-of-the-box, other than that the drive arrived formatted as exfat and the Librem 5 doesn’t have support for that type of file system out-of-the-box. Reformatting the drive as ext4 fixed that. Tick.

While this can’t be used to make a reliable backup of the eMMC drive, it can be used to back up stuff on the uSD card and can be used for casual backup of user files on the eMMC drive, and can be used for sneakernet (moving files on or off the Librem 5).

The third toy that I tested was a dock. That should allow charging of the Librem 5 (USB-C power passthrough) while connected to the above devices and (not tested) connection to an HDMI monitor. While charging worked, and the above devices worked, after a while the red light began to flash, charging stopped and the Librem 5 appeared to overheat. So I powered off and gave it a little rest. Needs more testing.


Why not? I don’t understand.

Because the root file system (the eMMC drive) is not quiesced. Files on it are changing in a manner that is uncoordinated with the process that is copying files onto the external drive. You will probably get lucky anyway but …

The right way to do this is either

  • to use a root file system type that supports snapshots (may or may not be possible currently but not the case for me), or
  • to boot from another disk so that the eMMC drive is not mounted (not currently possible? although you can probably go close if you are an extra advanced user), or
  • to use JumpDrive to expose the local drives via USB (and hence do the backup on your PC, maybe the only option currently).

Maybe I overlooked some options. Let’s see if anyone jumps in.


I’ve reconnected the dock but without the external drive and it is charging satisfactorily and the temperature is normal.

Edit: No. Gone crazy again. :frowning:

FYI - there’s only one microphone at the bottom of the phone, the second thing you marked as a mic is actually a speaker. The second microphone is at the top near the headphone jack. Also, there’s proximity and ambient light sensor next to the selfie cam and you’re missing the smartcard slot as well.


Thanks. Here’s an updated diagram.


Today I tested … upgrading the firmware on the USB-C PD controller. :open_mouth: (emoji indicates scary concern about bricking the device)

The command to check the firmware version is

sudo cat /sys/kernel/debug/tps6598x/0-003f/customer_use

and that was giving


which I took to mean version 0.1.1 - and that is not the latest.

The update procedure is a little untidy for me because my distro (Ubuntu) does not include uuu so I had to build uuu from source using the info from Purism. If anyone else needs to do this, I suggest replying here for more info.

I will note something from Purism’s web site: IMPORTANT: The firmware is for the Evergreen and Dogwood batches. Don’t flash it to other devices.

Otherwise the needed info is here: https://source.puri.sm/Librem5/firmware-tps6598x-nonfree/-/tree/master

I don’t have a USB-C port on my computer, so I had to use a USB-C Male to USB-A Male cable that I had lying around (and that I connected directly into a USB 3.0 port on my computer). I would suppose that the update procedure might try to make the most limited demands on the USB port but I didn’t push it (e.g. by trying a USB 2.0 port or by trying to do it through a hub).

While connected for update, the Librem 5 showed up with lsusb as:

Bus 999 Device 999: ID 1fc9:012b NXP Semiconductors i.MX 8M Dual/8M QuadLite/8M Quad Serial Downloader

where obviously the bus number and device number will be different on your computer.

The update failed (harmlessly?) the first time due to not running the script as root (and the Purism doco doesn’t specifically mention this). The reasonable error was:

Fail Failure open usb device,Try sudo uuu

Maybe a udev rule on my computer would avoid that problem but I don’t anticipate doing this very often so couldn’t be bothered, so sudo ... it is.

After the update, and rebooting the phone, the above cat command gives


which I took to mean 0.2.0 - so that looks like winning!


Any specific improvement(s) you expect to get from doing that? Do you notice any difference afterwards other than the new firmware version number?


I was wondering whether anyone would ask. I had two motivations.

  1. Charging through my dock doesn’t work properly. I figured that before putting the dock in a drawer and spending money on another dock, it would be best to test again with the latest firmware.
  2. I want to play around with backup via Jumpdrive, so I need to have uuu installed / built anyway.